Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Янв 2017, 02:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчёты  (Прочитано 742 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vjacheslav

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-24
  • Сайт: 
  • Профессия: Ученик 1С
Отчёты
« Первое сообщение: 24 Ноя 2015, 15:24 »
Написал форму для формирования отчёта, но, после начала формирования расход материалов идёт не со склада а с <>. подскажите пожалуйста в чём проблема.


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Отчёты
« Ответ #1: 24 Ноя 2015, 15:34 »
В движениях по регистру склад не указан

Оффлайн vjacheslav

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-24
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #2: 24 Ноя 2015, 16:04 »
В движениях по регистру склад не указан

Если я правильно понимаю, то склад указан.. но проблема сохраняется

Оффлайн Kironten

  • *****
  • Сообщений: 718
  • РЕПУТАЦИЯ: 154
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #3: 24 Ноя 2015, 16:25 »
В движениях по регистру склад не указан

Если я правильно понимаю, то склад указан.. но проблема сохраняется

Т.е. мало того, что вы значение склада присваиваете измерению номенклатура, так вы еще и 2 вида движения пытаетесь сделать в одной проводке...
Жесть...

Оффлайн vjacheslav

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-24
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #4: 24 Ноя 2015, 16:41 »
В движениях по регистру склад не указан

Если я правильно понимаю, то склад указан.. но проблема сохраняется

Т.е. мало того, что вы значение склада присваиваете измерению номенклатура, так вы еще и 2 вида движения пытаетесь сделать в одной проводке...
Жесть...
Подскажите пожалуйста, как необходимо сделать...
Добавлено: 24 Ноя 2015, 17:15

В движениях по регистру склад не указан

Если я правильно понимаю, то склад указан.. но проблема сохраняется

Цитировать
Рейтинг@Mail.ru
Т.е. мало того, что вы значение склада присваиваете измерению номенклатура, так вы еще и 2 вида движения пытаетесь сделать в одной проводке...
Жесть...
Подскажите пожалуйста, как необходимо сделать...
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиМатериалов Расход
Движения.ОстаткиМатериалов.Записывать = Истина;
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Склад = Склады;
Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
так тоже не получается..

Последний раз редактировалось: vjacheslav; 24 Ноя 2015, 17:15. Причина: Объединение сообщений

Оффлайн Kironten

  • *****
  • Сообщений: 718
  • РЕПУТАЦИЯ: 154
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #5: 24 Ноя 2015, 17:46 »
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиМатериалов Расход
Движения.ОстаткиМатериалов.Записывать = Истина;
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Склад = Склады;
                Движение.Материалы = ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Отчёты
« Ответ #6: 24 Ноя 2015, 17:47 »
покажите скрин документа в предприятии

Оффлайн vjacheslav

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-24
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #7: 24 Ноя 2015, 17:58 »
покажите скрин документа в предприятии

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Отчёты
« Ответ #8: 24 Ноя 2015, 18:02 »
Ок. Дубль 2. Покажите пожалуйста скрин документа в предприятии,а не в конфигураторе, где видно все заполненные данные.

Оффлайн vjacheslav

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-24
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчёты
« Ответ #9: 24 Ноя 2015, 18:09 »
Ок. Дубль 2. Покажите пожалуйста скрин документа в предприятии,а не в конфигураторе, где видно все заполненные данные.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
crow1983
37 Сообщений
alexandr_ll
27 Сообщений
LexaK
24 Сообщений
sertak sertak
22 Сообщений
BuhRust
19 Сообщений
Vzonder
18 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal