Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 04:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод "ВыбратьЭлемент"  (Прочитано 806 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Понял, в чем проблема. Надо естественно использовать данный метод на клиенте :zebzdr::D

Оффлайн Kironten

  • *****
  • Сообщений: 712
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало

Синтаксис:
ВыбратьЭлемент(<Заголовок>, <Элемент>)
...
Доступность:
Тонкий клиент, веб-клиент, толстый клиент.


Теги:
 

Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 938
Последний ответ 06 Июн 2016, 11:54
от vitasw
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3796
Последний ответ 25 Ноя 2008, 11:07
от DDD
Организации смогут самостоятельно решать метод формирования резерва на отпускные

Автор newsРаздел Новости

Ответов: 0
Просмотров: 572
Последний ответ 15 Дек 2014, 13:10
от news
Бесплатная конференция «Отчетность за I полугодие: актуальные вопросы подготовки и требования законодательства"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1397
Последний ответ 15 Июн 2014, 18:16
от mixqn
Оптимизация чтения DBF файлов, внешний источник или метод XBase

Автор tepliymРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 447
Последний ответ 02 Сен 2015, 11:56
от tepliym

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
crow1983
31 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
26 Сообщений
sertak sertak
23 Сообщений
BuhRust
18 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
16 Сообщений

* Кто онлайн

  • Точка Гостей: 198
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal