Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 19:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод "ВыбратьЭлемент"  (Прочитано 1309 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Понял, в чем проблема. Надо естественно использовать данный метод на клиенте :zebzdr::D

Онлайн Kironten

  • *****
  • Сообщений: 818
  • РЕПУТАЦИЯ: 173
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало

Синтаксис:
ВыбратьЭлемент(<Заголовок>, <Элемент>)
...
Доступность:
Тонкий клиент, веб-клиент, толстый клиент.


Теги:
 

Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1962
Последний ответ 13 Июн 2017, 12:17
от Whisper
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4087
Последний ответ 25 Ноя 2008, 11:07
от DDD
Бесплатная конференция «Отчетность за I полугодие: актуальные вопросы подготовки и требования законодательства"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1517
Последний ответ 15 Июн 2014, 18:16
от mixqn
Организации смогут самостоятельно решать метод формирования резерва на отпускные

Автор newsРаздел Новости

Ответов: 0
Просмотров: 681
Последний ответ 15 Дек 2014, 13:10
от news
Конфиг ЗиК Гос 3.1 Когда нажим на стаж вых ошибка - Метод не найден на сервере

Автор Рашид777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 226
Последний ответ 12 Мар 2017, 22:30
от Рашид777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
79 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
LexaK
23 Сообщений
Dethmontt Dethmontt
22 Сообщений

* Кто онлайн

  • Точка Гостей: 426
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal