Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Ноя 2017, 02:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод "ВыбратьЭлемент"  (Прочитано 1690 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Понял, в чем проблема. Надо естественно использовать данный метод на клиенте :zebzdr::D

Оффлайн Kironten

  • *****
  • Сообщений: 891
  • РЕПУТАЦИЯ: 184
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало

Синтаксис:
ВыбратьЭлемент(<Заголовок>, <Элемент>)
...
Доступность:
Тонкий клиент, веб-клиент, толстый клиент.


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 252
Последний ответ 21 Сен 2017, 10:33
от Insider
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2738
Последний ответ 13 Июн 2017, 12:17
от Whisper
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4282
Последний ответ 25 Ноя 2008, 11:07
от DDD
Организации смогут самостоятельно решать метод формирования резерва на отпускные

Автор newsРаздел Новости

Ответов: 0
Просмотров: 734
Последний ответ 15 Дек 2014, 13:10
от news
Конфиг ЗиК Гос 3.1 Когда нажим на стаж вых ошибка - Метод не найден на сервере

Автор Рашид777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 309
Последний ответ 12 Мар 2017, 22:30
от Рашид777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
MuI_I_Ika MuI_I_Ika
96 Сообщений
oleg-x
67 Сообщений
alex0402
66 Сообщений
ilyay ilyay
58 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
BuhRust
19 Сообщений
Golickoff Golickoff
16 Сообщений

* Кто онлайн

  • Точка Гостей: 146
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal