Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 09:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод "ВыбратьЭлемент"  (Прочитано 975 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Понял, в чем проблема. Надо естественно использовать данный метод на клиенте :zebzdr::D

Оффлайн Kironten

  • *****
  • Сообщений: 766
  • РЕПУТАЦИЯ: 164
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 8.3.6.1977.
Использую метод "ВыбратьЭлемент" списка значений.
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
СЗ = Новый СписокЗначений;
СЗ.Добавить(1);
СЗ.Добавить(2);
СЗ.Добавить(3);
ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
КонецПроцедуры
Выскакивает ошибка
{Форма.Форма.Форма(13)}: Ошибка при вызове метода контекста (ВыбратьЭлемент)
   ВыбранныйЭлемент = СЗ.ВыбратьЭлемент("выберите элемент");
по причине:
Неудачная попытка создания окна

Что не так делаю? Вроде все так, в 8.2 все прекрасно работало

Синтаксис:
ВыбратьЭлемент(<Заголовок>, <Элемент>)
...
Доступность:
Тонкий клиент, веб-клиент, толстый клиент.


Теги:
 

Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1260
Последний ответ 06 Июн 2016, 11:54
от vitasw
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3888
Последний ответ 25 Ноя 2008, 11:07
от DDD
Бесплатная конференция «Отчетность за I полугодие: актуальные вопросы подготовки и требования законодательства"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1438
Последний ответ 15 Июн 2014, 18:16
от mixqn
Организации смогут самостоятельно решать метод формирования резерва на отпускные

Автор newsРаздел Новости

Ответов: 0
Просмотров: 609
Последний ответ 15 Дек 2014, 13:10
от news
Конфиг ЗиК Гос 3.1 Когда нажим на стаж вых ошибка - Метод не найден на сервере

Автор Рашид777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 102
Последний ответ 12 Мар 2017, 22:30
от Рашид777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
117 Сообщений
Norfolk
52 Сообщений
MuI_I_Ika MuI_I_Ika
50 Сообщений
LexaK
46 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 798
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal