Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Апр 2018, 22:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с преобразованием из текста в число  (Прочитано 1062 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Пайко Александр

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-21
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день.
Не могу преобразовать текст в число. В переменной Выс хранится строка "210" (смотрел в отладчике), но не могу в реквизит Высота занести это значение, так как высота (реквизит числовой 15,2), в система выдает сообщение преобразование к типу число не может быть выполнено.
Код такой.
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
СпрНоменклатура = Справочники.Номенклатура;
Выборка = Справочники.Номенклатура.ВыбратьИерархически();
Пока Выборка.Следующий() цикл
Если НЕ Выборка.ЭтоГруппа и Выборка.Код="00000000016"  тогда
Наименование = Выборка.Наименование;
Выс =Сред(СокрЛ(Выборка.Наименование),1,3);
Код = Выборка.Код;                                    НайденныйЭлемент = СпрНоменклатура.НайтиПоКоду(Код);
ТекущийОбъект =НайденныйЭлемент.ПолучитьОбъект();
ТекущийОбъект.Высота = 0+Число(Выс);
ТекущийОбъект.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
В какой строке ошибка?
И что у вас находится в выборке.Наименование?


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4630
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5886
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6221
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5020
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2182
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
206 Сообщений
alex0402
73 Сообщений
AIFrame AIFrame
69 Сообщений
oleg-x
50 Сообщений
alexandr_ll
40 Сообщений
BuhRust
23 Сообщений
pavl_vs
22 Сообщений
KOI8-R
20 Сообщений
wise wise
15 Сообщений
Sheriff
13 Сообщений

* Кто онлайн

  • Точка Гостей: 285
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal