Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 15:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть программно дополнительный отчет  (Прочитано 1740 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! УТ 11.1.10
Была похожая тема но по внутренней обработке,по нажатии на кнопку в форме,сделал так
ПараметрыОткрытия = Новый Структура(
            "Отбор, КлючНастроек, СформироватьПриОткрытии",
            Новый Структура("Партнер", Объект.Партнер),
          "Партнер",
          ИСТИНА);
ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру", ПараметрыОткрытия);

А как отрыть дополнительный отчет из дополнительных обработок? и передать в него Контрагента ?
И второй вопрос попутно, возможно ли открыть дополнительный отчет из формы типового документа не прибегая к вмешательству в типовой функционал? на подобии внешней печатной формы.


Оффлайн Дмитрий@

  • *****
  • Сообщений: 731
  • РЕПУТАЦИЯ: 133
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Что то наподобе этого
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Помещаем обработку во временном хранилище
    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
   
    // Откроем форму подключенной внешней обработки
    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");
КонецПроцедуры
&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)
    Возврат ВнешниеОбработки.Подключить(АдресХранилища);
КонецФункции
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Это из файла,я уже всю голову сломал...решил внешний отчет включить в состав конфигурации,но и тут проблема...

На форме документа кнопка ,по кнопке мне нужно открыть отчет и передать в отчет параметр с формы документа..
&НаКлиенте
Процедура ДокументыПоПартнеру(Элемент)
 


 ПараметрыОткрытия = Новый Структура(
            "Отбор, КлючНастроек, СформироватьПриОткрытии",
            Новый Структура("Контрагент", Объект.Контрагент),
           "Контрагент",
            ИСТИНА);
 ОткрытьФорму("Отчет.пмРеестрДокументов.Форма", ПараметрыОткрытия);


КонецПроцедуры

Отчет открывается,формируется,но параметр Контрагент не передается...
Отчет на СКД,без формы..
Добавлено: 23 Ноя 2015, 11:56

Понимаю что это не обработка и надо использовать компановку данных но не знаю как..
Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Контрагент");

Последний раз редактировалось: SkyNetYar; 23 Ноя 2015, 11:56. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Покажите скрин панели отборов в отчете из конфигуратора.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Вот..

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
1. А что за слово "Обычное"?
2.Галочку по активности отбора лучше снять

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
1. А что за слово "Обычное"?
2.Галочку по активности отбора лучше снять
Снял,результат тот же..Теперь он формирует ,но контрагента берет из предыдущей настройки,а не переданный из формы..
Обычное - Применение ,думаю оно тут не причем..
Когда нажимаешь в поле выбора Контрагента он спрашивает из какого справочника брать данные,из Партнеров или из Контрагентов,может в этом дело ?
Добавлено: 23 Ноя 2015, 12:55

Вот если режим редактирования пользовательских настроек поставить "обычный" то отчет формируется без отбора по всем контрагентам,но если посмотреть в расширенные настройки отчета то там контрагент как раз таки подставляется правильно,из документа!
Добавлено: 23 Ноя 2015, 13:05

Получается что значение контрагент передается нормально,но отчет формируется с пустым значением..

Последний раз редактировалось: SkyNetYar; 23 Ноя 2015, 13:05. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В конфигураторе в отборе для контрагента установите пустое значение нужного типа.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Что то я запутался,вот на скринах я описал всю ситуацию ,отбор отчета работает если его делать в структуре.
Как передать отбор программно в структуру ?
Добавлено: 23 Ноя 2015, 16:55

Ну что никто не поможет?
Документ передает в Параметр а надо в Отбор
Последний скрин..
Добавлено: 23 Ноя 2015, 17:21

ВСЕ разобрался,Спасибо всем кто старался помочь =)
Дело было в отчете,накосячил когда объединял в условиях запросов ...

Последний раз редактировалось: SkyNetYar; 23 Ноя 2015, 17:21. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
82 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal