Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Окт 2017, 23:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Реквизит формы документа не заполняется  (Прочитано 860 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kaidj

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток Уважаемые Гуру! Помогите, встрял
Задача такая. Имеется табличная часть "Товары" Формы Документа "Продажа"
Её реквизиты:
 - Номенклатура (СправочникСсылка.Номенклатура)
 - Упаковка (СправочникСсылка.Упаковка)
 - Количество (Число)
 - ОбъемУпаковки (Число)
 - Объем (Число)
Нужно при заполнении "Номенклатура", "Упаковка", "Количество" что бы автоматически заполнялись реквизиты:
 - "ОбъемУпаковки" (из Справочник.Упаковка реквизит "Объем")
 - "Объем" (умножить автоматически заполненый реквизит "ОбъемУпаковки" на заполненый реквизит "Количество")
в общем я под эту задачу наваял такой "код":

&НаКлиенте
Процедура ТоварыУпаковкаПриИзменении(Элемент)
   Строка = Элементы.Товары.ТекущиеДанные;
   ЗаполнениеТабличнойЧастиТовары(Строка.Упаковка);
КонецПроцедуры

&НаСервере
Процедура ЗаполнениеТабличнойЧастиТовары (Упаковка)
   Запрос = новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   Упаковка.Объем
                  |ИЗ
                  |   Справочник.Упаковка КАК Упаковка
               |ГДЕ
               |   Упаковка.Наименование = &Упаковка";
   Запрос.УстановитьПараметр("Упаковка",Упаковка);
   Результат = Запрос.Выполнить();
   Выборка = Результат.Выгрузить();
      Для Каждого СтрокаВыборки Из Выборка Цикл
            НоваяСтрока = Объект.Товары.Добавить();
            НоваяСтрока.ОбъемУпаковки = СтрокаВыборки.Объем;
      КонецЦикла
КонецПроцедуры

в итоге после сиих манипуляций, ошибки не выдает, ну и не заполняет ничего, что делаю не так?


Оффлайн Natain14

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
1) У вас в ТЧ Упаковка - это строковый тип,а не ссылочный? если ссылочный, то не понятно, зачем вы проверяете в запросе, что Упаковка.Наименование = &Упаковка
2) Вы в цикле выборки добавляете новые строки, а не заполняете значение в имеющихся

Запросом можно, наверное, сделать так: в запросе взять таблицу Товары документа Продажа и к ней присоединить данные из справочника Упаковка.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
из значения Упаковки текущей строки достаточно получить реквизит "Объем" и присвоить его соответствующему реквизиту текущей строки.

эта элементарная задача разбирается на первых страницах Радченко!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Цитировать
Реквизит формы документа не заполняется
Вы пытаетесь заполнить не то что нужно, заполнять нужно не реквизит а значение.
 НоваяСтрока = Объект.Товары.Добавить();
Зачем новая строка? Разве нужно не в текущую?
 
Цитировать
в итоге после сиих манипуляций, ошибки не выдает
1с пока не научилась смысловые ошибки определять
 
Цитировать
ну и не заполняет ничего, что делаю не так?
скорее не делаете:
 
НоваяСтрока.Записать();


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4376
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15389
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4041
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 503
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7558
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
90 Сообщений
alex0402
54 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
44 Сообщений
AIFrame
40 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
BuhRust
14 Сообщений
AsadRoman
13 Сообщений

* Кто онлайн

  • Точка Гостей: 290
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal