Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 23:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с условием, если ТабличнаяЧасть пустая...  (Прочитано 883 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mila1231

  • ***
  • Сообщений: 139
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Помогите, если у меня пустая табличная часть, мне нужно, чтоб выводилось сообщение, не могу правильно условие сообразить, вот сам код....
Процедура Кнопка1Нажатие(Элемент)
// Вставить содержимое обработчика.
ТекДанные = ЭлементыФормы.приборы_принятые.ТекущиеДанные ;
Если ТекДанные  = null тогда
Сообщить ("Заполните табличную часть!")

 иначе
ПФорма = ПолучитьФорму ("Документ.Поверка_прибора.Форма.ФормаДокумента") ;
ПФорма.номер_прибора_пов = ТекДанные.Номер_прибора;
     Сообщить(ТекДанные.Номер_прибора);
ПФорма.Открыть();

 конецЕсли;
КонецПроцедуры

Т.е нужно если табличная часть не заполнено, т.е вообще пустое выводилось сообщение, а если выделен текущий объект, чтоб открывался новый документ, с условием туплю(((


Оффлайн pavl_vs

  • *****
  • Сообщений: 919
  • РЕПУТАЦИЯ: 145
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
mila1231, думаю ветвление надо писать именно для ТЧ (как я понимаю это "приборы_принятые"):
Если приборы_принятые.Количество() = 0 Тогда
    Сообщить ("Заполните табличную часть!")
Иначе
    // обработка не пустых данных
КонецЕсли;

Оффлайн mila1231

  • ***
  • Сообщений: 139
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
mila1231, думаю ветвление надо писать именно для ТЧ (как я понимаю это "приборы_принятые"):
Если приборы_принятые.Количество() = 0 Тогда
    Сообщить ("Заполните табличную часть!")
Иначе
    // обработка не пустых данных
КонецЕсли;

Это работает , но выполня счас условие, я поняля, что не правильно сама сформулировала вопрос.. а может подскажите, а если текущее поле не выбрано, т.е по сути.. я думала можно нулом обойтись.. т.е если поля табличной части заполнены,но ни одно из полей не выделено..  я думала добавить или
ТекДанные.Номер_прибора =null
Но как я поняла это не правильно....

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ТекДанные = ЭлементыФормы.приборы_принятые.ТекущиеДанные;
Если ТекДанные = Неопределено тогда

Null - больше в запросах применяется
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн pavl_vs

  • *****
  • Сообщений: 919
  • РЕПУТАЦИЯ: 145
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
mila1231, а здесь я бы использовал что-то типа ЗначениеЗаполнено(ТекДанные.Номер_прибора).

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
mila1231, а здесь я бы использовал что-то типа ЗначениеЗаполнено(ТекДанные.Номер_прибора).

получит модульную ошибку "поле объекта не обнаружено Номер_прибора"
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн pavl_vs

  • *****
  • Сообщений: 919
  • РЕПУТАЦИЯ: 145
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
получит модульную ошибку "поле объекта не обнаружено Номер_прибора"
С этим легко справиться - использовать не Текущие Данные, а ТекущуюСтроку (в #2 автор пишет о текущем поле).

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
pavl_vs, каждый понял что ей надо "в меру своей испорченности" ;)

mila1231, вы уж точно сформулируйте, что вам надо!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1516
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3516
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3807
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1661
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 178
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
65 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
alexandr_ll
33 Сообщений
LexaK
32 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal