Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 15:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись В Ворд  (Прочитано 1144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Ребята Привет) У меня вопрос по Сохранения в ворд) Запись в excel нормальная)А вот После записи в ворд файл выдает ошибку поврежденный файл что это может быть?)


Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Re: Запись В Ворд
« Ответ #1: 18 Ноя 2015, 09:33 »
Как записываете хоть?
Если я Вам помог, нажми - Спасибо!

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Re: Запись В Ворд
« Ответ #2: 18 Ноя 2015, 09:37 »
Как записываете хоть?

   
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
ДиалогОткрытияФайла.ПолноеИмяФайла = "Заявка";
ДиалогОткрытияФайла.Расширение = "xlsx";

ДиалогОткрытияФайла.Фильтр = "Файлы Microsoft Excel (*.xlsx)|*.xlsx|Файлы Microsoft Word (*.docx)|*.docx|Все файлы (*.*)|*.*";
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
Если ДиалогОткрытияФайла.Выбрать() тогда
ТабДок.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла,ТипФайлаТабличногоДокумента.XLSX);
КонецЕсли;


Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Re: Запись В Ворд
« Ответ #3: 18 Ноя 2015, 10:05 »
Проблема в том, что Вы всегда сохраняете файл в формате Excel в не зависимости от выбранного расширения в форме сохранения файла. Т.е. выбираете ".docx", но сохраняете его как ".xlsx" поэтому не можете открыть.
Первое что приходит в голову:
Если ДиалогОткрытияФайла.Выбрать() тогда
Если ДиалогОткрытияФайла.Расширение = "xlsx" Тогда //cохраняем в Excel
ТабДок.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла, ТипФайлаТабличногоДокумента.XLS);
ИначеЕсли ДиалогОткрытияФайла.Расширение = "docx" Тогда //сохраняем в Word
ТабДок.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла, ТипФайлаТабличногоДокумента.DOCX);
//можно еще набросать вариантов
КонецЕсли;
КонецЕсли;
Но для данного варианта очень плохо подходит фильтр
"|Все файлы (*.*)|*.*"
Его лучше исключить.
Если я Вам помог, нажми - Спасибо!

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Re: Запись В Ворд
« Ответ #4: 18 Ноя 2015, 10:34 »
Проблема в том, что Вы всегда сохраняете файл в формате Excel в не зависимости от выбранного расширения в форме сохранения файла. Т.е. выбираете ".docx", но сохраняете его как ".xlsx" поэтому не можете открыть.
Первое что приходит в голову:
Если ДиалогОткрытияФайла.Выбрать() тогда
Если ДиалогОткрытияФайла.Расширение = "xlsx" Тогда //cохраняем в Excel
ТабДок.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла, ТипФайлаТабличногоДокумента.XLS);
ИначеЕсли ДиалогОткрытияФайла.Расширение = "docx" Тогда //сохраняем в Word
ТабДок.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла, ТипФайлаТабличногоДокумента.DOCX);
//можно еще набросать вариантов
КонецЕсли;
КонецЕсли;
Но для данного варианта очень плохо подходит фильтр
"|Все файлы (*.*)|*.*"
Его лучше исключить.

Теперь После выбора фильтра в расширение записывается пустая строка))
Добавлено: 18 Ноя 2015, 10:48

Если поменять все на Word То записывает))Спасибо) дальше думаю разберусь)

Последний раз редактировалось: Пустовалов Артем; 18 Ноя 2015, 10:48. Причина: Объединение сообщений

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Re: Запись В Ворд
« Ответ #5: 18 Ноя 2015, 11:10 »
Пустовалов Артем, Удачи!
Если я Вам помог, нажми - Спасибо!


Теги:
 

Как понять запись ?(НачОстаток = Null,0,НачОстаток)

Автор olgahachnewРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2374
Последний ответ 07 Апр 2011, 17:38
от chuevsf
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12804
Последний ответ 11 Янв 2011, 10:04
от nomer13
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3401
Последний ответ 02 Фев 2014, 21:37
от LordWizard
Запись элемента справочника из модуля объекта другого справочника

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1246
Последний ответ 05 Май 2016, 09:29
от LexaK
При формир. "Книги покупок" в 1С УПП двойная запись в основ. книге и в доп.листе

Автор Dasha_Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4029
Последний ответ 14 Сен 2012, 09:36
от Dasha_

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal