Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 13:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ОткрытьФорму()  (Прочитано 1536 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! УТ 11.1
Есть документ,в документе кнопка на ней процедура:
&НаКлиенте
Процедура ДокументыПоПартнеру(Элемент)
ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру")
КонецПроцедуры

В обработке есть Параметр с СправочникСсылка.Партнеры
У Документа на форме есть реквизит Объект.Партнер с СправочникСсылка.Партнеры

Как передать этот параметр из документа в обработку ?


Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Re: ОткрытьФорму()
« Ответ #1: 16 Ноя 2015, 16:56 »
ПараметрыОткрытия = Новый Структура("Партнер ", Объект.Партнер);
ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру", ПараметрыОткрытия);

Далее в процедуре ПриСозданииНаСервере открываемой формы можете делать с параметром что угодно
Если я Вам помог, нажми - Спасибо!

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: ОткрытьФорму()
« Ответ #2: 16 Ноя 2015, 17:09 »
ПараметрыОткрытия = Новый Структура("Партнер ", Объект.Партнер);
ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру", ПараметрыОткрытия);

Далее в процедуре ПриСозданииНаСервере открываемой формы можете делать с параметром что угодно

Не передает :fdbsdfbsd:
В обработке есть команда,выглядит она вот так
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

ПараметрыФормы = Новый Структура(
"Отбор, КлючНастроек, СформироватьПриОткрытии",
Новый Структура("Партнер", ПараметрКоманды),
"Партнер",
Истина);

ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру",
ПараметрыФормы,
ПараметрыВыполненияКоманды.Источник,
ПараметрыВыполненияКоманды.Уникальность,
ПараметрыВыполненияКоманды.Окно);

КонецПроцедуры
Когда Обработка в режиме предприятия на форме есть поле Контрагент,когда открываешь в конфигураторе то этого поля нет..
Эта команда например срабатывает из Справочники.Партнеры , слева в панели,и открывает все документы по партнеру,мне нужно бы так же только из документа..

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Re: ОткрытьФорму()
« Ответ #3: 16 Ноя 2015, 17:12 »
Просмотрите что происходит в обработке ПриСозданииНаСервере на форме ДокументыПоПартнеру. Можете использовать данный код, но корректно обрабатывайте переданные значения.
Если я Вам помог, нажми - Спасибо!

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: ОткрытьФорму()
« Ответ #4: 17 Ноя 2015, 11:03 »
Прошелся отладчиком,и выяснил что если параметр "КлючНастроек" не передается то он Партнер устанавливается пустым..
Если Параметры.Свойство("КлючНастроек") И Не ПустаяСтрока(Параметры.КлючНастроек) Тогда

КлючНастроек = Параметры.КлючНастроек;

Иначе

КлючНастроек = "БезПартнера";

КонецЕсли;
Вот у меня всегда было Иначе КлючНастроек = "БезПартнера";
Сделал так..
ПараметрыОткрытия = Новый Структура(
            "Отбор, КлючНастроек, СформироватьПриОткрытии",
            Новый Структура("Партнер", Объект.Партнер),
            "Партнер",
            Истина);
ОткрытьФорму("Обработка.ДокументыПоПартнеруИСделке.Форма.ДокументыПоПартнеру", ПараметрыОткрытия);

И все как по маслу :)
Спасибо Вам добрый человек,натолкнули на правильный путь!(плюсанул)


Теги:
 

Заменить ОткрытьМодально() на ОткрытьФорму()

Автор ShaldrynРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2739
Последний ответ 15 Июл 2016, 16:31
от Golickoff
ОткрытьФорму

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 1220
Последний ответ 19 Июл 2015, 15:52
от 1cwiki

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
93 Сообщений
oleg-x
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 881
  • Точка Скрытых: 0
  • Точка Пользователей: 18
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal