Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Мар 2017, 13:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемые формы. Установить текущую строку в дереве на форме  (Прочитано 1496 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natain14

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2015-06-16
  • Сайт: 
Добрый день, помогите, пожалуйста, не могу установить текущую строку в дереве на форме:

ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
СтрокаРеквезита=ДеревоРезервов.НайтиПоИдентификатору(ТекущаяАктивнаяСтрока.ПолучитьИдентификатор());
.........
.........
.........
Элементы.ДеревоРезервов.ТекущаяСтрока=СтрокаРеквезита.ПолучитьИдентификатор();

Это последний вариант, уже всяко пробовала( :dfbsdfbsdf:


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
По приведенному коду получается, что операции выполняются над одной и той же строкой.

Оффлайн Natain14

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2015-06-16
  • Сайт: 
Спасибо, поняла в чем была проблема :zebzdr:

Решила так:
ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
....
....
....
УстановитьТекущуюСтроку(ДеревоРезервов,ТекущаяАктивнаяСтрока.КлючСвязи);



&НаКлиенте
Процедура УстановитьТекущуюСтроку(ДеревоРезервовПередачи, КлючСвязи)
   
   Для каждого ТекущаяСтрока Из ДеревоРезервовПередачи.ПолучитьЭлементы() Цикл
      Если ТекущаяСтрока.КлючСвязи=КлючСвязи Тогда      
          Элементы.ДеревоРезервов.ТекущаяСтрока=ТекущаяСтрока.ПолучитьИдентификатор();
          Возврат;
       иначе
           УстановитьТекущуюСтроку(ТекущаяСтрока, КлючСвязи);      
      КонецЕсли;      
   КонецЦикла;   
   
КонецПроцедуры


Теги:
 

Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4134
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2846
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3967
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 133
Последний ответ 10 Мар 2017, 21:00
от Жанна
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1105
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
148 Сообщений
alex0402
116 Сообщений
Norfolk
51 Сообщений
LexaK
48 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
AsadRoman
22 Сообщений
друган
21 Сообщений
SlimShady
19 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений

* Кто онлайн

  • Точка Гостей: 889
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal