Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Ноя 2017, 23:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемые формы. Установить текущую строку в дереве на форме  (Прочитано 2622 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natain14

  • **
  • Сообщений: 53
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
Добрый день, помогите, пожалуйста, не могу установить текущую строку в дереве на форме:

ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
СтрокаРеквезита=ДеревоРезервов.НайтиПоИдентификатору(ТекущаяАктивнаяСтрока.ПолучитьИдентификатор());
.........
.........
.........
Элементы.ДеревоРезервов.ТекущаяСтрока=СтрокаРеквезита.ПолучитьИдентификатор();

Это последний вариант, уже всяко пробовала( :dfbsdfbsdf:


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
По приведенному коду получается, что операции выполняются над одной и той же строкой.

Оффлайн Natain14

  • **
  • Сообщений: 53
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
Спасибо, поняла в чем была проблема :zebzdr:

Решила так:
ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
....
....
....
УстановитьТекущуюСтроку(ДеревоРезервов,ТекущаяАктивнаяСтрока.КлючСвязи);



&НаКлиенте
Процедура УстановитьТекущуюСтроку(ДеревоРезервовПередачи, КлючСвязи)
   
   Для каждого ТекущаяСтрока Из ДеревоРезервовПередачи.ПолучитьЭлементы() Цикл
      Если ТекущаяСтрока.КлючСвязи=КлючСвязи Тогда      
          Элементы.ДеревоРезервов.ТекущаяСтрока=ТекущаяСтрока.ПолучитьИдентификатор();
          Возврат;
       иначе
           УстановитьТекущуюСтроку(ТекущаяСтрока, КлючСвязи);      
      КонецЕсли;      
   КонецЦикла;   
   
КонецПроцедуры


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 254
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4764
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3378
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4926
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 557
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
MuI_I_Ika MuI_I_Ika
87 Сообщений
oleg-x
71 Сообщений
ilyay ilyay
68 Сообщений
alex0402
62 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Golickoff Golickoff
24 Сообщений
Sy4a
24 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal