Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 16:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемые формы. Установить текущую строку в дереве на форме  (Прочитано 1768 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natain14

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2015-06-16
  • Сайт: 
Добрый день, помогите, пожалуйста, не могу установить текущую строку в дереве на форме:

ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
СтрокаРеквезита=ДеревоРезервов.НайтиПоИдентификатору(ТекущаяАктивнаяСтрока.ПолучитьИдентификатор());
.........
.........
.........
Элементы.ДеревоРезервов.ТекущаяСтрока=СтрокаРеквезита.ПолучитьИдентификатор();

Это последний вариант, уже всяко пробовала( :dfbsdfbsdf:


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
По приведенному коду получается, что операции выполняются над одной и той же строкой.

Оффлайн Natain14

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2015-06-16
  • Сайт: 
Спасибо, поняла в чем была проблема :zebzdr:

Решила так:
ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
....
....
....
УстановитьТекущуюСтроку(ДеревоРезервов,ТекущаяАктивнаяСтрока.КлючСвязи);



&НаКлиенте
Процедура УстановитьТекущуюСтроку(ДеревоРезервовПередачи, КлючСвязи)
   
   Для каждого ТекущаяСтрока Из ДеревоРезервовПередачи.ПолучитьЭлементы() Цикл
      Если ТекущаяСтрока.КлючСвязи=КлючСвязи Тогда      
          Элементы.ДеревоРезервов.ТекущаяСтрока=ТекущаяСтрока.ПолучитьИдентификатор();
          Возврат;
       иначе
           УстановитьТекущуюСтроку(ТекущаяСтрока, КлючСвязи);      
      КонецЕсли;      
   КонецЦикла;   
   
КонецПроцедуры


Теги:
 

Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4299
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2974
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4224
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 298
Последний ответ 10 Мар 2017, 21:00
от Жанна
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1328
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
wise wise
76 Сообщений
MuI_I_Ika MuI_I_Ika
56 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
29 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 850
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal