Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2017, 01:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемые формы. Установить текущую строку в дереве на форме  (Прочитано 1270 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natain14

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2015-06-16
  • Сайт: 
Добрый день, помогите, пожалуйста, не могу установить текущую строку в дереве на форме:

ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
СтрокаРеквезита=ДеревоРезервов.НайтиПоИдентификатору(ТекущаяАктивнаяСтрока.ПолучитьИдентификатор());
.........
.........
.........
Элементы.ДеревоРезервов.ТекущаяСтрока=СтрокаРеквезита.ПолучитьИдентификатор();

Это последний вариант, уже всяко пробовала( :dfbsdfbsdf:

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
По приведенному коду получается, что операции выполняются над одной и той же строкой.

Оффлайн Natain14

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2015-06-16
  • Сайт: 
Спасибо, поняла в чем была проблема :zebzdr:

Решила так:
ТекущаяАктивнаяСтрока = Элементы.ДеревоРезервов.ТекущиеДанные;
....
....
....
УстановитьТекущуюСтроку(ДеревоРезервов,ТекущаяАктивнаяСтрока.КлючСвязи);



&НаКлиенте
Процедура УстановитьТекущуюСтроку(ДеревоРезервовПередачи, КлючСвязи)
   
   Для каждого ТекущаяСтрока Из ДеревоРезервовПередачи.ПолучитьЭлементы() Цикл
      Если ТекущаяСтрока.КлючСвязи=КлючСвязи Тогда      
          Элементы.ДеревоРезервов.ТекущаяСтрока=ТекущаяСтрока.ПолучитьИдентификатор();
          Возврат;
       иначе
           УстановитьТекущуюСтроку(ТекущаяСтрока, КлючСвязи);      
      КонецЕсли;      
   КонецЦикла;   
   
КонецПроцедуры


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 264
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3587
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2569
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3549
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
В при печати формы не заполняется поле "заказчик"

Автор senqsРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2803
Последний ответ 02 Окт 2013, 12:03
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
74 Сообщений
alexandr_ll
37 Сообщений
LexaK
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
17 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal