Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Авг 2017, 10:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите !!! Условие ОТБОРА  (Прочитано 380 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн claberRZN

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Конфиг УТ.... Совсем мне мозг сломал отбор ((( В скд получается а вот в дереве значений никак...


Как сделать что бы выводил только Поступление и Возврат !!! Сейчас выводит Поступление, Поступление + Возврат..


Помоги  пожалуйста !!!! :trhregerhg:

   Дерево = Новый ДеревоЗначений;
      
      Дерево.Колонки.Добавить("Дата",,"Дата");
      Дерево.Колонки.Добавить("Номер",,"Номер");
      Дерево.Колонки.Добавить("СуммаДокумента",,"СуммаДокумента");
      Дерево.Колонки.Добавить("Организация",,"Организация");
      Дерево.Колонки.Добавить("Контрагент",,"Контрагент");
      //Дерево.Колонки.Добавить("Ссылка",,"Ссылка");
      
      
      
      
      ЗапросВозвратПоступление  = Новый Запрос;
      ЗапросВозвратПоступление.УстановитьПараметр("НачалоПериода",НачалоПериода);
      ЗапросВозвратПоступление.УстановитьПараметр("КонецПериода",КонецДня(КонецПериода));
      ЗапросВозвратПоступление.УстановитьПараметр("Организация",Организации );
      ЗапросВозвратПоступление.УстановитьПараметр("Контрагент", Контрагент);
      ЗапросВозвратПоступление.Текст = ("ВЫБРАТЬ РАЗЛИЧНЫЕ
                                        |   ПоступлениеТоваровУслугТовары.Ссылка КАК ДокументПоступления
                                        |ПОМЕСТИТЬ ВТДокументыПоступления
                                        |ИЗ
                                        |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
                                        |ГДЕ
                                        |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
                                        |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен = ИСТИНА
                                        |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
                                        |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Организация = &Организация)
                                        |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
                                        |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Контрагент = &Контрагент)
                                        |
                                        |СГРУППИРОВАТЬ ПО
                                        |   ПоступлениеТоваровУслугТовары.Ссылка
                                        |;
                                        |
                                        |////////////////////////////////////////////////////////////////////////////////
                                        |ВЫБРАТЬ РАЗЛИЧНЫЕ
                                        |   ВозвратТоваровПоставщикуТовары.Ссылка КАК ДокументВозврата,
                                        |   ВозвратТоваровПоставщикуТовары.ДокументПоступления
                                        |ПОМЕСТИТЬ ВТДокументыВозврата
                                        |ИЗ
                                        |   Документ.ВозвратТоваровПоставщику.Товары КАК ВозвратТоваровПоставщикуТовары
                                        |ГДЕ
                                        |   ВозвратТоваровПоставщикуТовары.Ссылка.Дата >= &НачалоПериода
                                        |   И ВозвратТоваровПоставщикуТовары.Ссылка.Проведен = ИСТИНА
                                        |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
                                        |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Организация = &Организация)
                                        |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
                                        |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Контрагент = &Контрагент)
                                        |;
                                        |
                                        |////////////////////////////////////////////////////////////////////////////////
                                        |ВЫБРАТЬ
                                        |   ВТДокументыПоступления.ДокументПоступления КАК ДокументПоступления,
                                        |   ВТДокументыПоступления.ДокументПоступления.Дата КАК ДокументПоступленияДата,
                                        |   ВТДокументыПоступления.ДокументПоступления.Номер КАК ДокументПоступленияНомер,
                                        |   ВТДокументыПоступления.ДокументПоступления.СуммаДокумента КАК ДокументПоступленияСуммаДокумента,
                                        |   ВТДокументыПоступления.ДокументПоступления.Организация КАК ДокументПоступленияОрганизация,
                                        |   ВТДокументыПоступления.ДокументПоступления.Контрагент КАК ДокументПоступленияКонтрагент,
                                        |   ВТДокументыВозврата.ДокументВозврата,
                                        |   ВТДокументыВозврата.ДокументВозврата.Дата КАК ДокументВозвратаДата,
                                        |   ВТДокументыВозврата.ДокументВозврата.Номер КАК ДокументВозвратаНомер,
                                        |   ВТДокументыВозврата.ДокументВозврата.СуммаДокумента КАК ДокументВозвратаСуммаДокумента,
                                        |   ВТДокументыВозврата.ДокументВозврата.Организация КАК ДокументВозвратаОрганизация,
                                        |   ВТДокументыВозврата.ДокументВозврата.Контрагент КАК ДокументВозвратаКонтрагент
                                        |ИЗ
                                        |   ВТДокументыПоступления КАК ВТДокументыПоступления
                                        |      ЛЕВОЕ СОЕДИНЕНИЕ ВТДокументыВозврата КАК ВТДокументыВозврата
                                        |      ПО ВТДокументыПоступления.ДокументПоступления = ВТДокументыВозврата.ДокументПоступления
                                        |
                                        |УПОРЯДОЧИТЬ ПО
                                        |   ДокументПоступленияДата,
                                        |   ДокументВозвратаДата
                                        |ИТОГИ ПО
                                        |   ДокументПоступления");
      
      Результат = ЗапросВозвратПоступление.Выполнить();
      
      РезультатЗапроса = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      
      
      Пока РезультатЗапроса.Следующий() Цикл
         НоваяСтрокаУровеньПоступление                = Дерево.Строки.Добавить();
         
         НоваяСтрокаУровеньПоступление.Дата             = РезультатЗапроса.ДокументПоступленияДата;
         НоваяСтрокаУровеньПоступление.Номер            = РезультатЗапроса.ДокументПоступленияНомер;
         НоваяСтрокаУровеньПоступление.СуммаДокумента   = РезультатЗапроса.ДокументПоступленияСуммаДокумента;
         НоваяСтрокаУровеньПоступление.Организация      = РезультатЗапроса.ДокументПоступленияОрганизация;
         НоваяСтрокаУровеньПоступление.Контрагент      = РезультатЗапроса.ДокументПоступленияКонтрагент;
         //НоваяСтрокаУровеньПоступление.Ссылка          = РезультатЗапроса.ДокументПоступления;
         ВыборкаДокументыВозврат = РезультатЗапроса.Выбрать();
         Пока ВыборкаДокументыВозврат.Следующий() Цикл
            
            Если Не ЗначениеЗаполнено(ВыборкаДокументыВозврат.ДокументВозврата) Тогда
               Продолжить;
            КонецЕсли;
            
            
            НоваяСтрокаУровеньВозврат                = НоваяСтрокаУровеньПоступление.Строки.Добавить();
            //НоваяСтрокаУровеньВозврат.Ссылка          = ВыборкаДокументыВозврат.ДокументВозврата;
            НоваяСтрокаУровеньВозврат.Дата             = ВыборкаДокументыВозврат.ДокументВозвратаДата;
            НоваяСтрокаУровеньВозврат.Номер            = ВыборкаДокументыВозврат.ДокументВозвратаНомер;
            НоваяСтрокаУровеньВозврат.СуммаДокумента   = ВыборкаДокументыВозврат.ДокументВозвратаСуммаДокумента;
            НоваяСтрокаУровеньВозврат.Организация      = ВыборкаДокументыВозврат.ДокументВозвратаОрганизация;
            НоваяСтрокаУровеньВозврат.Контрагент      = ВыборкаДокументыВозврат.ДокументВозвратаКонтрагент;
            
         КонецЦикла;     
      КонецЦикла; 
      
      ЭлементыФормы.Дерево.СоздатьКолонки();
      ЭлементыФормы.Дерево.ГоризонтальныеЛинии = Истина;ЭлементыФормы.Дерево.ВертикальныеЛинии = Истина;
      ОбойтиУровеньДерева(Дерево.Строки);
      
      
   КонецЕсли;
 


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Н-да....
1. Зачем выборка из табличной части, если не используете ни одно реквизита из табличной части
2.
                     |   ВозвратТоваровПоставщикуТовары.Ссылка КАК ДокументВозврата,
                                        |   ВозвратТоваровПоставщикуТовары.ДокументПоступления
Что выбираете - то и получаете.


Теги:
 

Не формируется штрих код.Пишет ошибочный штрих код в тексте кода и подставляет стандартный штрих код.Подскажите как сформировать штрих код состоящий из букв и цифр?

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 459
Последний ответ 31 Янв 2017, 14:02
от Kironten
Подскажите в документе "РасходнаяНакладная"

Автор n24nРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2103
Последний ответ 05 Мар 2011, 20:55
от n24n
Подскажите как реализовать "планинг"?

Автор cannabis_86Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 20 Июн 2011, 10:29
от cska-fanat-kz
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1741
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1 страница - портрет, 2 страница - ландшафт Подскажите как сделать?

Автор YaposhaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4306
Последний ответ 05 Апр 2012, 11:37
от Yaposha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
129 Сообщений
alex0402
60 Сообщений
AIFrame
46 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
27 Сообщений
pavl_vs
26 Сообщений
Kironten
24 Сообщений
Александр Лахтин Александр Лахтин
18 Сообщений
magnifico61
16 Сообщений
BuhRust
15 Сообщений

* Кто онлайн

  • Точка Гостей: 192
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal