Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 07:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как Программо Скрыть Колонку в Дереве Значения!!!!  (Прочитано 1501 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн claberRZN

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Люди а как программно скрыть колонку Ссылка !!! Вот кусок запроса



Дерево = Новый ДеревоЗначений;
      
      Дерево.Колонки.Добавить("Дата",,"Дата");
      Дерево.Колонки.Добавить("Номер",,"Номер");
      Дерево.Колонки.Добавить("СуммаДокумента",,"СуммаДокумента");
      Дерево.Колонки.Добавить("Организация",,"Организация");
      Дерево.Колонки.Добавить("Контрагент",,"Контрагент");
      Дерево.Колонки.Добавить("Ссылка",,"Ссылка");
      
      
      
      
      ЗапросВозвратПоступление  = Новый Запрос;
      ЗапросВозвратПоступление.УстановитьПараметр("НачалоПериода",НачалоПериода);
      ЗапросВозвратПоступление.УстановитьПараметр("КонецПериода",КонецДня(КонецПериода));
      ЗапросВозвратПоступление.УстановитьПараметр("Организация",Организации );
      ЗапросВозвратПоступление.УстановитьПараметр("Контрагент", Контрагент);
      ЗапросВозвратПоступление.Текст = ("ВЫБРАТЬ
      |   ПоступлениеТоваровУслугТовары.Ссылка КАК ДокументПоступления
      |ПОМЕСТИТЬ ВТДокументыПоступления
      |ИЗ
      |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
      |ГДЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
      |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = Значение(Справочник.Организации.ПустаяСсылка) или  ПоступлениеТоваровУслугТовары.Ссылка.Организация = &Организация)      
      |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
      |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Контрагент = &Контрагент)
      |
      |СГРУППИРОВАТЬ ПО
      |   ПоступлениеТоваровУслугТовары.Ссылка
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ РАЗЛИЧНЫЕ
      |   ВозвратТоваровПоставщикуТовары.Ссылка КАК ДокументВозврата,
      |   ВозвратТоваровПоставщикуТовары.ДокументПоступления
      |ПОМЕСТИТЬ ВТДокументыВозврата
      |ИЗ
      |   Документ.ВозвратТоваровПоставщику.Товары КАК ВозвратТоваровПоставщикуТовары
      |ГДЕ
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Дата >= &НачалоПериода
      |   И ВозвратТоваровПоставщикуТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = Значение(Справочник.Организации.ПустаяСсылка) или  ВозвратТоваровПоставщикуТовары.Ссылка.Организация = &Организация)
      |    И &Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка) ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Контрагент = &Контрагент
      
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   ВТДокументыПоступления.ДокументПоступления КАК ДокументПоступления,
      |   ВТДокументыПоступления.ДокументПоступления.Дата КАК ДокументПоступленияДата,
      |   ВТДокументыПоступления.ДокументПоступления.Номер КАК ДокументПоступленияНомер,
      |   ВТДокументыПоступления.ДокументПоступления.СуммаДокумента КАК ДокументПоступленияСуммаДокумента,
      |   ВТДокументыПоступления.ДокументПоступления.Организация КАК ДокументПоступленияОрганизация,
      |   ВТДокументыПоступления.ДокументПоступления.Контрагент КАК ДокументПоступленияКонтрагент,
      |   ВТДокументыВозврата.ДокументВозврата,
      |   ВТДокументыВозврата.ДокументВозврата.Дата КАК ДокументВозвратаДата,
      |   ВТДокументыВозврата.ДокументВозврата.Номер КАК ДокументВозвратаНомер,
      |   ВТДокументыВозврата.ДокументВозврата.СуммаДокумента КАК ДокументВозвратаСуммаДокумента,
      |   ВТДокументыВозврата.ДокументВозврата.Организация КАК ДокументВозвратаОрганизация,
      |   ВТДокументыВозврата.ДокументВозврата.Контрагент КАК ДокументВозвратаКонтрагент
      |ИЗ
      |   ВТДокументыПоступления КАК ВТДокументыПоступления
      |      ЛЕВОЕ СОЕДИНЕНИЕ ВТДокументыВозврата КАК ВТДокументыВозврата
      |      ПО ВТДокументыПоступления.ДокументПоступления = ВТДокументыВозврата.ДокументПоступления
      |
      |УПОРЯДОЧИТЬ ПО
      |   ДокументПоступленияДата,
      |   ДокументВозвратаДата
      |ИТОГИ ПО
      |   ДокументПоступления");
      
      Результат = ЗапросВозвратПоступление.Выполнить();
      
      РезультатЗапроса = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      
      
      Пока РезультатЗапроса.Следующий() Цикл
         НоваяСтрокаУровеньПоступление                = Дерево.Строки.Добавить();
         
         НоваяСтрокаУровеньПоступление.Дата             = РезультатЗапроса.ДокументПоступленияДата;
         НоваяСтрокаУровеньПоступление.Номер            = РезультатЗапроса.ДокументПоступленияНомер;
         НоваяСтрокаУровеньПоступление.СуммаДокумента   = РезультатЗапроса.ДокументПоступленияСуммаДокумента;
         НоваяСтрокаУровеньПоступление.Организация      = РезультатЗапроса.ДокументПоступленияОрганизация;
         НоваяСтрокаУровеньПоступление.Контрагент      = РезультатЗапроса.ДокументПоступленияКонтрагент;
         НоваяСтрокаУровеньПоступление.Ссылка          = РезультатЗапроса.ДокументПоступления;
         ВыборкаДокументыВозврат = РезультатЗапроса.Выбрать();
         Пока ВыборкаДокументыВозврат.Следующий() Цикл
            
            Если Не ЗначениеЗаполнено(ВыборкаДокументыВозврат.ДокументВозврата) Тогда
               Продолжить;
            КонецЕсли;
            
            
            НоваяСтрокаУровеньВозврат                = НоваяСтрокаУровеньПоступление.Строки.Добавить();
            НоваяСтрокаУровеньВозврат.Ссылка          = ВыборкаДокументыВозврат.ДокументВозврата;
            НоваяСтрокаУровеньВозврат.Дата             = ВыборкаДокументыВозврат.ДокументВозвратаДата;
            НоваяСтрокаУровеньВозврат.Номер            = ВыборкаДокументыВозврат.ДокументВозвратаНомер;
            НоваяСтрокаУровеньВозврат.СуммаДокумента   = ВыборкаДокументыВозврат.ДокументВозвратаСуммаДокумента;
            НоваяСтрокаУровеньВозврат.Организация      = ВыборкаДокументыВозврат.ДокументВозвратаОрганизация;
            НоваяСтрокаУровеньВозврат.Контрагент      = ВыборкаДокументыВозврат.ДокументВозвратаКонтрагент;
            
         КонецЦикла;     
      КонецЦикла; 
      ЭлементыФормы.Дерево.СоздатьКолонки();
      ЭлементыФормы.Дерево.ГоризонтальныеЛинии = Истина;ЭлементыФормы.Дерево.ВертикальныеЛинии = Истина;
      ОбойтиУровеньДерева(Дерево.Строки);   
   КонецЕсли;
   

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Может просто не добавлять колонку "Ссылка" в ДЗ?<_<

Оффлайн claberRZN

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
ну я так и сделал, а вот как кодом это сделать не вышло !!! просто для общего интереса нужно

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
"Видимость" - не работает?

Оффлайн claberRZN

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Видимость не работает так как у меня 3 запроса и дерево создает ссылку, я удалил из запроса Ссылку но теперь мне сказали что бы при 2м щелчке на ТЗ открывался документ !!! и при этом ссылка на ТЗ не нужна , вот ее надо скрыть кодом. Идей Нету =(

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
claberRZN, да хоть 100500 запросов. Почему не работает? Уберите видимость колонки на форме.
Если я Вам помог, нажми - Спасибо!

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Чет я совсем начинаю терять нить повествования
Видимость не работает так как у меня 3 запроса
Эээ, а причем тут количество запросов к видимости колонки элемента формы?
при 2м щелчке на ТЗ открывался документ
Откуда вдруг взялась ТЗ, если всю дорогу речь шла о ДЗ?

Оффлайн claberRZN

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Вот запрос целиком, убираю видимость все равно она отображается !!!

Процедура КнопкаВыполнитьНажатие(Кнопка)
   ЭФ=ЭлементыФормы;
   Если Переключатель1=0
      Тогда
      
      Дерево = Новый ДеревоЗначений;
      ЗапросПоступление = Новый Запрос;
      ЗапросПоступление.УстановитьПараметр("НачалоПериода",НачалоПериода);
      ЗапросПоступление.УстановитьПараметр("КонецПериода",КонецДня(КонецПериода));
      ЗапросПоступление.УстановитьПараметр("Организация",Организации );
      ЗапросПоступление.УстановитьПараметр("Контрагент",Контрагент);
      ЗапросПоступление.Текст = ("ВЫБРАТЬ РАЗЛИЧНЫЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата КАК Дата,
      |   ПоступлениеТоваровУслугТовары.Ссылка.Номер,
      |   ПоступлениеТоваровУслугТовары.Ссылка.СуммаДокумента,
      |   ПоступлениеТоваровУслугТовары.Ссылка.Контрагент,
      |   ПоступлениеТоваровУслугТовары.Ссылка.Организация
      |ИЗ
      |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
      |ГДЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
      |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
      |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Организация = &Организация)
      |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
      |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Контрагент = &Контрагент)
      |
      |УПОРЯДОЧИТЬ ПО
      |   Дата"
      );
      
      
      Дерево = ЗапросПоступление.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
      ЭлементыФормы.Дерево.ГоризонтальныеЛинии = Истина;ЭлементыФормы.Дерево.ВертикальныеЛинии = Истина;
      
      
      
   ИначеЕсли Переключатель1=1 Тогда
      
      
      
      
      
      
      
      ЗапросВозврат  = Новый Запрос;
      
      ЗапросВозврат.УстановитьПараметр("НачалоПериода",НачалоПериода);
      ЗапросВозврат.УстановитьПараметр("Организация",Организации );
      ЗапросВозврат.УстановитьПараметр("Контрагент", Контрагент);
      ЗапросВозврат.Текст = ("ВЫБРАТЬ РАЗЛИЧНЫЕ
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Номер,
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Дата КАК Дата,
      |   ВозвратТоваровПоставщикуТовары.Ссылка.СуммаДокумента,
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Организация,
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Контрагент
      |ИЗ
      |   Документ.ВозвратТоваровПоставщику.Товары КАК ВозвратТоваровПоставщикуТовары
      |ГДЕ
      |   ВозвратТоваровПоставщикуТовары.ДокументПоступления ССЫЛКА Документ.ПоступлениеТоваровУслуг
      |   И ВозвратТоваровПоставщикуТовары.Ссылка.Дата >= &НачалоПериода
      |   И ВозвратТоваровПоставщикуТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
      |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Организация = &Организация)
      |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
      |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Контрагент = &Контрагент)
      |
      |УПОРЯДОЧИТЬ ПО
      |   Дата");
      
      
      
      
      Дерево = ЗапросВозврат.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
      ЭлементыФормы.Дерево.ГоризонтальныеЛинии = Истина;ЭлементыФормы.Дерево.ВертикальныеЛинии = Истина;
      
   ИначеЕсли Переключатель1=2 Тогда
      
      
      
      Дерево = Новый ДеревоЗначений;
      
      Дерево.Колонки.Добавить("Дата",,"Дата");
      Дерево.Колонки.Добавить("Номер",,"Номер");
      Дерево.Колонки.Добавить("СуммаДокумента",,"СуммаДокумента");
      Дерево.Колонки.Добавить("Организация",,"Организация");
      Дерево.Колонки.Добавить("Контрагент",,"Контрагент");
      //Дерево.Колонки.Добавить("Ссылка",,"Ссылка");
      
      
      
      
      ЗапросВозвратПоступление  = Новый Запрос;
      ЗапросВозвратПоступление.УстановитьПараметр("НачалоПериода",НачалоПериода);
      ЗапросВозвратПоступление.УстановитьПараметр("КонецПериода",КонецДня(КонецПериода));
      ЗапросВозвратПоступление.УстановитьПараметр("Организация",Организации );
      ЗапросВозвратПоступление.УстановитьПараметр("Контрагент", Контрагент);
      ЗапросВозвратПоступление.Текст = ("ВЫБРАТЬ РАЗЛИЧНЫЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка КАК ДокументПоступления
      |ПОМЕСТИТЬ ВТДокументыПоступления
      |ИЗ
      |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
      |ГДЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
      |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
      |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Организация = &Организация)
      |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
      |         ИЛИ ПоступлениеТоваровУслугТовары.Ссылка.Контрагент = &Контрагент)
      |
      |СГРУППИРОВАТЬ ПО
      |   ПоступлениеТоваровУслугТовары.Ссылка
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ РАЗЛИЧНЫЕ
      |   ВозвратТоваровПоставщикуТовары.Ссылка КАК ДокументВозврата,
      |   ВозвратТоваровПоставщикуТовары.ДокументПоступления
      |ПОМЕСТИТЬ ВТДокументыВозврата
      |ИЗ
      |   Документ.ВозвратТоваровПоставщику.Товары КАК ВозвратТоваровПоставщикуТовары
      |ГДЕ
      |   ВозвратТоваровПоставщикуТовары.Ссылка.Дата >= &НачалоПериода
      |   И ВозвратТоваровПоставщикуТовары.Ссылка.Проведен = ИСТИНА
      |   И (&Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
      |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Организация = &Организация)
      |   И (&Контрагент = ЗНАЧЕНИЕ(Справочник.Контрагенты.пустаяСсылка)
      |         ИЛИ ВозвратТоваровПоставщикуТовары.Ссылка.Контрагент = &Контрагент)
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   ВТДокументыПоступления.ДокументПоступления КАК ДокументПоступления,
      |   ВТДокументыПоступления.ДокументПоступления.Дата КАК ДокументПоступленияДата,
      |   ВТДокументыПоступления.ДокументПоступления.Номер КАК ДокументПоступленияНомер,
      |   ВТДокументыПоступления.ДокументПоступления.СуммаДокумента КАК ДокументПоступленияСуммаДокумента,
      |   ВТДокументыПоступления.ДокументПоступления.Организация КАК ДокументПоступленияОрганизация,
      |   ВТДокументыПоступления.ДокументПоступления.Контрагент КАК ДокументПоступленияКонтрагент,
      |   ВТДокументыВозврата.ДокументВозврата,
      |   ВТДокументыВозврата.ДокументВозврата.Дата КАК ДокументВозвратаДата,
      |   ВТДокументыВозврата.ДокументВозврата.Номер КАК ДокументВозвратаНомер,
      |   ВТДокументыВозврата.ДокументВозврата.СуммаДокумента КАК ДокументВозвратаСуммаДокумента,
      |   ВТДокументыВозврата.ДокументВозврата.Организация КАК ДокументВозвратаОрганизация,
      |   ВТДокументыВозврата.ДокументВозврата.Контрагент КАК ДокументВозвратаКонтрагент
      |ИЗ
      |   ВТДокументыПоступления КАК ВТДокументыПоступления
      |      ЛЕВОЕ СОЕДИНЕНИЕ ВТДокументыВозврата КАК ВТДокументыВозврата
      |      ПО ВТДокументыПоступления.ДокументПоступления = ВТДокументыВозврата.ДокументПоступления
      |
      |УПОРЯДОЧИТЬ ПО
      |   ДокументПоступленияДата,
      |   ДокументВозвратаДата
      |ИТОГИ ПО
      |   ДокументПоступления");
      
      Результат = ЗапросВозвратПоступление.Выполнить();
      
      РезультатЗапроса = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      
      
      Пока РезультатЗапроса.Следующий() Цикл
         НоваяСтрокаУровеньПоступление                = Дерево.Строки.Добавить();
         
         НоваяСтрокаУровеньПоступление.Дата             = РезультатЗапроса.ДокументПоступленияДата;
         НоваяСтрокаУровеньПоступление.Номер            = РезультатЗапроса.ДокументПоступленияНомер;
         НоваяСтрокаУровеньПоступление.СуммаДокумента   = РезультатЗапроса.ДокументПоступленияСуммаДокумента;
         НоваяСтрокаУровеньПоступление.Организация      = РезультатЗапроса.ДокументПоступленияОрганизация;
         НоваяСтрокаУровеньПоступление.Контрагент      = РезультатЗапроса.ДокументПоступленияКонтрагент;
         НоваяСтрокаУровеньПоступление.Ссылка          = РезультатЗапроса.ДокументПоступления;
         ВыборкаДокументыВозврат = РезультатЗапроса.Выбрать();
         Пока ВыборкаДокументыВозврат.Следующий() Цикл
            
            Если Не ЗначениеЗаполнено(ВыборкаДокументыВозврат.ДокументВозврата) Тогда
               Продолжить;
            КонецЕсли;
            
            
            НоваяСтрокаУровеньВозврат                = НоваяСтрокаУровеньПоступление.Строки.Добавить();
            НоваяСтрокаУровеньВозврат.Ссылка          = ВыборкаДокументыВозврат.ДокументВозврата;
            НоваяСтрокаУровеньВозврат.Дата             = ВыборкаДокументыВозврат.ДокументВозвратаДата;
            НоваяСтрокаУровеньВозврат.Номер            = ВыборкаДокументыВозврат.ДокументВозвратаНомер;
            НоваяСтрокаУровеньВозврат.СуммаДокумента   = ВыборкаДокументыВозврат.ДокументВозвратаСуммаДокумента;
            НоваяСтрокаУровеньВозврат.Организация      = ВыборкаДокументыВозврат.ДокументВозвратаОрганизация;
            НоваяСтрокаУровеньВозврат.Контрагент      = ВыборкаДокументыВозврат.ДокументВозвратаКонтрагент;
            
         КонецЦикла;     
      КонецЦикла; 
      
      ЭлементыФормы.Дерево.СоздатьКолонки();
      ЭлементыФормы.Дерево.ГоризонтальныеЛинии = Истина;ЭлементыФормы.Дерево.ВертикальныеЛинии = Истина;
      ОбойтиУровеньДерева(Дерево.Строки);   
   КонецЕсли;
   
   
КонецПроцедуры

Процедура ДеревоВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   
   
КонецПроцедуры

Процедура ОбойтиУровеньДерева(Строки);
   Для каждого Строка из Строки Цикл
      ОбойтиУровеньДерева(Строка.Строки);
   КонецЦикла;
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
убираю видимость все равно она отображается !!!
Стисняюсь спросить, где?! в какой строке кода вы управляете видимостью колонки дерева?

Оффлайн claberRZN

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
убираю видимость все равно она отображается !!!
Стисняюсь спросить, где?! в какой строке кода вы управляете видимостью колонки дерева?

А ну вот так я и не знаю чего пописать что бы скрыть и куда прописать , я думал что достаточно сделать на Форме "Убрать галку видимости"


 

Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 527
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 18
Просмотров: 9218
Последний ответ 10 Окт 2013, 00:24
от mixqn
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 436
Последний ответ 17 Авг 2016, 11:25
от Караул
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1446
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Конвертация данных, ошибка "Преобразование значения к типу Число не может быть выполнено"

Автор CerebrinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1278
Последний ответ 10 Май 2015, 21:51
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
61 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
alexandr_ll
32 Сообщений
LexaK
32 Сообщений
crow1983
31 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 146
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal