Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2017, 15:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка инициализации библиотеки модулей  (Прочитано 3841 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ТихомировИгорь

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Самостоятельно занимаюсь изучением 1:С Предприятие 8.3 по книге Радченко М.Г.
При изучении на девятом задании возникла проблема. Все делаю правильно, как описано в книге, но выдает следующую ошибку:

Ошибка инициализации библиотеки модулей
по причине:
{ОбщийМодуль.РаботаСоСправочниками.Модуль(3,7)}: Неопознанный оператор
Общие <<?>>модули   Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);

Подскажите пожалуйста в ем может быть проблема.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Приведите код из вашего общего модуля РаботаСоСправочниками с 1 по 5-ую строку

Оффлайн ТихомировИгорь

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Приведите код из вашего общего модуля РаботаСоСправочниками с 1 по 5-ую строку

&НаКлиенте
Процедура ПереченьНоменклатурыНоменклатураПриИзмененииНаСервере()
   // Получить текущую строку табличной части.
   СтрокаТабличнойЧасти = Элементы.ПереченьНоменклатуры.ТекущиеДанные;
   
   // Установить цену.
   СтрокаТабличнойЧасти.Цена = РаботаСоСправочниками.РозничнаяЦена(
                                         Объект.Дата, СтрокаТабличнойЧасти.Номенклатура);
                               
   // Пересчитать сумму строки
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Это точно код из общего модуля? Покажите скрином.

Оффлайн ТихомировИгорь

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Это точно код из общего модуля? Покажите скрином.

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн ТихомировИгорь

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
http://www.lessons1c.ru/articles/55-moduly82.html

Функция РозничнаяЦена(АктуальнаяДата, ЭлементНоменклатуры) Экспорт
   // Создать вспомогательный объект "Отбор".
Общие модули   Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);
   
    // Получить актуальные значения ресурсов регистра.
    ЗначенияРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);
    Возврат ЗначенияРесурсов.Цена;
КонецФункции

Прошу прошения, перепутал

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Общие модули   Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);

В этой строке вас ничего не смущает? Так в книге НЕ написано.

Оффлайн ТихомировИгорь

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-11
  • Сайт: 
  • Профессия: Ученик 1С
Общие модули   Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);

В этой строке вас ничего не смущает? Так в книге НЕ написано.

Смущает, но что не пойму.

Оффлайн Kironten

  • *****
  • Сообщений: 712
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Общие модули   Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);

В этой строке вас ничего не смущает? Так в книге НЕ написано.

Смущает, но что не пойму.

Функция РозничнаяЦена(АктуальнаяДата, ЭлементНоменклатуры) Экспорт
// Создать вспомогательный объект "Отбор".
Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);
// Получить актуальные значения ресурсов регистра.
ЗначенияРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);
Возврат ЗначенияРесурсов.Цена;
КонецФункции
Вот как там написано. Где вы увидели в этом коде фразу "Общие модули"?


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3659
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4804
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3222
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 5144
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6997
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
alex0402
75 Сообщений
alexandr_ll
37 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
23 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
15 Сообщений
Vzonder
15 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal