Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод на печать  (Прочитано 4532 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Есть справочник контрагентов необходимо вывести его на печать.Этот справочник вывел средствами конструктора.У каждого контрагента есть договора размещенные в справочнике ДоговорыКонтрагента.Необходимо еще выводить для справочника контрагентов его договора. Как обойти эти договора?
Пробывал так
Пока Выборка1.Следующий() Цикл
     Если Выборка1.Владелец=Выборка.Наименование
      Тогда
      Элемент.Параметры.ДоговорыКонтрагентов=Выборка1.Наименование;
       
   ТабДок.Вывести(Элемент);    



Процедура Печать(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК(Печать)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТабДок = Новый ТабличныйДокумент;
   Макет = Справочники.Контрагенты.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Область = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);
   Выборка = Справочники.Контрагенты.ВыбратьИерархически();
   Выборка1 = Справочники.ДоговорыКонтрагентов.Выбрать();
   Группа = Макет.ПолучитьОбласть("Группа");
   Элемент = Макет.ПолучитьОбласть("Элемент");
   Пока Выборка.Следующий() Цикл
      
      Если Выборка.ЭтоГруппа Тогда
         Группа.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Группа);
      Иначе
      
         Элемент.Параметры.Код=Выборка.Код;
         Элемент.Параметры.Наименование=Выборка.Наименование;
         Элемент.Параметры.Адрес=Выборка.Адрес;
         Элемент.Параметры.ИНН=Выборка.ИНН;
         
                  ТабДок.Вывести(Элемент);
         
      Пока Выборка1.Следующий() Цикл
     Если Выборка1.Владелец=Выборка.Наименование
      Тогда
      Элемент.Параметры.ДоговорыКонтрагентов=Выборка1.Наименование;
       
   ТабДок.Вывести(Элемент);    
     Иначе
                КонецЕсли;
         КонецЦикла;
   
         КонецЕсли;         
                
        КонецЦикла;

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Истина;
   ТабДок.ТолькоПросмотр = Истина;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК
КонецПроцедуры


Оффлайн markantonio

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 4
  • КПД: 22%
  • Регистрация: 2010-12-07
  • Сайт: 
  • Профессия: Программист 1С
Re: Вывод на печать
« Ответ #1: 08 Дек 2010, 12:09 »
Пока Выборка.Следующий() Цикл
Если Выборка.ЭтоГруппа Тогда
Группа.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Группа);
Иначе
Элемент.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Элемент);

Выборка1 = Справочники.ДоговорыКонтрагентов.Выбрать(,Выборка);

Пока Выборка1.Следующий() Цикл
//.................................
//.................................
КонецЦикла;


КонецЕсли;
КонецЦикла;

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Re: Вывод на печать
« Ответ #2: 09 Дек 2010, 10:33 »
Процедура Печать(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК(Печать)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТабДок = Новый ТабличныйДокумент;
   Макет = Справочники.Контрагенты.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Область = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);
   Выборка = Справочники.Контрагенты.ВыбратьИерархически();
   Группа = Макет.ПолучитьОбласть("Группа");
   Элемент = Макет.ПолучитьОбласть("Элемент");
   Пока Выборка.Следующий() Цикл
      
      Если Выборка.ЭтоГруппа Тогда
         Группа.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Группа);
      Иначе
      
         Элемент.Параметры.Код=Выборка.Код;
         Элемент.Параметры.Наименование=Выборка.Наименование;
         Элемент.Параметры.Адрес=Выборка.Адрес;
         Элемент.Параметры.ИНН=Выборка.ИНН;
         
                  ТабДок.Вывести(Элемент);
      Выборка1 = Справочники.ДоговорыКонтрагентов.Выбрать(,Выборка);   
      Пока Выборка1.Следующий() Цикл
     Элемент.Параметры.ДоговорыКонтрагентов=Выборка1.Наименование;
   ТабДок.Вывести(Элемент);    
            КонецЦикла;

                 КонецЕсли;   
         КонецЦикла;
   
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Истина;
   ТабДок.ТолькоПросмотр = Истина;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК
КонецПроцедуры

Выдает ошибку {Справочник.Контрагенты.Форма.ФормаСписка(30)}: Ошибка при вызове метода контекста (Выбрать): Несоответствие типов (параметр номер '2')
      Выборка1 = Справочники.ДоговорыКонтрагентов.Выбрать(,Выборка);   


Оффлайн markantonio

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 4
  • КПД: 22%
  • Регистрация: 2010-12-07
  • Сайт: 
  • Профессия: Программист 1С
Re: Вывод на печать
« Ответ #3: 09 Дек 2010, 11:39 »
Выборка1 = Справочники.ДоговорыКонтрагентов.Выбрать(,Выборка.Ссылка);

попробуй.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Re: Вывод на печать
« Ответ #4: 10 Дек 2010, 12:01 »
Добавил в выборку отбор по владельцу Выбрать(,выборка.Ссылка);
Договор начал выводится.Допустим Сидоров Договор 111.
Затем договор выводится у руданова ,хотя у руданова нет этого договора.


Теги:
 

УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3757
Последний ответ 29 Июн 2012, 18:37
от LexaK
Печать справки "Б"

Автор wvlasРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2250
Последний ответ 27 Апр 2016, 18:01
от wvlas
Как "поймать" нажатие на кнопку "Печать" в открываемом макете(табличный документ)?

Автор taramz5Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1170
Последний ответ 14 Фев 2017, 14:27
от ilyay
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 206
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Расширение меню кнопки "Печать"

Автор dab2Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6201
Последний ответ 23 Июл 2010, 13:26
от dab2

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 241
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal