Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Окт 2017, 11:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вытащить данные из регистранакопления?  (Прочитано 569 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mila1231

  • ***
  • Сообщений: 150
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, как сделать, чтоб работало?))
Есть Документ Изменение_параметров, с него данные записываются в регистрнакопления РегистрПараметров, так вот из этого регистра нужно выдернуть данные в документ Свидетельство. Так вот при изменении одного из реквизитов Документа Свидетельства, должны меняться другие реквизиты, вот собственно сама процедура

Процедура ПолеВвода1ПриИзменении(Элемент)
   // Вставить содержимое обработчика.
   
   
   
    Запрос = Новый запрос;
    Запрос.текст = "ВЫБРАТЬ
                   |   РегистрПараметров.Температутра КАК Температура1,
                   |   РегистрПараметров.Влажность,
                   |   РегистрПараметров.давление,
                   |   РегистрПараметров.Дата,
                   |   Свидетельство.Дата КАК Дата1,
                   |   РегистрПараметров.Период
                   |ИЗ
                   |   РегистрНакопления.РегистрПараметров КАК РегистрПараметров,
                   |   Документ.Свидетельство КАК Свидетельство"  ;

   Выборка = Запрос.Выполнить().Выбрать();
Если Формат (выборка.Дата, "ДЛФ=Д")= Формат(выборка.Дата1, "ДЛФ=Д") тогда
    Температура =выборка.Температура1;
   
иначе
   Температура = 123
      
      
   КонецЕсли;
   
   
КонецПроцедуры

Это не работает, т.е условие по сути похоже выполняется, а значение параметраформы температура не меняется, что не так?
Заранее спасибо.


Оффлайн mila1231

  • ***
  • Сообщений: 150
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Это не работает, т.е условие по сути похоже выполняется
Определите выполняется ли условие - с помощью отладчика
а значение параметраформы температура
Может быть поля формы или реквизита формы? Нужно более конкретно чем у Вас является "Температура"?
Выборка = Запрос.Выполнить().Выбрать();
Если Формат (выборка.Дата, "ДЛФ=Д")= Формат(выборка.Дата1, "ДЛФ=Д") тогда
    Температура =выборка.Температура1;
   
иначе
   Температура = 123
     
     
   КонецЕсли;
Отсутствует обход результата запроса
Выборка.Следующий()

Вывод: думаю вам лучше всего почитать Радченко.

Если я Вам помог, нажми - Спасибо!


Теги:
 

Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4776
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3673
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 7678
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6717
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 908
Последний ответ 01 Мар 2016, 14:33
от sveta C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
86 Сообщений
alex0402
54 Сообщений
AIFrame
40 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
19 Сообщений
BuhRust
14 Сообщений
DmitriyF DmitriyF
13 Сообщений

* Кто онлайн

  • Точка Гостей: 909
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal