Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть список документов.  (Прочитано 986 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AndreyAcid

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-07
    • Skype: Andrey_485
  • Сайт: Acid.Name
  • Профессия: Программист 1С
Добрый день. Подскажите как по кнопке отрыть список документов, например Расходная накладная
Конфигурацию пишу с нуля.

Вот код который пытаюсь исполнить:
&НаКлиенте
Процедура КМОткрытьСписокНакладных(Команда) // контекстное меню
ОткрытьСписокНакладных();
КонецПроцедуры
&НаСервере
Процедура ОткрытьСписокНакладных()
форма = Документы.РасходнаяНакладная.ПолучитьФормуВыбора("ФормаВыбора",,);
форма.Открыть();
КонецПроцедуры


Выдает ошибку:

{Обработка.РабочееМесто.Форма.Форма.Форма(1080)}: Ошибка при вызове метода контекста (ПолучитьФормуВыбора)
   форма = Документы.РасходнаяНакладная.ПолучитьФормуВыбора("ФормаВыбора",,);
по причине:
Интерактивные операции недоступны


Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
AndreyAcid, открывать форму нужно на клиенте.

Оффлайн AndreyAcid

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-07
    • Skype: Andrey_485
  • Сайт: Acid.Name
  • Профессия: Программист 1С
AndreyAcid, открывать форму нужно на клиенте.

Спасибо. Дошло ))
Сделал вот так:
&НаКлиенте
Процедура КМОткрытьСписокНакладных(Команда) // контекстное ме
Получитьформу("Документ.РасходнаяНакладная.Форма.ФормаВыбора").Открыть();
КонецПроцедуры

:befhbt:



Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Используйте ОткрытьФорму() вместо ПолучитьФорму().Открыть()


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6791
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3188
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4102
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 181
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3029
Последний ответ 29 Май 2013, 16:24
от leklerk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 245
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal