Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 01:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть список документов.  (Прочитано 450 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AndreyAcid

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-07
    • Skype: Andrey_485
  • Сайт: Acid.Name
  • Профессия: Программист 1С
Добрый день. Подскажите как по кнопке отрыть список документов, например Расходная накладная
Конфигурацию пишу с нуля.

Вот код который пытаюсь исполнить:
&НаКлиенте
Процедура КМОткрытьСписокНакладных(Команда) // контекстное меню
ОткрытьСписокНакладных();
КонецПроцедуры
&НаСервере
Процедура ОткрытьСписокНакладных()
форма = Документы.РасходнаяНакладная.ПолучитьФормуВыбора("ФормаВыбора",,);
форма.Открыть();
КонецПроцедуры


Выдает ошибку:

{Обработка.РабочееМесто.Форма.Форма.Форма(1080)}: Ошибка при вызове метода контекста (ПолучитьФормуВыбора)
   форма = Документы.РасходнаяНакладная.ПолучитьФормуВыбора("ФормаВыбора",,);
по причине:
Интерактивные операции недоступны


Оффлайн pavl_vs

  • *****
  • Сообщений: 919
  • РЕПУТАЦИЯ: 145
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
AndreyAcid, открывать форму нужно на клиенте.

Оффлайн AndreyAcid

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-07
    • Skype: Andrey_485
  • Сайт: Acid.Name
  • Профессия: Программист 1С
AndreyAcid, открывать форму нужно на клиенте.

Спасибо. Дошло ))
Сделал вот так:
&НаКлиенте
Процедура КМОткрытьСписокНакладных(Команда) // контекстное ме
Получитьформу("Документ.РасходнаяНакладная.Форма.ФормаВыбора").Открыть();
КонецПроцедуры

:befhbt:



Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Используйте ОткрытьФорму() вместо ПолучитьФорму().Открыть()


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5278
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 1596
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3597
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2275
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1398
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
61 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
LexaK
32 Сообщений
alexandr_ll
32 Сообщений
crow1983
31 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 165
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal