Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Авг 2017, 05:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Организация выбора в регистре сведений  (Прочитано 1466 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maximadelevich

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-03
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Друзья, у меня не получается организовать выбор элемента из регистра сведений ШаблоныЗаказовКлиентам. Есть внешняя обработка, где выбирается документ для заполнения данными и кнопка Заполнить.

В модуле формы обработки пишу это:
&НаКлиенте
Процедура Заполнить(Команда)
ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()

    ДанныеКлюча = Новый Структура("Контрагент", СсылкаНаДокумент.Контрагент);
    Ключ = РегистрыСведений.ШаблоныЗаказовКлиентам.СоздатьКлючЗаписи(ДанныеКлюча); 

    Фрм = РегистрыСведений.ШаблоныЗаказовКлиентам.ПолучитьФормуСписка("ФормаСписка");
    Фрм.Параметры.РежимВыбора = Истина;
    Фрм.ВладелецФормы = Фрм;
    Фрм.Параметры.КлючНазначенияИспользования = Ключ;
    Фрм.Открыть();

КонецПроцедуры

А в форме списка регистра сведений пишу это:
&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
ОповеститьОВыборе(ВыбраннаяСтрока);
СтандартнаяОбработка = Ложь;
КонецПроцедуры

Вопрос такой: где нужно организовывать процедуру ОбработкаВыбора ? Подскажите, пожалуйста, что я делаю неправильно (я новичок) :(
"Кто владеет информацией, тот владеет миром" М. Ротшильд


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
выбор из регистра сведений сама по себе странная операция.
потому что запись регистра сведений - это не объектная сущность.
при этом конечно нельзя сказать что подобие выбора нельзя организовать.

1) форму нельзя открывать на сервере в серверной процедуре
2) обработка выбора срабатывает в владельца открываемой формы. у вас же она почему то сама себе владелец...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн maximadelevich

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-03
  • Сайт: 
  • Профессия: Ученик 1С
выбор из регистра сведений сама по себе странная операция.
потому что запись регистра сведений - это не объектная сущность.
при этом конечно нельзя сказать что подобие выбора нельзя организовать.

1) форму нельзя открывать на сервере в серверной процедуре
2) обработка выбора срабатывает в владельца открываемой формы. у вас же она почему то сама себе владелец...

Спасибо, правда я запутался, то есть форма обработки получается дочерней, а форма списка родительской?
"Кто владеет информацией, тот владеет миром" М. Ротшильд

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
форма обработки - владелец формы списка регистра
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги: Выбор 
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4599
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7361
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8489
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 13078
Последний ответ 11 Янв 2011, 10:04
от nomer13
Регистры накопления, Регистры сведений, Документы, Проведение

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 7493
Последний ответ 17 Янв 2014, 21:52
от kot_oo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
142 Сообщений
alex0402
57 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
32 Сообщений
AIFrame
30 Сообщений
Kironten
29 Сообщений
pavl_vs
26 Сообщений
AsadRoman
20 Сообщений
magnifico61
18 Сообщений
Александр Лахтин Александр Лахтин
18 Сообщений

* Кто онлайн

  • Точка Гостей: 294
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal