Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Закладки формы из результатов запроса. Как? (  (Прочитано 10723 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gaidn

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток. Имея колоссальный опыт программирования 1с 7.7 в количестве 4 часов столкнулся с такой ситуевиной. Программа должна автоматически подключиться к базе данных и загрузить в закладки первые буквы фамилий из таблицы Анкета (только тех, которые существуют в таблице, а не весь алфавит). Представляю реализацию данной прихоти в Delphi, но 1с...!??!? Я так понимаю что нужно:
 1. Выполнить запрос на фамилии.
 2. Сохранить его результаты (как? в какой тип данных?).
 3. Пройтись по результату запроса, сохранить первые буквы фамилий в массиве, исключая повторения.
 4. При открытии Справочника динамически создавать закладки на форме этого справочника с названиями из элементов массива.
Я понимаю, что курить мануалы и т.д., просто необходимо это сделать сегодня. Или хотя бы скажите, правильным ли курсом идем, товарищи?!
  Заранее спасибо.
Откуда бобик? И два сержанта?
Фома, куда же делась Темза!?!
Вокруг асфальт, косяк предательски не тонет...
И мы стоим, менты стоят, а он лежит


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
давай ка поподробнее, да больше на стандартном русском, мы тут все больше ущербные интерпретаторщики,почти не компиляторщики, и уж совсем не разу не дельфины (ну разве шо чуть чуть)    ;)
Ну а если серьезно, то :
Что компилятор, что интерпретатор алгоритм примерно  одинаков:
1 Автоматически подключаться, к чему? к какой то готовой базе? - тогда просто  пропиши её сначала.
2.Либо конфигурация должна подцепиться к какой нить дбф - ке ?  тогда нужна обработка
(дальше код - смотря к чему цепляться)
3.Таблица я так понял в другом каком то файле? например в екселе,  :xfbnsdfb:
(вишь как трудно когда так обьясняют, что к чему цепляется?, что где сохраняется?)
тогда надо в обработке обратиться  :o  к  экселю твоему (дальше опять уже код).
4.Запрос нужен - перебор построчный файла  экселя - сравнение с твоим конечным    :lol:  дбф-ом
который тебе нужен, и пополнение его в зависимости от того есть ли совпадения.(можно циклами ПОКА - КОНЕЦЦИКЛА, можно ЕСЛИ - ТОГДА, можно запросом и т.д.)   :kmtu:
5.Дальше вообще непонятно - можно конечно создать справочник , позаводить реквизитов, и цикл по проверке насовпадений запустить + пополнить этот справочник элементами получившегося массива...(тут опять код)...                не, все... я так не могу,сдался .   пойду застрелюсь...  :trhregerhg:

Оффлайн Gaidn

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Ученик 1С
Есть 2 связаные таблицы тьфу справочники: "Анкеты" и "ПодробныеДанные", в 1с. В "Анкете" ФИО, дата рождения, место рождения и личные данные, в "ПодробныеДанные" не суть важно. К примеру в справочнике "Анкета" есть Иванов, Петров, Исаев, Сидоров, Дыркин. Так вот при открытии базы должна появляться форма у которой есть вкладки И(там тблица Иванов, Исаев), П (там Петров) и Д (соответственно). Жмакаешь вкладку с буквой, появляеться инфа из "Анкета" с возможностью просмотра "ПодробныеДанные".
Вот полный текст задания Программа должна автоматически подключиться к базе данных и загрузить в закладки первые буквы фамилий из таблицы Анкета (только тех, которые существуют в таблице, а не весь алфавит). При выборе закладки загружать фамилии с инициалами в какой-нибудь элемент (на Ваше усмотрение, лист, всплывающее меню или что-нибудь еще). При выборе же фамилии загружать послужной список этого человека. Реализовать возможности добавления, редактирования, удаления данных
ЗЫ: Пистолетик одолжи  B)
Откуда бобик? И два сержанта?
Фома, куда же делась Темза!?!
Вокруг асфальт, косяк предательски не тонет...
И мы стоим, менты стоят, а он лежит

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
кто тебе такие задания придумывает?
Это нетрудное задание, но странное, тебя научить надо? или сделать за тебя надо?

Оффлайн Gaidn

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Ученик 1С
Нет, за меня не надо, мне б хотя бы принцип.
Вродже как с алгоритмами у меня неплохо, но вот с терминалогией и принципами 1с никак ((, надеюсь пока. В любой другой СУБД на Object Paskal или С++ я б осилил. Проблема в незнании элементарного, а времени на изучение до завтра 12.00  B) Если можешь, скинь пожалуйста ссыль на справочник по типам данных, процедурам и функциям 1с, что-то наподобие синтаксис-помощника. Как связать 1с и SQL. в сети слишком много советов и все противоречивые. Я только начинаю изучать 1с.
Откуда бобик? И два сержанта?
Фома, куда же делась Темза!?!
Вокруг асфальт, косяк предательски не тонет...
И мы стоим, менты стоят, а он лежит

Оффлайн Gaidn

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Ученик 1С
Задание странное, конечно, но работодателю не указывают  ;) Если сделаю, то берут стажером с обучением и сертификацей.
Откуда бобик? И два сержанта?
Фома, куда же делась Темза!?!
Вокруг асфальт, косяк предательски не тонет...
И мы стоим, менты стоят, а он лежит

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Раз уж есть тема по закладкам, задам и свой вопрос по реализации закладок в журнале.
Пытался реализовать по примеру не вышло (ФлЗакладки -  если флаг стоит то и закладки есть, лучше без флага вообще) 
В журнале должны быть закладки по цехам (Справочник.Подразделения.ТипСклада), кусок кода в процедуре ПриОткрытии() 
Укажите пожалуйста где ошибся, ибо как не пробовал закладки не создаются

   Форма.ИспользоватьЗакладки(ФлЗакладки);
   Если ФлЗакладки=1 Тогда
      Спис = СоздатьОбъект("СписокЗначений");
      Спр = СоздатьОбъект("Справочник.Подразделения");
      Спр.ПорядокКодов();
      Спр.ВыбратьЭлементы(1);
      Пока Спр.ПолучитьЭлемент()=1 Цикл
         Если Спр.ТипСклада = "Цех" Тогда
          Если Спр.ПометкаУдаления()=0 Тогда
            Спис.ДобавитьЗначение(Спр.ТекущийЭлемент(), СокрЛП(Спр.ТипСклада));
          КонецЕсли;
         КонецЕсли;
      КонецЦикла;
      Спис.Выгрузить(Форма.Закладки);
   Иначе
      УстановитьОтбор("");
   КонецЕсли;
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
помогите пожалуйста
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
 Спис.Выгрузить(Форма.Закладки);
 МОДИФИЦИРОВАННОСТЬ();
   Иначе
      УстановитьОтбор("");
   КонецЕсли;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal