Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 04:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение подстраничек из иерархического справочника  (Прочитано 595 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые!
 Имеется документ, в нем имеется несколько подстраничек, и для каждой из них одна одинаковая табличная часть. При создании документа есть процедура, которая заполняет колонку "Наименование" значениями из определенной группы иерархического справочника. Вот процедура:

Процедура ДобавитьПредопределенныеСтроки()
   
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Ссылка,
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Наименование
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ
      |ГДЕ
      |   НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ЭтоГруппа
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Предопределенный
      |   И НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ПометкаУдаления
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Родитель = &Родитель" ;
            Запрос.УстановитьПараметр("Родитель", Справочники.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.МясоСвежееЗамороженноеИПродуктыПереработки);
   Результат = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Пока
   Пока ВыборкаДетальныеЗаписи.Следующий()=1 Цикл
             НовСтр = Объект.СведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Добавить();
            НовСтр.НаименованиеИсследуемогоПоказателя = ВыборкаДетальныеЗаписи.Ссылка;
   КонецЦикла;   

  КонецПроцедуры



Подскажите, как сделать так, что бы другие подстранички заполнялись элементами других групп из справочника. В данный момент у меня все подстранички запоняются элементами из одной группы справочника, а нужно что бы каждая подстраничка заполнялась из разных групп справочника.  Зараннее спасибо!


Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
вот добавил скриншот, что бы было понятней http://s019.radikal.ru/i602/1510/fe/de7b0a1cc17e.png

Импортная продукция(Мясо свежее..... Это первая подстраничка
Субпродукты убойных животных.....    Это вторая подстраничка

Онлайн Kironten

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 169
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Абсолютно также как и первую табличную часть.
Можно сделать пакетный запрос. Соотвественно каждый пакет для определенной ТЧ.

И еще. Делайте лучше в запросах попроще представления объектов, сложно читать. Поскольку запрос не многоуровневый, вряд ли это оправдано.
Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   СпрСведения.Ссылка,
      |   СпрСведения.Наименование
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК СпрСведения
      |ГДЕ
      |   НЕ СпрСведения.ЭтоГруппа
      |   И СпрСведения.Предопределенный
      |   И НЕ СпрСведения.ПометкаУдаления
      |   И СпрСведения = &Родитель" ;
            Запрос.УстановитьПараметр("Родитель", Справочники.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.МясоСвежееЗамороженноеИПродуктыПереработки);
   Результат = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   //Пока
   //Пока ВыборкаДетальныеЗаписи.Следующий()=1 Цикл //еденица, это лишнее
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Извиняюсь за названия. Сделал пакетный запрос:
 Процедура ДобавитьПредопределенныеСтроки()
   
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Ссылка,
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Наименование
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ
      |ГДЕ
      |   НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ЭтоГруппа
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Предопределенный
      |   И НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ПометкаУдаления
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Родитель = &Родитель
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Наименование,
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Ссылка
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ
      |ГДЕ
      |   НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ЭтоГруппа
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Предопределенный
      |   И НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ПометкаУдаления
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Родитель = &Родитель" ;
            Запрос.УстановитьПараметр("Родитель", Справочники.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.МясоСвежееЗамороженноеИПродуктыПереработки);
   Результат = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Пока ВыборкаДетальныеЗаписи.Следующий()=1 Цикл
             НовСтр = Объект.СведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Добавить();
            //НовСтр.НомерСтроки = ВыборкаДетальныеЗаписи.Ссылка;
            НовСтр.НаименованиеИсследуемогоПоказателя = ВыборкаДетальныеЗаписи.Ссылка;
   КонецЦикла;   


Это по сути тот же запрос, но подскажите, как установить параметры Родителя, что бы для каждого пакета, они были свои?
Добавлено: 30 Окт 2015, 13:33

Табличная часть ведь одна и та же, отличаются лишь элменты, которыми надо заполнить эти подстранички

Онлайн Kironten

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 169
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ДобавитьПредопределенныеСтроки()
   
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Ссылка,
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Наименование
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ
      |ГДЕ
      |   НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ЭтоГруппа
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Предопределенный
      |   И НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ПометкаУдаления
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Родитель = &Родитель
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Наименование,
      |   мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Ссылка
      |ИЗ
      |   Справочник.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ КАК мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ
      |ГДЕ
      |   НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ЭтоГруппа
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Предопределенный
      |   И НЕ мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.ПометкаУдаления
      |   И мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Родитель = &Родитель2" ;
            Запрос.УстановитьПараметр("Родитель", Справочники.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.МясоСвежееЗамороженноеИПродуктыПереработки);
Запрос.УстановитьПараметр("Родитель2", Справочники.мвткСведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.<ДругаяГруппа>);
   Результат = Запрос.ВыполнитьПакет();
   ВыборкаДетальныеЗаписи1 = Результат[1].Выбрать();
   Пока ВыборкаДетальныеЗаписи1.Следующий() Цикл
             НовСтр = Объект.СведенияОВыполненииПланаГосударственногоВетеринарногоМониторингаЗапрещенныхИВредныхВеществ.Добавить();
            //НовСтр.НомерСтроки = ВыборкаДетальныеЗаписи.Ссылка;
            НовСтр.НаименованиеИсследуемогоПоказателя = ВыборкаДетальныеЗаписи.Ссылка;
   КонецЦикла;
   
    ВыборкаДетальныеЗаписи2 = Результат[2].Выбрать();
    Пока ВыборкаДетальныеЗаписи2.Следующий() Цикл
        //Заполняем вторую тч.
Я код не причесывал - лениво.

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
От души! Спасибо!:zebzdr::zebzdr::zebzdr::nhsrm:
Добавлено: 30 Окт 2015, 13:59

Не пойму, зачем указывать номер строки? Пакеты запросов, параметры, это все да, но табличная часть одна же ведь
Добавлено: 30 Окт 2015, 14:04

От души! Спасибо!:zebzdr::zebzdr::zebzdr::nhsrm:
Добавлено: 30 Окт 2015, 13:59

Не пойму, зачем указывать номер строки? Пакеты запросов, параметры, это все да, но табличная часть одна же ведь
Извиняюсь, разобрался

Последний раз редактировалось: GanG031; 30 Окт 2015, 14:04. Причина: Объединение сообщений


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5869
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1560
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6347
Последний ответ 16 Авг 2012, 21:50
от Will
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3407
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 119
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
Dethmontt Dethmontt
67 Сообщений
alex0402
65 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
60 Сообщений
ilyay ilyay
39 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
24 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal