Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Сен 2017, 01:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Прикрепленные файлы  (Прочитано 2082 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн -shark-

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • shark
  • Регистрация: 2015-10-29
    • Skype: akaipbay
  • Сайт: 
  • Профессия: Ученик 1С
Привет всем!

Подскажите как реализовать возможность прикрепления файлов в документе, чтобы позже можно было позже просматривать прикрепленные скрины, файлы всякого рода в каждом документе?

Что нужно для этого использовать?


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ХранилищеЗначений
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
В УПП есть кнопочка "Файлы". Можно прям там посмотреть как этот механизм работает.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Эта кнопочка есть практически в любой конфигурации. Но это ж надо посмотреть и разобраться...

Оффлайн -shark-

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • shark
  • Регистрация: 2015-10-29
    • Skype: akaipbay
  • Сайт: 
  • Профессия: Ученик 1С
В УПП есть кнопочка "Файлы". Можно прям там посмотреть как этот механизм работает.

К сожалению не имею такой конфигурации
Добавлено: 29 Окт 2015, 12:21

ХранилищеЗначений

А возможно ли реализовать это при помощи ActiveX? Тут один программист сказал что можно и через ActiveX.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
можно. можно 1С написать свое.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн -shark-

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • shark
  • Регистрация: 2015-10-29
    • Skype: akaipbay
  • Сайт: 
  • Профессия: Ученик 1С
можно. можно 1С написать свое.
Вопрос, можно ли использовать ActiveX на обычных формах?

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Конечно можно. только не понятно зачем. у вас это тормазить все будет. огогогого
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
С трудом представляю как ActiveX поможет в вопросе прикрепленных файлов.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Привет всем!

Подскажите как реализовать возможность прикрепления файлов в документе, чтобы позже можно было позже просматривать прикрепленные скрины, файлы всякого рода в каждом документе?

Что нужно для этого использовать?

Если именно ссылка на документ то для управляемых форм я делал так. Создавал реквизит "Прикрепить" тип строка.

Кнопка выбора "Да", Кнопка открытия "Да"


&НаКлиенте
Процедура ПрикрепитьОткрытие(Элемент, СтандартнаяОбработка)   
    СтандартнаяОбработка=Ложь;
    ЗапуститьПриложение(Объект.Прикрепить);
   // Вставить содержимое обработчика.
КонецПроцедуры


&НаКлиенте
Процедура ПрикрепитьНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
     СтандартнаяОбработка=Ложь;   
    Режим=  РежимДиалогаВыбораФайла.Открытие;
     ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
     ДиалогОткрытияФайла.ПолноеИмяФайла = "";
     Фильтр = "Файл (*.*)|*.*";
     ДиалогОткрытияФайла.Фильтр = Фильтр;
     ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
     ДиалогОткрытияФайла.Заголовок = "Выберите файлы";

 Если ДиалогОткрытияФайла.Выбрать() Тогда
       Объект.Прикрепить = ДиалогОткрытияФайла.ПолноеИмяФайла;
   КонецЕсли;
   // Вставить содержимое обработчика.
КонецПроцедуры

Последний раз редактировалось: Artjomrgv; 31 Окт 2015, 12:57


Теги:
 

Как "засунуть" файлы pkg в 1С 8.2

Автор domovenok1982Раздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 1232
Последний ответ 04 Июн 2015, 16:07
от LidiaLy
Внешняя обработка "Выгрузка зарплатных ведомостей в DBF-файлы"

Автор pavl_vsРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 5259
Последний ответ 17 Апр 2013, 19:16
от pavl_vs
Как размещать Файлы не в базе, а в отдельных, в том числе сетевых папках?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 500
Последний ответ 13 Янв 2017, 10:05
от LexaK
Как выгружать на диск файлы из ХранилищеЗначений - в цикле или запросом?

Автор метис метисРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 587
Последний ответ 27 Окт 2016, 16:22
от ilyay
Перекачка данных в DBF-файлы. Проблема с индексами.

Автор bobinnickРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4403
Последний ответ 13 Ноя 2010, 19:42
от bobinnick

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
164 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
87 Сообщений
alex0402
81 Сообщений
Golickoff Golickoff
31 Сообщений
ilyay ilyay
30 Сообщений
Kironten
29 Сообщений
BuhRust
26 Сообщений
AsadRoman
26 Сообщений
AIFrame
25 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal