Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 18:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: XML в регистр сведений 1с 8  (Прочитано 858 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн casper21

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-04
  • Сайт: 
  • Профессия: Программист 1С
Как загрузить некоторые данные из XML файла в 1с регистр сведений?
например
http://s020.radikal.ru/i721/1510/f0/345b56a1a243.png
Измерение(регистра сведений ):
1) Номер отделения - <Number>
2) Город-<CityDescription>
  Ресурс(регистра сведений ):
1) Время работы - <Reception>
2) Адрес - <Description>
3) МаксВантаж - <TotalMaxWeightAllowed>

это обработку нужно написать какую ??
       
ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("");
//Корень
ЧтениеXML.Прочитать();

Пока ВозможностьЧтенияДанных(ЧтениеXML) Цикл
Данные = ПрочитатьДанные(ЧтениеXML);
Данные.Записать();
КонецЦикла;
ЧтениеXML.Закрыть();
Помогите плз, или инфой как загружать, че писать.


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2640
  • РЕПУТАЦИЯ: 319
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
http://online.1c.ru/catalog/programs/program/18610119/

вам надо научится рабоатьть с XML и с регистром сведений
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн casper21

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-04
  • Сайт: 
  • Профессия: Программист 1С
пример какой бы о регистрах с XML
Добавлено: 29 Окт 2015, 00:08

или будет легче сначала в справочник? а затем в регистр сведений?
Добавлено: 29 Окт 2015, 18:22

вот так сделал, но выводит только одна запись.
То есть все перезаписывает - НаборЗаписей.Записать ()


Процедура КнопкаВыполнитьНажатие1(Кнопка)
    ОчиститьСообщения();
    НаборЗаписей = РегистрыСведений.НоваПошта.СоздатьМенеджерЗаписи().СоздатьНаборЗаписей();
    //НаборЗаписей.Отбор.УстановитьДоступныеПоля("Адреса");

    НаборЗаписей.Прочитать();
    НоваяЗапись = НаборЗаписей.Добавить();
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл("d:\vidpov.xml");
        Пока ЧтениеXML.Прочитать() Цикл
            Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
                Имя = ЧтениеXML.Имя;
            КонецЕсли;
                Если Имя = "Description" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                    НоваяЗапись.Адреса = ЧтениеXML.Значение; 
                    Сообщить(ЧтениеXML.Значение);
                КонецЕсли;
                    Если Имя = "Number" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                        НоваяЗапись.НомерВідділення = ЧтениеXML.Значение;
                        //НаборЗаписей.Записать();

                        Сообщить(ЧтениеXML.Значение);
                    КонецЕсли;
                        Если Имя = "CityDescription" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                            НоваяЗапись.Місто = ЧтениеXML.Значение;
                            //НаборЗаписей.Записать();

                            Сообщить(ЧтениеXML.Значение);
                        КонецЕсли;
                            Если Имя = "TotalMaxWeightAllowed" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                                НоваяЗапись.МаксимальнийВантаж = ЧтениеXML.Значение;
                            //    НаборЗаписей.Записать();

                                Сообщить(ЧтениеXML.Значение);
                            КонецЕсли;
        НаборЗаписей.Записать();
        КонецЦикла;
       
        ЧтениеXML.Закрыть();   
             
КонецПроцедуры


что сделать чтобы добавлялись все записи?
Добавлено: 30 Окт 2015, 11:36

Процедура КнопкаВыполнитьНажатие1(Кнопка)
    ОчиститьСообщения();   
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл("F:\Work\Taras-Ukraine\vidpov.xml");


    Пока ЧтениеXML.Прочитать() Цикл
            НоваяЗапись = РегистрыСведений.НоваПошта.СоздатьМенеджерЗаписи();
            Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
                Имя = ЧтениеXML.Имя;
            КонецЕсли;
                Если Имя = "Description" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                    НоваяЗапись.Адреса = ЧтениеXML.Значение; 
                    Сообщить(ЧтениеXML.Значение);
                КонецЕсли;
                    Если Имя = "Number" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                        НоваяЗапись.НомерВідділення = ЧтениеXML.Значение;
                        Сообщить(ЧтениеXML.Значение);
                    КонецЕсли;
                        Если Имя = "CityDescription" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                            НоваяЗапись.Місто = ЧтениеXML.Значение;                             
                            Сообщить(ЧтениеXML.Значение);
                        КонецЕсли;
                            Если Имя = "TotalMaxWeightAllowed" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                                НоваяЗапись.МаксимальнийВантаж = ЧтениеXML.Значение;                             
                                Сообщить(ЧтениеXML.Значение);
                            КонецЕсли;
        НоваяЗапись.Записать();
        КонецЦикла;
       
        ЧтениеXML.Закрыть();   
             
КонецПроцедуры


Ошибка{Форма.Форма.Форма (57)}: Ошибка при вызове метода контекста (Записать)
НоваяЗапись.Записать ();
через:
Нарушение прав доступа!

Что это может быть?

Последний раз редактировалось: casper21; 30 Окт 2015, 11:36. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
123 Сообщений
MuI_I_Ika MuI_I_Ika
53 Сообщений
Norfolk
52 Сообщений
LexaK
47 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
друган
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 543
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal