Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 09:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выгрузить в таблицу значений данные выборки с запроса  (Прочитано 3946 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, уважаемые коллеги. У меня задача - выгрузить в таблицу значений данные выборки с запроса еще с обходом результатов значений по группировке

Результат=Запрос2.Выполнить();
Вариант 1     
    Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ФизЛицо");
    ТаблицаПросмотраОРЗ = Новый ТаблицаЗначений;
    ТаблицаПросмотраОРЗ.ЗаполнитьЗначения(Выборка);
Результат - в ТЗ ничего нет.

В ТЗ не выгружается выборка даже без обхода результата то есть код
        Результат.Выбрать();
    ТаблицаПросмотраОРЗ = Новый ТаблицаЗначений;
    ТаблицаПросмотраОРЗ.ЗаполнитьЗначения(Выборка);
не работает!!

Вариант 2   
    Пока Выборка.Следующий() Цикл
    ТаблицаПросмотраОРЗ.ЗаполнитьЗначения(Выборка);
    КонецЦикла;
Тоже в ТЗ ничего нет


Вариант 3
ТЗ = Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам,"ФизЛицо"); выдает ошибку слишком много фактических параметров.

Подскажите пожалуйста. Заранее благодарен. Удачи Вам


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

ТЗ=Запрос.Выполнить().Выгрузить();//Выгружает запрос в ТЗ
ТЗ=Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам); //Выгрузка в дерево значений, если конечно есть в запросе секция "итоги"

//Заполнение ТЗ по выборке
ТЗ=Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("ФизЛицо");

Выборка=Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока Выборка.Следующий() Цикл
   НовСтрока=ТЗ.Добавить();
   ЗаполнитьЗначенияСвойств(НовСтрока,Выборка);

КонецЦикла;

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С

ТЗ=Запрос.Выполнить().Выгрузить();//Выгружает запрос в ТЗ
ТЗ=Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам); //Выгрузка в дерево значений, если конечно есть в запросе секция "итоги"

//Заполнение ТЗ по выборке
ТЗ=Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("ФизЛицо");

Выборка=Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока Выборка.Следующий() Цикл
   НовСтрока=ТЗ.Добавить();
   ЗаполнитьЗначенияСвойств(НовСтрока,Выборка);

КонецЦикла;

Витас большое спасибо


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 10651
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4645
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3482
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 7118
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6344
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal