Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 16:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расшифровка с параметром СписокЗначения  (Прочитано 781 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 88
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн AIFrame

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)
Выборка = Запрос.Выполнить.Выгрузить();
Пока Выборка.Следующий() Цикл
...
КонецЦикла;
Если речь об этом.

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 88
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)
Выборка = Запрос.Выполнить.Выгрузить();
Пока Выборка.Следующий() Цикл
...
КонецЦикла;
Если речь об этом.

Нет.Может я не так выразился. Нужно что бы при двойном клике ячейки в отчете появлялось окно с новым отчетом. В которое передавались параметры расшифровки (Номенклатура и склад) и именно по ним формируется расшифровка. Вопрос как передать эти параметры в параметр расшифровки ячеек.)

Оффлайн AIFrame

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)
Выборка = Запрос.Выполнить.Выгрузить();
Пока Выборка.Следующий() Цикл
...
КонецЦикла;
Если речь об этом.

Нет.Может я не так выразился. Нужно что бы при двойном клике ячейки в отчете появлялось окно с новым отчетом. В которое передавались параметры расшифровки (Номенклатура и склад) и именно по ним формируется расшифровка. Вопрос как передать эти параметры в параметр расшифровки ячеек.)
Отчет внешний?

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 88
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)
Выборка = Запрос.Выполнить.Выгрузить();
Пока Выборка.Следующий() Цикл
...
КонецЦикла;
Если речь об этом.

Нет.Может я не так выразился. Нужно что бы при двойном клике ячейки в отчете появлялось окно с новым отчетом. В которое передавались параметры расшифровки (Номенклатура и склад) и именно по ним формируется расшифровка. Вопрос как передать эти параметры в параметр расшифровки ячеек.)
Отчет внешний?
Да. Типовая УПП 1,3

Оффлайн AIFrame

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день Всем.Изучаю 1с не так давно. Пытаюсь сделать расшифровку отчета по нескольким параметрам. Может есть какой нибудь простой пример как это сделать. Знаю что нужно параметры поместить в СписокЗначений. Но как это сделать? Помогите)
Выборка = Запрос.Выполнить.Выгрузить();
Пока Выборка.Следующий() Цикл
...
КонецЦикла;
Если речь об этом.

Нет.Может я не так выразился. Нужно что бы при двойном клике ячейки в отчете появлялось окно с новым отчетом. В которое передавались параметры расшифровки (Номенклатура и склад) и именно по ним формируется расшифровка. Вопрос как передать эти параметры в параметр расшифровки ячеек.)
Отчет внешний?
Да. Типовая УПП 1,3
Справочник.ВнешниеОбработки.Форма.ФормаСписка.Форма.Модуль
Обрати внимание на АДМ +
Процедура СправочникСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)

Если Не ВыбраннаяСтрока.ЭтоГруппа Тогда

ЭтоОбработка = ?(ВыбраннаяСтрока.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка, Истина, Ложь);
ЭтоОтчет = ?(ВыбраннаяСтрока.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет, Истина, Ложь);

Если НЕ (ЭтоОбработка ИЛИ ЭтоОтчет) Тогда
Возврат;
КонецЕсли;


//И ВыбраннаяСтрока.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка Тогда

Попытка

ИмяФайла = ПолучитьИмяВременногоФайла();
ДвоичныеДанные = ВыбраннаяСтрока.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);

Если ЭтоОбработка Тогда

Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);

Иначе

Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);

КонецЕсли;

Если Не Форма = Неопределено Тогда

Форма.Открыть();

Иначе

Если ЭтоОбработка Тогда
ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла);
Иначе
ВнешнийОтчет = ВнешниеОтчеты.Создать(ИмяФайла);
КонецЕсли;

КонецЕсли;

Если НЕ ЭтоОтчет Тогда  // АДМ+++
УдалитьФайлы(ИмяФайла);
КонецЕсли; // АДМ+++

Исключение

Если ЭтоОбработка Тогда

Предупреждение("Выбранный файл не является внешней обработкой.
   |Либо, данная обработка не предназначена для
   |запуска в этой конфигурации.");
Иначе
Предупреждение("Выбранный файл не является внешним отчетом.
   |Либо, данный отчет не предназначена для
   |запуска в этой конфигурации.");
КонецЕсли;

КонецПопытки;

СтандартнаяОбработка = Ложь;

КонецЕсли;

КонецПроцедуры

Оффлайн Пустовалов Артем

  • **
  • Сообщений: 88
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2015-10-14
  • Сайт: 
  • Профессия: Ученик 1С
Что то но не то )
Добавлено: 29 Окт 2015, 14:36

Как говорится посидел покапался пару дней и нашел решение.:zebzdr: Передаю данные в расшифровку через Структуру.
Вот код если кому то пригодится

ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;   
   Макет = ВнешнийОтчетОбъект.ПолучитьМакет("Отчет");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад,
   |   ТоварыНаСкладахОстаткиИОбороты.Номенклатура,
   |   ЦеныНоменклатурыСрезПоследних.Цена,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток * (ЦеныНоменклатурыСрезПоследних.Цена * ЦеныНоменклатурыСрезПоследних.ЕдиницаИзмерения.Коэффициент / ТоварыНаСкладахОстаткиИОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК СуммаНачальная,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход КАК КоличествоПриход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход * (ЦеныНоменклатурыСрезПоследних.Цена * ЦеныНоменклатурыСрезПоследних.ЕдиницаИзмерения.Коэффициент / ТоварыНаСкладахОстаткиИОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК СуммаПриход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход КАК КоличествоРасход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход * (ЦеныНоменклатурыСрезПоследних.Цена * ЦеныНоменклатурыСрезПоследних.ЕдиницаИзмерения.Коэффициент / ТоварыНаСкладахОстаткиИОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК СуммаРасход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток * (ЦеныНоменклатурыСрезПоследних.Цена * ЦеныНоменклатурыСрезПоследних.ЕдиницаИзмерения.Коэффициент / ТоварыНаСкладахОстаткиИОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК СуммаКонечная,
   |   ЦеныНоменклатурыСрезПоследних.Валюта
   |ПОМЕСТИТЬ ВеменныеОст
   |ИЗ
   |   РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(
   |         &НачалоПериода,
   |         &КонецПериода,
   |         ,
   |         ,
   |         Склад = &Склад
   |            ИЛИ &Склад = ЗНАЧЕНИЕ(Справочник.Склады.ПустаяСсылка)) КАК ТоварыНаСкладахОстаткиИОбороты
   |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонецПериода, ТипЦен = &ТипЦен) КАК ЦеныНоменклатурыСрезПоследних
   |      ПО ТоварыНаСкладахОстаткиИОбороты.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура
   |;
   |
   |////////////////////////////////////////////////////////////////////////////////
   |ВЫБРАТЬ
   |   ВеменныеОст.Склад КАК Склад,
   |   ВеменныеОст.Номенклатура,
   |   ВеменныеОст.Цена,
   |   ВеменныеОст.КоличествоНачальныйОстаток,
   |   СУММА(ВеменныеОст.СуммаНачальная * КурсыВалютСрезПоследних.Курс) КАК СуммаНачальная,
   |   ВеменныеОст.КоличествоПриход,
   |   СУММА(ВеменныеОст.СуммаПриход * КурсыВалютСрезПоследних.Курс) КАК СуммаПриход,
   |   ВеменныеОст.КоличествоРасход,
   |   СУММА(ВеменныеОст.СуммаРасход * КурсыВалютСрезПоследних.Курс) КАК СуммаРасход,
   |   ВеменныеОст.КоличествоКонечныйОстаток,
   |   СУММА(ВеменныеОст.СуммаКонечная * КурсыВалютСрезПоследних.Курс) КАК СуммаКонечная
   |ИЗ
   |   ВеменныеОст КАК ВеменныеОст
   |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КурсыВалют.СрезПоследних(&КонецПериода, ) КАК КурсыВалютСрезПоследних
   |      ПО ВеменныеОст.Валюта = КурсыВалютСрезПоследних.Валюта
   |
   |СГРУППИРОВАТЬ ПО
   |   ВеменныеОст.Склад,
   |   ВеменныеОст.Номенклатура,
   |   ВеменныеОст.Цена,
   |   ВеменныеОст.КоличествоНачальныйОстаток,
   |   ВеменныеОст.КоличествоПриход,
   |   ВеменныеОст.КоличествоРасход,
   |   ВеменныеОст.КоличествоКонечныйОстаток
   |
   |УПОРЯДОЧИТЬ ПО
   |   Склад
   |ИТОГИ ПО
   |   Склад
   |АВТОУПОРЯДОЧИВАНИЕ";
   
   Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
   Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
   Запрос.УстановитьПараметр("Склад", Склад);
   Запрос.УстановитьПараметр("ТипЦен", ТипЦен);
      
   РезультатЗапроса = Запрос.Выполнить();
   
   ОбластьЗаголовок = Макет.ПолучитьОбласть           ("Заголовок");
   

   ОбластьПодвал = Макет.ПолучитьОбласть              ("Подвал");
   ОбластьШапкаТаблицы = Макет.ПолучитьОбласть           ("ШапкаТаблицы|Основа");
   ОбластьШапкаТаблицыСклады = Макет.ПолучитьОбласть    ("ШапкаТаблицы|СкладКолонки");
   ОбластьПодвалТаблицы = Макет.ПолучитьОбласть        ("ПодвалТаблицы");
   ОбластьОбщийИтог = Макет.ПолучитьОбласть           ("ОбщиеИтоги");
   ОбластьСкладОснова =  Макет.ПолучитьОбласть           ("Склад|Основа");
   ОбластьСклад = Макет.ПолучитьОбласть              ("Склад|СкладКолонки");
   ОбластьДетальныхЗаписейОснова = Макет.ПолучитьОбласть("Детали|Основа");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть       ("Детали|СкладКолонки");
   ПустаяОбласть = Макет.ПолучитьОбласть             ("ПустаяОбласть | СкладКолонки");
   
   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.НачатьАвтогруппировкуСтрок();
      
   ВыборкаСклад = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   ТабДок.Вывести(ОбластьШапкаТаблицы);
   
   Пока ВыборкаСклад.Следующий() Цикл                                                  /// шапка
      ОбластьШапкаТаблицыСклады.Параметры.Заполнить(ВыборкаСклад);
      ТабДок.Присоединить(ОбластьШапкаТаблицыСклады,ВыборкаСклад.Уровень());
   КонецЦикла;
   
   ВыборкаСклад.Сбросить(); //= РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
   Пока ВыборкаСклад.Следующий() Цикл
      ВыборкаДетальныеЗаписи = ВыборкаСклад.Выбрать();
         Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         
         ОбластьДетальныхЗаписейОснова.Параметры.Заполнить(ВыборкаДетальныеЗаписи); //Детали основа
         
         Расшифровка = Новый Структура;
         Расшифровка.Вставить("Номенклатура",ВыборкаДетальныеЗаписи.Номенклатура);
         Расшифровка.Вставить("Склад",ВыборкаДетальныеЗаписи.Склад);                  //Расшифровка
         ОбластьДетальныхЗаписейОснова.Параметры.Расшифровка = Расшифровка;
         
         ТабДок.вывести(ОбластьДетальныхЗаписейОснова, ВыборкаДетальныеЗаписи.Уровень());
         
         ВыборкаСклад1 = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Склад");
         
         Пока ВыборкаСклад1.Следующий() Цикл
            Если  ВыборкаСклад1.Склад = ВыборкаСклад.Склад Тогда
            ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи); //ДеталиСклад
         //Расшифровка!!!В макете параметрРасшифровки      
         Расшифровка = Новый Структура;
         Расшифровка.Вставить("Номенклатура",ВыборкаДетальныеЗаписи.Номенклатура);
                   Расшифровка.Вставить("Склад",ВыборкаДетальныеЗаписи.Склад);                               
                   ОбластьДетальныхЗаписей.Параметры.Расшифровка = Расшифровка;

            ТабДок.Присоединить(ОбластьДетальныхЗаписей); Иначе
               ТабДок.Присоединить(ПустаяОбласть);
            КонецЕсли;
         КонецЦикла
      КонецЦикла;
      
   конецЦикла;
   
    ВыборкаСклад.Сбросить();
    ВыборкаДетальныеЗаписи.Сбросить();
   
   ТабДок.ЗакончитьАвтогруппировкуСтрок();
   ТабДок.Вывести(ОбластьПодвалТаблицы);
   ТабДок.Вывести(ОбластьПодвал);
 

Последний раз редактировалось: Пустовалов Артем; 29 Окт 2015, 14:36. Причина: Объединение сообщений


Теги:
 

Отчет - расшифровка по статье затрат "услуги автотранспорта"

Автор marismurРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2124
Последний ответ 22 Авг 2014, 14:36
от morph1991
Расшифровка в отчете на СКД, который вызывается из формы справочника(управляемые формы)

Автор anna_vsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 2815
Последний ответ 09 Дек 2015, 14:39
от vitasw
ОСВ по 20 счету (отсутствует расшифровка статей затрат на конец месяца )

Автор ирина56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3717
Последний ответ 02 Апр 2013, 17:23
от MuI_I_Ika
Расшифровка по Регистратору на СКД не получается оформить макет

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 204
Последний ответ 29 Сен 2016, 15:19
от ZSS
расшифровка ячейки счет-фактуры

Автор ruslan_k-1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 2835
Последний ответ 17 Окт 2010, 23:15
от progmikon

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
158 Сообщений
alex0402
61 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
32 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal