Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 03:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибки в коде при нажатии обновить конф БД  (Прочитано 763 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Adam_88

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-27
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   Для Каждого СтрокаТабличнойЧасти Из СписокКниг Цикл
      мЗапрос = Новый Запрос;
      мЗапрос.Текст =
      "ВЫБРАТЬ
      |   КнигиУЧитателейОстатки.КоличествоОстаток
      |ИЗ
      |   РегистрНакопления.КнигиУЧитателей.Остатки(&ДатаДокумента, ) КАК КнигиУЧитателейОстатки
      |ГДЕ
      |   КнигиУЧитателейОстатки.Книга = &Книга
      |   И КнигиУЧитателейОстатки.Читатель = &Читатель";
      мЗапрос.УстановитьПараметр("Книга",СтрокаТабличнойЧасти.Книга);
      мЗапрос.УстановитьПараметр("Читатель",Читатель);
      Результат = мЗапрос.Выполнить();
      ВыборкаИзЗапроса = Результат.Выбрать();
      Если ВыборкаИзЗапроса.Следующий(); Тогда
         Если СтрокаТабличнойЧасти.Количество > ВыборкаИзЗапроса.КоличествоОстаток Тогда
            Сообщить("Книга "+СтрокаТабличнойЧасти.Книга+ " была выдана в меньшем количестве");
            Отказ = Истина;
         КонецЕсли;
      Иначе
         Сообщить("Книга "+СтрокаТабличнойЧасти.Книга+ " не была выдана");
         Отказ = Истина;   
      КонецЕсли;
   КонецЦикла;   
      
КонецПроцедуры


Нажимаю обновить конф БД и выдает:

{Документ.ВозвратКниг.МодульОбъекта(48,36)}: Ожидается ключевое слово 'Тогда' ('Then')
      Если ВыборкаИзЗапроса.Следующий()<<?>>; Тогда (Проверка: Толстый клиент (обычное приложение))
{Документ.ВозвратКниг.МодульОбъекта(48,38)}: Неопознанный оператор
      Если ВыборкаИзЗапроса.Следующий(); <<?>>Тогда (Проверка: Толстый клиент (обычное приложение))
{Документ.ВозвратКниг.МодульОбъекта(48,43)}: Ожидается символ ';'
      Если ВыборкаИзЗапроса.Следующий(); Тогда<<?>> (Проверка: Толстый клиент (обычное приложение))
{Документ.ВозвратКниг.МодульОбъекта(53,3)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
      <<?>>Иначе  (Проверка: Толстый клиент (обычное приложение))
{Документ.ВозвратКниг.МодульОбъекта(57,13)}: Обнаружено логическое завершение исходного текста модуля
   КонецЦикла;<<?>>    (Проверка: Толстый клиент (обычное приложение))






 


Оффлайн DmitriyF

  • *****
  • Сообщений: 706
  • РЕПУТАЦИЯ: 43
  • КПД: 6%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Adam_88, УФ или как?? и Запрос в цикле ой как не хорошо.
Добавлено: 27 Окт 2015, 00:28

Если ВыборкаИзЗапроса.Следующий(); Тогда       точка с запятой лтшняя

Оффлайн Adam_88

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-27
  • Сайт: 
  • Профессия: Ученик 1С
Помогли, спасибо.
Добавлено: 27 Окт 2015, 13:36

Цитировать
УФ или как??
Честно сказать не понял. НЕ судите строго.

Последний раз редактировалось: Adam_88; 27 Окт 2015, 13:36. Причина: Объединение сообщений


Теги: ошибка  код 
 

Как отловить возникновение ошибки "Данные были изменены или удалены другим пользователем"

Автор bkmz_1_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 624
Последний ответ 18 Июл 2016, 12:56
от MuI_I_Ika
Обновить нетиповую конфигурацию конфигурацию

Автор JOGРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 858
Последний ответ 16 Янв 2017, 16:09
от LexaK
Исправила в форме авансового отчета и теперь выдает ошибки при открытии авансового док-та

Автор komarova ninaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2006
Последний ответ 02 Мар 2015, 11:39
от komarova nina
Ошибки в счете-фактуре, касающиеся номера таможенной декларации и страны происхождения товара, не считаются основанием для официального отказа в вычете НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1050
Последний ответ 03 Фев 2015, 13:16
от news
чем отличается сохранить конфигурацию от обновить конфигурацию?

Автор John_ConnorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2781
Последний ответ 31 Янв 2014, 15:08
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
79 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
42 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
xproh
21 Сообщений

* Кто онлайн

  • Точка Гостей: 157
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal