Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Июл 2017, 21:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Группа строк в отчете  (Прочитано 445 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Есть отчет с макетом. Могу свернуть только по типу денежных средств, а вот по организациям не получается свернуть в отчете. Подскажите как это сделать!

P.S. Не ругайте за код, так как изначально была группировка по организациям, только начал переделывать.

	ВыборкаКлиент = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Первый = Истина;

Пока ВыборкаКлиент.Следующий() Цикл

Если Не Первый тогда
ТабДок.ЗакончитьГруппуСтрок();
КонецЕсли;
Первый=Ложь;

ОбластьОрганизации.Параметры.Организация = ВыборкаКлиент.ВидДенежныхСредств;
ОбластьОрганизации.Параметры.НачОст = ВыборкаКлиент.НачальныйОстаток;
ОбластьОрганизации.Параметры.Приход = ВыборкаКлиент.Приход;
ОбластьОрганизации.Параметры.Расход = ВыборкаКлиент.Расход;
ОбластьОрганизации.Параметры.КонОст = ВыборкаКлиент.КонечныйОстаток;
ТабДок.Вывести(ОбластьОрганизации);

ТабДок.НачатьГруппуСтрок();

ВыборкаВид = ВыборкаКЛиент.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаВид.Следующий() Цикл
ОбластьВидКасс.Параметры.ВидКассы = ВыборкаВид.Организация;
ОбластьВидКасс.Параметры.НачОст = ВыборкаВид.НачальныйОстаток;
ОбластьВидКасс.Параметры.Приход = ВыборкаВид.Приход;
ОбластьВидКасс.Параметры.Расход = ВыборкаВид.Расход;
ОбластьВидКасс.Параметры.КонОст = ВыборкаВид.КонечныйОстаток;
ТабДок.Вывести(ОбластьВидКасс);

ВыборкаУслуги = ВыборкаВид.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаУслуги.Следующий() Цикл
ОбластьКассыСчета.Параметры.КассаСчет = ВыборкаУслуги.БанковскийСчетКасса;
ОбластьКассыСчета.Параметры.НачОст = ВыборкаУслуги.НачальныйОстаток;
ОбластьКассыСчета.Параметры.Приход = ВыборкаУслуги.Приход;
ОбластьКассыСчета.Параметры.Расход = ВыборкаУслуги.Расход;
ОбластьКассыСчета.Параметры.КонОст = ВыборкаУслуги.КонечныйОстаток;
ТабДок.Вывести(ОбластьКассыСчета);
КонецЦикла;

КонецЦикла;

КонецЦикла;


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 224
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 945
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 295
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 6393
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1050
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
140 Сообщений
alex0402
112 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
51 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
43 Сообщений
wise wise
40 Сообщений
ab30ru
38 Сообщений
Амал
35 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 305
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal