Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Май 2017, 12:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: БУХ редакция 3.0 (3.0.42.45) РФ Ошибка обновления  (Прочитано 1309 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Witoldowi4

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-26
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день. После обновления 1С на 3.0 3.0 (3.0.42.45)  возникла проблема данного характера :
При попытке обновления, сравнивали нашу доработанную с типовым релизом (3.0.42.45). Обновление не выполнилось по причине:
{ОбщийМодуль.ОбщегоНазначения.Модуль(2553)}: Неизвестный тип объекта метаданных "Документ.УведомлениеОСпецрежимахНалогообложения"
ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Неизвестный тип объекта метаданных ""%1""'"), ПолноеИмя);

Было принято решение накатывать наши доработки на типовую обновленную конфигурацию. Обновление проходит без ошибок.
После обновления при использовании обработки "Обновление вспомогательных данных" возникает та же ошибка  'Неизвестный тип объекта метаданных ".
Выкидывает в данный модуль и вызывается исключение , по документу не определяется менеджер объекта.
Функция МенеджерОбъектаПоПолномуИмени(ПолноеИмя) Экспорт

   Перем КлассОМ, ИмяОМ, Менеджер;
   ЧастиИмени = СтрРазделить(ПолноеИмя, ".");
   
   Если ЧастиИмени.Количество() >= 2 Тогда
      КлассОМ = ЧастиИмени[0];
      ИмяОМ  = ЧастиИмени[1];
   КонецЕсли;
   
   Если      ВРег(КлассОМ) = "ПЛАНОБМЕНА" Тогда
      Менеджер = ПланыОбмена;
      
   ИначеЕсли ВРег(КлассОМ) = "СПРАВОЧНИК" Тогда
      Менеджер = Справочники;
      
   ИначеЕсли ВРег(КлассОМ) = "ДОКУМЕНТ" Тогда
      Менеджер = Документы;
      
   ИначеЕсли ВРег(КлассОМ) = "ЖУРНАЛДОКУМЕНТОВ" Тогда
      Менеджер = ЖурналыДокументов;
      
   ИначеЕсли ВРег(КлассОМ) = "ПЕРЕЧИСЛЕНИЕ" Тогда
      Менеджер = Перечисления;
      
   ИначеЕсли ВРег(КлассОМ) = "ОТЧЕТ" Тогда
      Менеджер = Отчеты;
      
   ИначеЕсли ВРег(КлассОМ) = "ОБРАБОТКА" Тогда
      Менеджер = Обработки;
      
   ИначеЕсли ВРег(КлассОМ) = "ПЛАНВИДОВХАРАКТЕРИСТИК" Тогда
      Менеджер = ПланыВидовХарактеристик;
      
   ИначеЕсли ВРег(КлассОМ) = "ПЛАНСЧЕТОВ" Тогда
      Менеджер = ПланыСчетов;
      
   ИначеЕсли ВРег(КлассОМ) = "ПЛАНВИДОВРАСЧЕТА" Тогда
      Менеджер = ПланыВидовРасчета;
      
   ИначеЕсли ВРег(КлассОМ) = "РЕГИСТРСВЕДЕНИЙ" Тогда
      Менеджер = РегистрыСведений;
      
   ИначеЕсли ВРег(КлассОМ) = "РЕГИСТРНАКОПЛЕНИЯ" Тогда
      Менеджер = РегистрыНакопления;
      
   ИначеЕсли ВРег(КлассОМ) = "РЕГИСТРБУХГАЛТЕРИИ" Тогда
      Менеджер = РегистрыБухгалтерии;
      
   ИначеЕсли ВРег(КлассОМ) = "РЕГИСТРРАСЧЕТА" Тогда
      Если ЧастиИмени.Количество() = 2 Тогда
         // Регистр расчета
         Менеджер = РегистрыРасчета;
      Иначе
         КлассПодчиненногоОМ = ЧастиИмени[2];
         ИмяПодчиненногоОМ = ЧастиИмени[3];
         Если ВРег(КлассПодчиненногоОМ) = "ПЕРЕРАСЧЕТ" Тогда
            // Перерасчет
            Попытка
               Менеджер = РегистрыРасчета[ИмяОМ].Перерасчеты;
               ИмяОм = ИмяПодчиненногоОМ;
            Исключение
               Менеджер = Неопределено;
            КонецПопытки;
         КонецЕсли;
      КонецЕсли;
      
   ИначеЕсли ВРег(КлассОМ) = "БИЗНЕСПРОЦЕСС" Тогда
      Менеджер = БизнесПроцессы;
      
   ИначеЕсли ВРег(КлассОМ) = "ЗАДАЧА" Тогда
      Менеджер = Задачи;
      
   ИначеЕсли ВРег(КлассОМ) = "КОНСТАНТА" Тогда
      Менеджер = Константы;
      
   ИначеЕсли ВРег(КлассОМ) = "ПОСЛЕДОВАТЕЛЬНОСТЬ" Тогда
      Менеджер = Последовательности;
   КонецЕсли;
   
   Если Менеджер <> Неопределено Тогда
      Попытка
         Возврат Менеджер[ИмяОМ]; (файл "Ошибка2 " в ТЗ значение пустое !)
      Исключение
         Менеджер = Неопределено;
      КонецПопытки;
   КонецЕсли;
   
   ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Неизвестный тип объекта метаданных ""%1""'"), ПолноеИмя);

Возможно кто сталкивался с данной проблемой ?

 


Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Документ.УведомлениеОСпецрежимахНалогообложения
Такой вообще в конфе есть? Ваш кэп.

Оффлайн 161a

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-10-22
  • Сайт: 
  • Профессия: Программист 1С
Документ.УведомлениеОСпецрежимахНалогообложения
Такой вообще в конфе есть? Ваш кэп.

есть!
такая ж хрень!!! бъюсь уже который день...ui;;t; ui;;t; :dfbsdfbsdf:
может кто решил?


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3970
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5234
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3560
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6701
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 7652
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
wise wise
64 Сообщений
MuI_I_Ika MuI_I_Ika
50 Сообщений
Dethmontt Dethmontt
49 Сообщений
alex0402
43 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
30 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 977
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal