Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение табличной части документа  (Прочитано 8223 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Davids

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-12-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! 1с предприятие v 7.70.025. Мне нужно чтоб при открытии документа автоматически заполнились два табличных реквизита: Наименование и должность. заполнение происходит из справочника с одноименными реквизитами. возможно ли это реализовать в "процедуре приоткрытии" , и если да, то в каком модуле? спасибо..


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
можно.
в модуле формы.
какой документ?
из какого справочника?
зачем надо? конечную цель озвучте (может совсем другое надо).

Оффлайн Davids

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-12-05
  • Сайт: 
  • Профессия: Ученик 1С
документ "карточка учета выполненной работы".. за месяц по сотрудникам... из справочника сотрудники выбирается список сотрудников и их должность, и затем, в каждой строке(напротив ФИО сотрудника) заполняется количество выполненных работ по столбцам.. поэтому хочется чтоб при открытии сформировался список сотрудников..

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
правильно хочется...
если вопросы есть, то завтра с утра покумекаем если непротив.

Оффлайн Davids

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-12-05
  • Сайт: 
  • Профессия: Ученик 1С
да конечно не против) вот что пробую я:
Процедура ПриОткрытии()
   Справ=СоздатьОбъект("Справочник.сотрудники");
   ВыбратьСтроки();
   Пока ПолучитьСтроку()=1 Цикл
   наименование=Справ.Наименование;
   должность=справ.должность;
   КонецЦикла
КонецПроцедуры
но документ открывается пустым(

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Пока ПолучитьСтроку()=1 Цикл
Активизироватьстроку()
...
бла бла бла
...
КонецЦикла;
Записать();
КонецПроцедуры

Оффлайн Davids

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-12-05
  • Сайт: 
  • Профессия: Ученик 1С
Пока ПолучитьСтроку()=1 Цикл
Активизироватьстроку()
...
бла бла бла
...
КонецЦикла;
Записать();
КонецПроцедуры
все равно не выводит..прописал в модуле формы..

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
сорри
Пока ПолучитьСтроку()=1 Цикл
Активизироватьстроку()
...
бла бла бла
...
Записать();

КонецЦикла;
КонецПроцедуры

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
а строки в документе есть уже (до открытия)?

Оффлайн Davids

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-12-05
  • Сайт: 
  • Профессия: Ученик 1С
нет..документ только начинает создаваться.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 224
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal