Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 22:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с задачей про Excel. Хочу научиться.  (Прочитано 966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KoRNeT46

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Программист 8.1
Короче пытаюсь сделать одну хреновину... Сразу напишу, чтоб не было, мол вот лошара, нубокодер и т.п., я только учусь и хочу научиться.
В общем суть задания сделать внешнюю обработку, которая загружает экселевский файл в табличную часть. Для того, чтобы проверить читает ли вообще эксель, нашел свойство, которое якобы, по описанию загоняет данные в массив. Но нефига не работает. Прикреплю обработку и код. Может поможет кто разобраться. Чисто для себя. Научиться с этим работать
роцедура ПутьНачалоВыбора(Элемент, СтандартнаяОбработка)
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите каталог";
    Если Диалог.Выбрать() Тогда
        ЭлементыФормы.Путь.Значение = Диалог.ПолноеИмяФайла;
    КонецЕсли;
КонецПроцедуры
 
Процедура ЗагрузитьНажатие(Элемент)
    ТабличныйДокумент.Очистить();
    //ТабличныйДокумент.Колонки.Очистить();
    ЭлементыФормы.ТабличныйДокумент.Колонки.Очистить();
   
    Попытка
        ПодключениеЭксель = Новый COMОбъект("Excel.Application");
        ПодключениеЭксель.WorkBooks.Open(Путь.Значение);
        Книга = ПодключениеЭксель.WorkSheets(1);
       
        //пытаюсь загнать в массив, чтоб проверить чтение файла
        Массив = Книга.UsedRange.Value;
       
        Состояние("Обработка данных Exel.....");
    Исключение
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Ошибка загрузки!";
        Сообщение.Текст = ОписаниеОшибки();
        Сообщение.Сообщить();
    КонецПопытки;
КонецПроцедуры


Оффлайн Каримдат

  • ****
  • Сообщений: 285
  • РЕПУТАЦИЯ: 20
  • КПД: 7%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Ты пытаешься сам себе разжевать что и почему не работает? Просмотреть уже готовую обработку и понять что и как работает, ты не желаешь? ЗагрузкаДанныхИзТабличногоДокумента, на диске ИТС есть.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
101 Сообщений
AIFrame
78 Сообщений
alex0402
33 Сообщений
kiksi
30 Сообщений
pavl_vs
24 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 250
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal