Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Непонятки с записью в регистр сведений  (Прочитано 709 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Одинэсник

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Ученик 1С
В конфе ЗУП 2.5 на платформе 8.3.5.1517

Добавляю в регистр сведений ШтатноеРасписаниеОрганизаций дополнительный ресурс (КодКлетки), ставлю его на форму, задаю ему значение. После вызова процедуры ЗаполнитьТекущимСостоянием мой реквизит почему то остается незаполненным, хотя остальные значения записи измерений и ресурсов, переносятся.

Даже более того, Закомментировал строку. После этого запускаю процедуру заполнения штатного расписания и получаю как на приложенной картинке! Ничего не понимаю как это работает

Процедура ДействияФормыЗаполнитьТекущимСостоянием(Кнопка)

Если Организация.Пустая() Тогда
Сообщить(ОбщегоНазначенияЗК.ПреобразоватьСтрокуИнтерфейса("Не указана организация!"));
Возврат;
КонецЕсли;

Период = ОбщегоНазначенияЗК.ПолучитьРабочуюДату();
Если Не ВвестиДату(Период, "Дата действия штатного расписания", ЧастиДаты.Дата) Тогда
Возврат;
КонецЕсли;

ТекстВопроса = "Перед заполнением текущее штатное расписание на дату: " + Формат(Период, "ДФ=dd.MM.yyyy") + " будет обновлено. Продолжить?";
Если Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
Возврат;
КонецЕсли;

Набор = РегистрыСведений.ШтатноеРасписаниеОрганизаций.СоздатьНаборЗаписей();
Набор.Отбор.Период.Значение = Период;
Набор.Отбор.Период.Использование = Истина;

Набор.Автозаполнение(Организация,Период);
Если Набор.Количество() > 0 Тогда
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Период", Период);
Запрос.Текст =
"ВЫБРАТЬ
| ШтатноеРасписаниеОрганизаций.Период,
| ШтатноеРасписаниеОрганизаций.ПодразделениеОрганизации,
| ШтатноеРасписаниеОрганизаций.Должность,
| ШтатноеРасписаниеОрганизаций.КоличествоСтавок,
| ШтатноеРасписаниеОрганизаций.МинимальнаяТарифнаяСтавка,
| ШтатноеРасписаниеОрганизаций.МаксимальнаяТарифнаяСтавка,
| ШтатноеРасписаниеОрганизаций.ВидТарифнойСтавки,
| ШтатноеРасписаниеОрганизаций.ГрафикРаботы,
| ШтатноеРасписаниеОрганизаций.ВалютаТарифнойСтавки,
| ШтатноеРасписаниеОрганизаций.ОсобыеУсловияТруда,
    | ШтатноеРасписаниеОрганизаций.КодКлетки,
| ШтатноеРасписаниеОрганизаций.Категория
|ИЗ
| РегистрСведений.ШтатноеРасписаниеОрганизаций КАК ШтатноеРасписаниеОрганизаций
|ГДЕ
| ШтатноеРасписаниеОрганизаций.ПодразделениеОрганизации.Владелец <> &Организация
| И ШтатноеРасписаниеОрганизаций.Период = &Период";

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
    //ЗаполнитьЗначенияСвойств(Набор.Добавить(),Выборка);
КонецЦикла;
Набор.Записать(Истина);
КонецЕсли;

КонецПроцедуры


https://disk.yandex.ru/client/disk%7Cslider/disk/P1.png


Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Не понимаю, что делает эта процедура вообщем, но
где собственно редактирование то?
Набор.КодКлетки = Что-то;

Оффлайн Одинэсник

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Ученик 1С
А где собственно редактирование то?
Набор.КодКлетки = Что-то;

Открываю форму списка штатного расписания. Редактирую запись, задавая значение КодКлетки. Затем вызываю процедуру ДействияФормыЗаполнитьТекущимСостоянием. Данные типа вилки окладов(см. картинку) переносятся в новые записиЮ а значения моего поля - нет. Вопрос: что не так?

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
1. Откройте скрин для просмотра по ссылке.
2. Выложите пожалуйста структуру регистра(скрин)
3. При сохранении записи значение попадает в регистр?
Если я Вам помог, нажми - Спасибо!


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4857
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7760
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9386
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 523
Последний ответ 11 Сен 2017, 10:50
от ilyay
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14373
Последний ответ 11 Янв 2011, 10:04
от nomer13

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal