Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как задать условие, чтоб выбор был выполнен в зависимости от типа документа  (Прочитано 1377 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, коллеги.
Помогите в таком вопросе.
В коде есть запрос из регистра накопления
Тут используются в качестве регистраторов два документа - Продажа и ВозвратЧека
В обработке есть условие.
В зависимости от типа документа в поле регистра накопления записывается соответствующее значение
Вот фрагмент кода:

+ Code
Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ПродажиРозница.Регистратор,
                   |    ПродажиРозница.Период
                   |ИЗ
                   |    РегистрНакопления.ПродажиРозница КАК ПродажиРозница
                   |ГДЕ
                   |    ПродажиРозница.Период МЕЖДУ &ДатаНачала И &ДатаОкончания";
    Запрос.УстановитьПараметр("ДатаНачала",ДатаНачала);               
    Запрос.УстановитьПараметр("ДатаОкончания",ДатаОкончания);
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() цикл
        Набор = РегистрыНакопления.ПродажиРозница.СоздатьНаборЗаписей();
        Набор.Отбор.Регистратор.Значение = Выборка.Регистратор;
        Набор.Прочитать();
       
        Для Каждого ТекЗапись из Набор Цикл
            ТекЗапись.Рекомендованный = Неопределено;
            ТекЗапись.ФормаРасчетов=ТекЗапись.Регистратор.ФормаВзаиморасчетов;
           
                //ТипЗнч(Выборка.Регистратор) = Тип("Неопределено")

                Если ТипЗнч(Выборка.Регистратор)=Тип("Документы.Продажа") Тогда
                    ТекЗапись.ВидОплаты=Справочники.ВидОплаты.СпецЦены;
                ИначеЕсли ТипЗнч(Выборка.Регистратор)=Тип("Документы.ВозвратныйЧек") Тогда
                    ТекЗапись.ВидОплаты=Справочники.ВидОплаты.Наличный;
                КонецЕсли;
               
        КонецЦикла;
           
    Набор.Записать();
    КонецЦикла;

При выполнении обработки выдается ошибка.

{Форма.Форма.Форма(24)}: Тип не определен (Документы.Продажа)
                Если ТипЗнч(Выборка.Регистратор)=Тип("Документы.Продажа") Тогда

Подскажите как лучше сделать? Заранее благодарен


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Тип("ДокументСсылка.ЗагрузкаПроизводства")

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Если ТипЗнч(Основание) = Тип("ДокументСсылка.ПриходнаяНакладная") Тогда


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4489
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15970
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4212
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 646
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7762
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 385
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal