Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ориентация страницы  (Прочитано 3983 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн amoRNizam

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Скажите пожалуйста, где и как в модуле поменять альбомную ориентацию при печати на портретную в документе "Заказ поставщику" в 1с 7.7


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ПараметрыСтраницы(<?>,,,,,,,,,,,);
Синтаксис:
ПараметрыСтраницы(<Ориентация>,<Масштаб>,<РежимПечатиКопий>,<ПолеСлева>,<ПолеСправа>,<ПолеСверху>,<ПолеСнизу>,<КолонтитулСверху>,<КолонтитулСнизу>,<Автомасштаб>,<ФлагЧБПечати>,<ИмяПринтера>)
Назначение:
Установить параметры страницы.
Возвращаемого значения нет.
Параметры:
<Ориентация> - необязательный параметр. Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
<Масштаб> - необязательный параметр. Числовое выражение - масштаб (в процентах) вывода на печать.
<РежимПечатиКопий> - необязательный параметр. Числовое выражение - режим вывода нескольких копий на печать: 0 -  (collate) выводить сначала первые страницы всех копий,  затем вторые и т.д.; 1 - (разобрать) выводить страницы копий по порядку.
<ПолеСлева> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от левого края страницы.
<ПолеСправа> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от правого края страницы.
<ПолеСверху> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от верхнего края страницы.
<ПолеСнизу> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от нижнего края страницы.
<КолонтитулСверху> - необязательный параметр. Числовое выражение - размер (в миллиметрах) верхнего колонтитула.
<КолонтитулСнизу> - необязательный параметр. Числовое выражение - размер (в миллиметрах) нижнего колонтитула.
<Автомасштаб> - необязательный параметр. Режим автоматического подбора масштаба для размещения документа при печати на листе по ширине. 1 - включить; 0 - выключить; по умолчанию - 0.
<ФлагЧБПечати> - необязательный параметр. Число: 1 - черно-белая печать; 0 - обычный режим печати. Значение по умолчанию - 0.
<ИмяПринтера> - необязательный параметр. Строка имени принтера, как в стандартном диалоге печати Windows.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн amoRNizam

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-07
  • Сайт: 
  • Профессия: Ученик 1С
ПараметрыСтраницы(<?>,,,,,,,,,,,);
Синтаксис:
ПараметрыСтраницы(<Ориентация>,<Масштаб>,<РежимПечатиКопий>,<ПолеСлева>,<ПолеСправа>,<ПолеСверху>,<ПолеСнизу>,<КолонтитулСверху>,<КолонтитулСнизу>,<Автомасштаб>,<ФлагЧБПечати>,<ИмяПринтера>)
Назначение:
Установить параметры страницы.
Возвращаемого значения нет.
Параметры:
<Ориентация> - необязательный параметр. Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
<Масштаб> - необязательный параметр. Числовое выражение - масштаб (в процентах) вывода на печать.
<РежимПечатиКопий> - необязательный параметр. Числовое выражение - режим вывода нескольких копий на печать: 0 -  (collate) выводить сначала первые страницы всех копий,  затем вторые и т.д.; 1 - (разобрать) выводить страницы копий по порядку.
<ПолеСлева> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от левого края страницы.
<ПолеСправа> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от правого края страницы.
<ПолеСверху> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от верхнего края страницы.
<ПолеСнизу> - необязательный параметр. Числовое выражение - расстояние (в миллиметрах) от нижнего края страницы.
<КолонтитулСверху> - необязательный параметр. Числовое выражение - размер (в миллиметрах) верхнего колонтитула.
<КолонтитулСнизу> - необязательный параметр. Числовое выражение - размер (в миллиметрах) нижнего колонтитула.
<Автомасштаб> - необязательный параметр. Режим автоматического подбора масштаба для размещения документа при печати на листе по ширине. 1 - включить; 0 - выключить; по умолчанию - 0.
<ФлагЧБПечати> - необязательный параметр. Число: 1 - черно-белая печать; 0 - обычный режим печати. Значение по умолчанию - 0.
<ИмяПринтера> - необязательный параметр. Строка имени принтера, как в стандартном диалоге печати Windows.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.

Объясните пожалуйста, что с этим делать.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Ну перед тем, как в коде написано что то типа ТабДок.Показать(); Нужно вписать собственно ТабДок.параметрыСТраницы() - указав соответствующие нужные вам параметры.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн fipolaz

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2015-03-29
    • Skype: fipolaz
  • Компания: ИП
  • Профессия: Программист 7.7
вложите файлом текст модуля

Оффлайн amoRNizam

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Ну перед тем, как в коде написано что то типа ТабДок.Показать(); Нужно вписать собственно ТабДок.параметрыСТраницы() - указав соответствующие нужные вам параметры.

Есть только
    ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),""); 
   Иначе     
      ИсхТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
      ИсхТабл.КоличествоЭкземпляров(КолЭкз);
      ИсхТабл.Напечатать(0);
   КонецЕсли;
Но файл как формировался в альбомной ориентации, так и осталось.
Добавлено: 13 Окт 2015, 08:52

вложите файлом текст модуля

///////////ДЛЯ ПОЧТЫ///////////////////////////
Процедура ДляПОЧТЫ(СразуНаПринтер = 0,КолЭкз = 1)
   
   Перем ТаблЧасть, СуммаИтог, НомСтроки, Итог, Количество, Поставщик, Покупатель;
   Перем ТекстВал, НачПовт, КонПовт, ТабДок;
   Перем РеквШапки;
   
   ИсхТабл = СоздатьОбъект("Таблица");
       Если Число(Фирма.Код)=00006 тогда
      ИсхТабл.ИсходнаяТаблица("Таблица1");
       fromEmail=Константа.ЛогинПочтаДвери;
      fromPassword=Константа.ПарольПочтаДвери;
    Иначе
      ИсхТабл.ИсходнаяТаблица("Таблица2");       
       fromEmail=Константа.ЛогинПочтаАсМен;
      fromPassword=Константа.ПарольПочтаАсМен;
   КонецЕсли;
//   
   //ИсхТабл.ВывестиСекцию("Заголовок");
   //НачПовт = ИсхТабл.ВысотаСекции("Заголовок");
   //ИсхТабл.ВывестиСекцию("ШапкаТаблицы");
   //КонПовт = НачПовт + ИсхТабл.ВысотаСекции("ШапкаТаблицы");
   
                                              
//*********************************************************************************************\\

//*************************************************************************

// секция Заголовок
   
   ИсхТабл.ВывестиСекцию("Заголовок");
   НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
// Секция Покупатель
   Покупатель = СокрЛП(Фирма.ЮрЛицо.ПолнНаименование) +  " " + глПредставлениеАдреса(Фирма.ЮрЛицо.ЮрАдрес);
   ИсхТабл.ВывестиСекцию("Покупатель");
   НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Покупатель");
   
// Секция Покупатель
   Поставщик = "";
   Если ПустоеЗначение(Контрагент) = 0 Тогда
      Если Контрагент.ЮрФизЛицо.Выбран() = 1 Тогда
         Поставщик = СокрЛП(Контрагент.ЮрФизЛицо.ПолнНаименование);
      КонецЕсли;
   КонецЕсли;
   
   ИсхТабл.ВывестиСекцию("Поставщик");
   НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Поставщик");
   
// Секция Шапка таблицы
   ИсхТабл.ВывестиСекцию("ШапкаТаблицы");
   КонПовт = НачПовт + ИсхТабл.ВысотаСекции("ШапкаТаблицы");
   ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);
   
// выводим табличную часть
   ВыгрузитьТабличнуюЧасть(ТаблЧасть, "Номенклатура,Количество,Единица,Цена,Сумма");
   ТаблЧасть.Свернуть("Номенклатура,Единица,Цена", "Количество,Сумма");
   
   НомСтроки = 0;
   ТаблЧасть.ВыбратьСтроки();
   Пока ТаблЧасть.ПолучитьСтроку() = 1 Цикл
      НомСтроки = НомСтроки + 1;
      ИсхТабл.ВывестиСекцию("Строка");
   КонецЦикла;
      
   СуммаИтог = Итог("Сумма");
      
// секция Итого
   ИсхТабл.ВывестиСекцию("Итого");
   
// секция ИтогоНДС
   Если УчитыватьНДС = 1 Тогда
      СуммаНДСИтог = Итог("СуммаНДС");
      Если СуммаВклНДС = 0 Тогда
         СуммаИтог = СуммаИтог + СуммаНДСИтог;
      КонецЕсли;
      ИсхТабл.ВывестиСекцию("ИтогоНДС");
   КонецЕсли;
      
// секция ИтогоНП
   Если УчитыватьНП = 1 Тогда
      СуммаНПИтог = Итог("СуммаНП");
      Если СуммаВклНП = 0 Тогда
         СуммаИтог = СуммаИтог + СуммаНПИтог;
      КонецЕсли;
      ИсхТабл.ВывестиСекцию("ИтогоНП");
   КонецЕсли;
      
// секция СуммаПрописью
   ИсхТабл.ВывестиСекцию("СуммаПрописью");
   
// секция Подписи
   ИсхТабл.ВывестиСекцию("Подписи");
//*********************************************************************************************\\

   

   Если СразуНаПринтер = 0 Тогда
      ИсхТабл.Опции(0, 0, 0, 0, "ДляСчетаФактурыВыданного", "ДляСчетаФактурыВыданного");

      Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
         ИсхТабл.Защита(1);
      Иначе
         ИсхТабл.Защита(0);
      КонецЕсли;
      ИсхТабл.ТолькоПросмотр(1);
        ИсхТабл.ПараметрыСтраницы(1);
      ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),""); 
   Иначе     
      ИсхТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
      ИсхТабл.КоличествоЭкземпляров(КолЭкз);
      ИсхТабл.Напечатать(0);
   КонецЕсли;

   Спр=создатьобъект("Справочник.Контрагенты");
Если Спр.НайтиЭлемент(Контрагент)=1 тогда;
Если ПустоеЗначение(Спр.ЭлПочта)=1 тогда
   Если Вопрос("Не указан Адрес электронной почты "+Контрагент+". Ввести сейчас?",4)=6 тогда
      ОткрытьФорму(Спр.ТекущийЭлемент());
    КонецЕсли;
КонецЕсли;
//Иначе

//файл="Заявка_zp"+Прав(НомерДок,5);
файл="Zakaz_"+Прав(НомерДок,5);
ИсхТабл.Записать(КаталогИБ()+"TMP\"+файл,1);
КомандаСистемы("D:\Program\xls2pdf_l.vbs "+""""+КаталогИБ()+"TMP\"+файл+".xls"""+" "+""""+КаталогИБ()+"TMP\"+файл+".pdf""");
//КомандаСистемы("c:\xls2pdf.vbs "+""""+КаталогИБ()+"TMP\"+файл+".xls"""+" "+""""+КаталогИБ()+"TMP\"+файл+".pdf""");
мыло=Спр.ЭлПочта;
Если (ВвестиСтроку(мыло,"Подтвердите Адрес электронной почты",200)=1) и (ПустоеЗначение(мыло)=0) тогда
//   Пауза(10000);
   
   smtp="smtp.mail.ru";
    ЗадержкаСекунд=7;
   scr = СоздатьОбъект("WScript.Shell");
   scr.Run("ping 127.0.0.1 -n "+СокрЛП(Число(ЗадержкаСекунд)),0,1);
   
    sendemail=""""+КаталогИБ()+"sendEmail"" -f "+fromEmail+" -o message-charset=windows-1251 message-content-type=html -u "+"File "+файл+".pdf "+" -m "+"Здравствуйте!  <br /> ООО ""Ассоциация Менеджеров"" <br /> Россия, 394033,г.Воронеж, ул. Витрука, 13А <br /> Тел.: 8 (473) 261-2-111 <br /> Если не удается открыть файл, перейдите по ссылке... www.am-vrn.ru/kontakti/shema.html <br />
   |Наш сайт: www.am-vrn.ru <br /> Наш прайс строительных материалов: www.am-vrn.ru/docs/prais1.pdf <br />"+" -t "+мыло+" -s "+smtp+" -o tls=auto -xu "+fromEmail+" -xp "+fromPassword+" -cc "+fromEmail+" -a """+КаталогИБ()+"TMP\"+файл+".pdf"" -q -l """+КаталогИБ()+"TMP\log_sf.txt""";
   ЗапуститьПриложение(sendemail);
//   Пауза(10000);
   Предупреждение("Файл "+файл+".pdf отправлен на почту - "+мыло);
   Иначе
   Предупреждение("Отправка "+файл+".pdf на почту - "+мыло+" отменена");
   КонецЕсли;
Командасистемы("del "+""""+КаталогИБ()+"TMP\"+файл+".xls""");
Командасистемы("del "+""""+КаталогИБ()+"TMP\"+файл+".pdf""");
//КонецЕсли;
КонецЕсли;
   
КонецПроцедуры // ДляПОЧТЫ()

Последний раз редактировалось: amoRNizam; 13 Окт 2015, 08:52. Причина: Объединение сообщений

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Есть только

вот чуть выше строчку забыли
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн fipolaz

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2015-03-29
    • Skype: fipolaz
  • Компания: ИП
  • Профессия: Программист 7.7
воронеж - раскошный и таинственный город ;)
Добавлено: 14 Окт 2015, 22:31

	Если СразуНаПринтер = 0 Тогда
ИсхТабл.Опции(0, 0, 0, 0, "ДляСчетаФактурыВыданного", "ДляСчетаФактурыВыданного");

Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
ИсхТабл.Защита(1);
Иначе
ИсхТабл.Защита(0);
КонецЕсли;
ИсхТабл.ТолькоПросмотр(1);
ИсхТабл.ПараметрыСтраницы(1);//Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),""); 
Иначе     
ИсхТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
ИсхТабл.КоличествоЭкземпляров(КолЭкз);
ИсхТабл.ПараметрыСтраницы(1);//Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
ИсхТабл.Напечатать(0);
КонецЕсли;

Последний раз редактировалось: fipolaz; 14 Окт 2015, 22:31. Причина: Объединение сообщений

Оффлайн amoRNizam

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-07
  • Сайт: 
  • Профессия: Ученик 1С
воронеж - раскошный и таинственный город ;)
Добавлено: 14 Окт 2015, 22:31

	Если СразуНаПринтер = 0 Тогда
ИсхТабл.Опции(0, 0, 0, 0, "ДляСчетаФактурыВыданного", "ДляСчетаФактурыВыданного");

Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
ИсхТабл.Защита(1);
Иначе
ИсхТабл.Защита(0);
КонецЕсли;
ИсхТабл.ТолькоПросмотр(1);
ИсхТабл.ПараметрыСтраницы(1);//Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),""); 
Иначе     
ИсхТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
ИсхТабл.КоличествоЭкземпляров(КолЭкз);
ИсхТабл.ПараметрыСтраницы(1);//Ориентация вывода на печать: число:  1 -  портрет; 2 - ландшафт.
ИсхТабл.Напечатать(0);
КонецЕсли;
Всё равно как формировался в ландшафтной ориентации, так и формируется.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal