Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Макет текстового документа  (Прочитано 2771 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Liones23

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2013-12-18
  • Сайт: 
  • Профессия: Программист 1С
Есть объект документ, у него есть команда Печать.
Модуль команды:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
ТекстДок = Новый ТекстовыйДокумент;
Печать(ТекстДок, ПараметрКоманды);

ТекстДок.Показать("Отчет"); 
КонецПроцедуры

&НаСервере
Процедура Печать(ТекстДок, ПараметрКоманды) 
ПечатьОтчета(ТекстДок,ПараметрКоманды);
КонецПроцедуры

В общих макетах есть текстовый документ.
В общем модуле есть процедура:
Процедура ПечатьОтчета(Док,Ссылка) Экспорт
Макет = ПолучитьОбщийМакет("Макет1");
Заголовок=Макет.ПолучитьОбласть("Заголовок");
Макет.Вывести(Заголовок);
   
КонецПроцедуры
Через отладчик смотрела все куски отрабатываются.
А окно отчета пустое.
Пробовала засунуть процедуру в модуль менеджера документа. Результат тот же.
Вот сам макет:
#Область Заголовок
Согласие на обработку персональных данных
#КонецОбласти
Где ошибка?





Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
думаю проблема тут
Макет.Вывести(Заголовок);
нужно выводить в документ, а не в макет

Оффлайн Liones23

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2013-12-18
  • Сайт: 
  • Профессия: Программист 1С
Точно!
Еще вопрос попутно. Я так понимаю навести красоту в текстовом документе не очень много возможностей?
Например выравнивание, размер шрифта и т.п.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ХЗ. вот ни разу за более чем 10 лет работы с 1С не приходилось выполнять распечатку с помощью текстового документа. все как-то через табличный документ.

Оффлайн Liones23

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2013-12-18
  • Сайт: 
  • Профессия: Программист 1С
я пользовалась Active-документ. Текстовый сделала ради любопытства и расширения кругозора. Видимо придется "по-старинке".

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
как вариант выводить в htm документ...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15923
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 625
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 769
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal