Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите составить Цикл Повтора операции  (Прочитано 657 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн siralex

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-09
  • Сайт: 
  • Профессия: Ученик 1С
Добрый День. Помогите составить цикл повтора ввода пароля Сотрудником. ( Если он ввел неправильно пароль, чтобы форма ввода пароля "не слетала" а дала возможность повторно ввести пасроль)

ФормаПароль = ПолучитьФорму("ФормаВводаПароляПроекта", ЭтаФорма);
   ПроектСсылка = ФормаПароль.ОткрытьМодально();
   
   Если (ПроектСсылка = Неопределено) ИЛИ (ПроектСсылка.Пустая()) Тогда
      Ответ = Вопрос("Пароль не определен, закрыть продажу под сотрудником по умолчанию?", РежимДиалогаВопрос.ДаНет);
      Если Ответ = КодВозвратаДиалога.Нет Тогда
         Возврат;
      КонецЕсли;
   КонецЕсли;
   
   Если (НЕ ПроектСсылка = Неопределено) Тогда
      Если НЕ ПроектСсылка.Пустая() И ПроектСсылка.Сотрудник.Пустая() Тогда
         Предупреждение("Внимание! В настройках проекта не указан сотрудник. Чек будет закрыт под сотрудником по умолчанию");
      Иначе
         Продавец = ПроектСсылка.Сотрудник;
         //переназначаем все строки чека под закрываемого под введенным сотрудником
         Для каждого СтрокаТовар Из Товары Цикл
            СтрокаТовар.Продавец = Продавец;
         КонецЦикла;
      КонецЕсли;
   КонецЕсли;
   
   Проект = ПроектСсылка;


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ПроектСсылка = Неопределено;
Пока (ПроектСсылка = Неопределено) ИЛИ (ПроектСсылка.Пустая()) Цикл
    ПроектСсылка = ФормаПароль.ОткрытьМодально();
   
   Если (ПроектСсылка = Неопределено) ИЛИ (ПроектСсылка.Пустая()) Тогда
      Ответ = Вопрос("Пароль не определен, закрыть продажу под сотрудником по умолчанию?", РежимДиалогаВопрос.ДаНет);
      Если Ответ = КодВозвратаДиалога.Нет Тогда
         Возврат;
      КонецЕсли;
   КонецЕсли;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн siralex

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-09
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 185
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal