Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 17:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3  (Прочитано 7753 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Виталий Емельянов

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Добрый день, столкнулся с такой проблемой, есть абсолютно новый документ "Заявка покупателя", отличается от "заказа покупателя", сделана и подсветка проведенных документов, и добавлена "корректировка" ну и много всего ещё полезного :) но вот проблема когда нажимаешь "подбор", он выдает номенклатуру, но не показывает цену, т.е можно ввести количество, видны остатки на складах, но нет цены... не могу сообразить куда копать... надеюсь на вашу помощь!


Оффлайн Виталий Емельянов

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Ну и собственно сам код...
Процедура КоманднаяПанельТоварыПодбор(Кнопка)
ДействиеПодбор(Товары);
КонецПроцедуры

// Процедура вызывает сервисный механизм для подбора номеклатуры в табличную часть.
//
// Параметры:
//  ТабличнаяЧасть - табличная часть, в которую осуществляется подбор.
//
Процедура ДействиеПодбор(ТабличнаяЧасть)

Перем Команда, Валюта;

мМожноМенятьЦенуВДокументе = УправлениеДопПравамиПользователей.РазрешитьРедактированиеЦенВДокументах();

ЕстьЦена        = мМожноМенятьЦенуВДокументе;
ЕстьСерия       = Ложь;
СкрыватьХарактеристику = Ложь;
Валюта          = Константы.ВалютаРегламентированногоУчета.Получить();
ПодбиратьУслуги = Ложь;

Команда           = "ПодборВТабличнуюЧастьТовары";
ИмяТабличнойЧасти = "Товары";

СписокВидовПодбора = СформироватьСписокЗапросовДляПодбора(ТабличнаяЧасть);
ПредставлениеДок   = Метаданные().Представление();

СтруктураПараметровПодбора = Новый Структура();
СтруктураПараметровПодбора.Вставить("Команда"            , Команда);
СтруктураПараметровПодбора.Вставить("СписокВидовПодбора" , СписокВидовПодбора);

// Параметры запросов.
ВременнаяДатаРасчетов = ?(НачалоДня(Дата) = НачалоДня(ТекущаяДата()), Неопределено, Дата);
СтруктураПараметровПодбора.Вставить("ДатаРасчетов"                 , ВременнаяДатаРасчетов);
СтруктураПараметровПодбора.Вставить("Склад"                        , ОсновнойСклад);
//СтруктураПараметровПодбора.Вставить("ТипЦен"                       , ТипЦен);
СтруктураПараметровПодбора.Вставить("ДоговорКонтрагента"           , ДоговорКонтрагента);
СтруктураПараметровПодбора.Вставить("Контрагент"                   , Контрагент);
СтруктураПараметровПодбора.Вставить("Организация"                  , Организация);
СтруктураПараметровПодбора.Вставить("ПодбиратьУслуги"              , ПодбиратьУслуги);
СтруктураПараметровПодбора.Вставить("СпособЗаполненияЦен"          , Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры);
СтруктураПараметровПодбора.Вставить("ЕстьЦена"                     , ЕстьЦена);
СтруктураПараметровПодбора.Вставить("ЕстьСерия"                    , ЕстьСерия);
СтруктураПараметровПодбора.Вставить("ИспользоватьГруппуДоступности", Истина);
СтруктураПараметровПодбора.Вставить("ВалютаДокумента"              , Валюта);
СтруктураПараметровПодбора.Вставить("СкрыватьХарактеристику"       , СкрыватьХарактеристику);
СтруктураПараметровПодбора.Вставить("Заголовок", "Подбор номенклатуры в документ " +
                                    ПредставлениеДок + " № " + Номер + " (" + ИмяТабличнойЧасти + ")");
//СтруктураПараметровПодбора.Вставить("УсловиеПродаж"                , УсловиеПродаж);

    СтруктураПараметровПодбора.Вставить("ЕстьКоличество", Ложь);

РаботаСДиалогами.ОткрытьПодборНоменклатуры(ЭтаФорма, СтруктураПараметровПодбора, Метаданные());

КонецПроцедуры // ДействиеПодбор()

// Функция формирует список запросов для передачи в форму подбора.
//
// Параметры:
//  ТабличнаяЧасть - табличная часть, для подбора в которую формируется список запросов.
//
// Возвращаемое значение:
//  Список значений - список запросов.
//
Функция СформироватьСписокЗапросовДляПодбора(ТабличнаяЧасть)

СписокЗапросов      = Новый СписокЗначений();
СписокЗапросов.Добавить(,"По справочнику");

СписокЗапросов.Добавить("ОстаткиНоменклатуры", "По остаткам номенклатуры");

Если (ЗначениеЗаполнено(ДоговорКонтрагента) И ДоговорКонтрагента.ВидУсловийДоговора = Перечисления.ВидыУсловийДоговоровВзаиморасчетов.СДополнительнымиУсловиями) Тогда
СписокЗапросов.Добавить("РасходОстаткиИЦеныНоменклатуры", "По остаткам и ценам номенклатуры");
СписокЗапросов.Добавить("РасходЦеныНоменклатуры",         "По ценам номенклатуры");
КонецЕсли;

Возврат СписокЗапросов;

КонецФункции // СформироватьСписокЗапросовДляПодбора()

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 329
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
цены то бывают разные. а вы отключили типцен
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Виталий Емельянов

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
цены то бывают разные. а вы отключили типцен

Допустим я снимаю комментирование с "тип цен", но ничего не меняется :( далее я в тупик зашел, и не могу сообразить куда и чего добавить)

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 329
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
В отладчике смотрите как в номенклатуре в подборе разбирается этот список и чего не хватает

Отправлено с моего Boost через Tapatalk

Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Виталий Емельянов

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
В отладчике смотрите как в номенклатуре в подборе разбирается этот список и чего не хватает

Отправлено с моего Boost через Tapatalk


Вот спасибо! Хоть кто-то указал куда тыкать. Сейчас буду пробовать!


Теги:
 

Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 27998
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1269
Последний ответ 18 Авг 2017, 11:57
от ZSS
Убрать документ из обмена. Правила обмена.

Автор bestnameРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2214
Последний ответ 10 Май 2017, 15:18
от bestname
1C:ERP 2.2 Документ Этап производства. Дата производства.

Автор Pavel_0573Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3565
Последний ответ 31 Май 2017, 16:59
от Pavel_0573
Выгрузить из Excel построчно в реквизиты документа. Каждая строка Excel- новый документ.

Автор User10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 715
Последний ответ 12 Дек 2018, 08:55
от к2в2

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
24 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 463
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal