Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос по выбору автора напоминания  (Прочитано 776 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Валерия00

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-09-20
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, помогите разобраться пожалуйста!!!!
Существует Документ заказ покупателя и заказ наряд, их оформляют сначала заказНаряд далее на основании его ЗаказПокупателя, когда приходит товар то приходит напоминание тому кто создал например заказ наряд создал иванов а заказ покупателя петров, так вот напоминание прийдет иванову.
Как сейчас работает код ниже...
А мне надо чтобы напоминание приходило если видремонта="такойто" то напоминание приходит автору заказ наряда, а если видремонта "Другой" то АвторуЗаКАЗА покупателя

//Получим регистратор записей в регистр
   ОтборРегистратор=Источник.Отбор.Найти("Регистратор");
   Если ОтборРегистратор=Неопределено Тогда
      Возврат;
   КонецЕсли;
   Регистратор=ОтборРегистратор.Значение;
   Попытка
      Если Не Источник.ИнтерактивноеПроведение Тогда
         Возврат;
      КонецЕсли;
   Исключение
      Возврат;
   КонецПопытки;
   
   Если ТипЗнч(рЕГИСТРАТОР)=Тип("ДокументСсылка.ЗаказПокупателя") и ТипЗнч(рЕГИСТРАТОР)=Тип("ДокументСсылка.ЗаказНаряд") Тогда
      Возврат;
   КонецЕсли;
   РегистраторАвтор=Регистратор.Автор;
   
//Получим заказы и их авторов, которым требуется создать напоминание
   Запрос=Новый Запрос;
   Запрос.Текст="ВЫБРАТЬ РАЗЛИЧНЫЕ
             |   ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя) КАК ЗаказПокупателя,
             |   ПРЕДСТАВЛЕНИЕ(ЗаказыПокупателей.Заказ) КАК ЗаказПокупателяПредставление,
             |   ЕСТЬNULL(Пользователи.Ссылка, ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя).Автор) КАК Автор,
             |   Пользователи.Ссылка
             |ИЗ
             |   РегистрНакопления.ЗаказыПокупателей КАК ЗаказыПокупателей
             |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
             |      ПО (ЗначенияСвойствОбъектов.Свойство = &Свойство)
             |         И ((ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя)) = ЗначенияСвойствОбъектов.Объект)
             |      ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
             |      ПО (ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя).Менеджер = Пользователи.Сотрудник)
             |         И (НЕ Пользователи.Сотрудник = ЗНАЧЕНИЕ(Справочник.Сотрудники.ПустаяСсылка))
             |ГДЕ
             |   ЗаказыПокупателей.ВидДвижения = &ВидДвиженияПриход
             |   И ЗаказыПокупателей.Регистратор = &Регистратор
             |   И ЗаказыПокупателей.Заказ ССЫЛКА Документ.ЗаказПокупателя
             |   И ЕСТЬNULL(Пользователи.Ссылка, ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя).Автор) <> &ПустойАвтор
             |   И ЗаказыПокупателей.Резерв > 0
             |   И ЗначенияСвойствОбъектов.Значение = ИСТИНА
             |
             |СГРУППИРОВАТЬ ПО
             |   ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя),
             |   ЕСТЬNULL(Пользователи.Ссылка, ВЫРАЗИТЬ(ЗаказыПокупателей.Заказ КАК Документ.ЗаказПокупателя).Автор),
             |   Пользователи.Ссылка,
             |   ПРЕДСТАВЛЕНИЕ(ЗаказыПокупателей.Заказ)";
   Запрос.УстановитьПараметр("ВидДвиженияПриход",ВидДвиженияНакопления.Приход);
   Запрос.УстановитьПараметр("Регистратор",Регистратор);
   Запрос.УстановитьПараметр("ПустойАвтор",Справочники.Пользователи.ПустаяСсылка());
   Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.СвойстваОбъектов.УведомлениеОРезервировании);
   Выборка=Запрос.Выполнить().Выбрать();
Если Выборка.Количество()=0 Тогда
      Возврат;
   КонецЕсли;
   
    НаборЗаписейНапоминания=РегистрыСведений.Напоминания.СоздатьНаборЗаписей();
   НаборЗаписейНапоминания.Отбор.Автор.Установить(Регистратор);
    НаборЗаписейНапоминания.Отбор.Завершено.Установить(Ложь);
   НаборЗаписейНапоминания.Прочитать();

Если (Выборка.ЗаказПокупателя.ВидРемонта=Справочники.ВидыРемонта.НайтиПоНаименованию("Кузовной"))или
         (Выборка.ЗаказПокупателя.ВидРемонта=Справочники.ВидыРемонта.НайтиПоНаименованию("Мойка"))тогда
//Для каждого автора создадим напоминание
      НоваяЗапись=НаборЗаписейНапоминания.Добавить();        
      НоваяЗапись.Пользователь=ПолучитьАдресата(Выборка.ЗаказПокупателя);
                НоваяЗапись.автор=РегистраторАвтор;   (((Вот тут должно быть новаяЗапись.Автор=Автор.ЗаказПокупателя но выдает ошибки)



Скажите пожалуйста как мне в запросе поменять чтобы заработало


Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Ошибка то какая?

Оффлайн Валерия00

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-09-20
  • Сайт: 
  • Профессия: Программист 1С
Ошибка то какая?

уже разобралась

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
   Если ТипЗнч(рЕГИСТРАТОР)=Тип("ДокументСсылка.ЗаказПокупателя") и ТипЗнч(рЕГИСТРАТОР)=Тип("ДокументСсылка.ЗаказНаряд") Тогда
      Возврат;
   КонецЕсли;
Аж до слез...


 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9327
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2990
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 977
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 678
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 16511
Последний ответ 02 Сен 2011, 01:14
от bolobol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal