Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: перенос базы из 8.0 в 8.3 в режиме совместимости.  (Прочитано 2880 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн joni

  • **
  • Сообщений: 58
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-28
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Нужна помощь, 1С клиент серверная.
есть старые базы на 8.0  есть 8.3 работают обе на одном сервере 8.3 на другом порту.
на сервере 8.0 три базы, как переносил
Подключаю сервер 8.3 в базу sql 8.0 и она конвертирует до 8.1 и включает режим совместимости.
С одной базой прокатило все работает.
в другой базе затык. а именно ошибки.
при выводе на экран для печати счет фактуры
{Документ.СчетФактураВыданный(1050)}: Ошибка при вызове метода контекста (Создать)
Обработка = ВнешниеОбработки.Создать(ИмяФайла);
по причине:
Ошибка подключения внешних метаданных
по причине:
Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.

В интернете нашел как это исправить запускаю обработку
КонвертацияВнешнихОбработок.epf
в ответ такая вот ошибка
{Форма.Форма(52)}: Поле объекта не обнаружено (ВнешниеОбработки)
ЕстьГруппы = Метаданные.Справочники.ВнешниеОбработки.Иерархический;

кто бы мог подсказать что мне делать дальше? как выгрузить внешние обработки из базы, конвертировать и обратно загрузить.


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Заходите в справочник внешних обработок (в предприятии). Выгружаете обработку, открываете обработку в конфигураторе 8.1, получаете запрос на конвертацию, соглашаетесь, снова в предприятии подключаете уже сконвертированную обработку. (все обработки забекапить до конвертации).

Оффлайн joni

  • **
  • Сообщений: 58
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-28
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за подсказки. в общем все так и сделал. Но ошибка осталась. У кого с этим был опыт?
Что делаю
Запускаю 1С - Продажи - реализация товаров и услуг - открываю документ - счет фактура - печать (выбираю счет фактуру) - Ошибка (ошибка подключения внешних метаданных) - жму подробнее -
{Документ.СчетФактураВыданный(1050)}: Ошибка при вызове метода контекста (Создать)
Обработка = ВнешниеОбработки.Создать(ИмяФайла);
по причине:
Ошибка подключения внешних метаданных
по причине:
Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.

Если отмена в окне счет фактура, выбираемая счет фактура появляется, жму на нее для печати и ошибка
{Документ.СчетФактураВыданный(913)}: Поле объекта не обнаружено (НаименованиеДоговораНакладной)
ОбластьМакета.Параметры.НаименованиеДоговораНакладной = "К товарной накладной №" + НомерТоварной + " от " + Формат(ДокументОснование.Дата, "ДФ=dd.MM.yyyy; ДЛФ=D") + "; " + Строка(ДокументОснование.ДоговорКонтрагента.Наименование);

На сколько я понимаю эта счет фактура не стандартная.
или как узнать о какой обработки тут идет реч. вот куда тычит конфигуратор.
Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт

Если ЭтоНовый() Тогда
Предупреждение("Документ можно распечатать только после его записи");
Возврат;
КонецЕсли;

Если Не ПроверитьМодифицированность(ЭтотОбъект) Тогда
Возврат;
КонецЕсли;

Если ИмяМакета = "СчетФактура" Тогда

// Получить экземпляр документа на печать
ТипОснования = ТипЗнч(ДокументОснование);
        Если НаАванс Тогда
    ДанныеДляПечати    = СобратьДанныеСФнаАванс();
ИначеЕсли ТипОснования      = Тип("ДокументСсылка.ОтчетКомитентуОПродажах") Тогда
ДанныеДляПечати    = СобратьДанныеПоОтчетКомитентуОПродажах();
ИначеЕсли ТипОснования = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
ДанныеДляПечати    = СобратьДанныеПоРеализацияТоваровУслуг();
ИначеЕсли ТипОснования = Тип("ДокументСсылка.ОтчетКомиссионераОПродажах") Тогда
ДанныеДляПечати    = СобратьДанныеПоОтчетКомиссионераОПродажах();
ИначеЕсли ТипОснования = Тип("ДокументСсылка.ОтражениеРеализацииТоваровИУслугНДС") Тогда
ДанныеДляПечати    = СобратьДанныеПоОтражениюРеализацииТоваровИУслуг();
КонецЕсли;

Если ТипЗнч(ДанныеДляПечати) = Тип("Соответствие") Тогда
Возврат;
ИначеЕсли ДанныеДляПечати = Неопределено Тогда
Возврат;
КонецЕсли;

ТабДокумент = ПечатьСчетаФактуры(ДанныеДляПечати);

ИначеЕсли ТипЗнч(ИмяМакета) = Тип("СправочникСсылка.ДополнительныеПечатныеФормы") Тогда

ИмяФайла = КаталогВременныхФайлов()+"PrnForm.tmp";
ОбъектВнешнейФормы = ИмяМакета.ПолучитьОбъект();
Если ОбъектВнешнейФормы = Неопределено Тогда
Сообщить("Ошибка получения внешней формы документа. Возможно форма была удалена", СтатусСообщения.Важное);
Возврат;
КонецЕсли;

ДвоичныеДанные = ОбъектВнешнейФормы.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);
Обработка = ВнешниеОбработки.Создать(ИмяФайла);  ----- Курсор тут
Обработка.СсылкаНаОбъект = Ссылка;
ТабДокумент = Обработка.Печать();

КонецЕсли;

НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, СформироватьЗаголовокДокумента(ЭтотОбъект, ЭтотОбъект.Метаданные().Представление()));

КонецПроцедуры // Печать

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Внешняя обработка не может быть прочитана текущей версией программы.

Вы не сконвертировали эту печатную форму.

Оффлайн joni

  • **
  • Сообщений: 58
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-28
  • Сайт: 
  • Профессия: Ученик 1С
Внешняя обработка не может быть прочитана текущей версией программы.

Вы не сконвертировали эту печатную форму.
Подскажите а как конвертируются внешние печатные формы.
В гугле на вопрос конвертация внешней печатной формы нашел вот эту статью
Цитировать
Чтобы сконвертировать внешние печатные формы для работы с версией 8.2 платформы, нужно открыть файл каждой из внешних печатных форм, сделанных для версии 8.1 платформы, в конфигураторе платформы версии 8.2. На вопрос "Требуется конвертация документа. Конвертировать?" ответить "Да", сохранить внешнюю печатную форму в файл и подключить этот файл к конфигурации в обычном порядке.

Открыть список внешних печатных форм через меню:

Сервис
- Дополнительные отчеты и обработки
-- Дополнительные внешние печатные формы
Так вот я не понял, найти нашел где эти печатные формы но они сохраняются в XML как я их буду в конфигураторе открывать. Конфигуратор открывает их как текстовый файл и ничего не предлагает.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
надо на каждую форму встать, нажать "Изменить" и уже на "форме формы" будет кнопка с дискетой "Сохранить".
в результате получите epf-файл.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн joni

  • **
  • Сообщений: 58
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-28
  • Сайт: 
  • Профессия: Ученик 1С
надо на каждую форму встать, нажать "Изменить" и уже на "форме формы" будет кнопка с дискетой "Сохранить".
в результате получите epf-файл.

ХМ, Давайте разберемся, говоря о "Форма" "Печатная форма" это все имеется ввиду "Общие макеты" а также макеты добавленные в самом документе? так? или это Общие формы или формы добавленные в документе?

на всякий случай проверил оба варианта
Макет. Нет дискетки не в меню файл не на форме

Если открыть макет то появляется но там нет формата  epf

С формами аналогично только там один формат html

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Все не так. В конфигуратор лезть не надо. Вы же уже нашли "Дополнительные внешние печатные формы". - это справочник. Каждый элемент справочника в себе содержит зашифрованную обработку по печати.
надо на каждую форму встать
Означает, что в форме списка справочника "Дополнительные внешние печатные формы" нужно спозиционироваться на каждый элемент.

нажать "Изменить"
Ну, собственно то и означает. Правая клавиша мыши->изменить
уже на "форме формы" будет кнопка с дискетой "Сохранить"
После "изменить" открывается форма элемента справочника "Дополнительные внешние печатные формы". Кнопка "Сохранить" позволяет извлечь зашифрованную обработку из элемента и сохранить ее на диск в произвольный каталог.
И только потом открываем конфигуратор, открываем эту сохраненную обработку и получаем запрос на конвертацию.
Затем надо уже эту сконвертированную обработку подгрузить назад в справочник "Дополнительные внешние печатные формы" в тоже самое место, т.е. заменить.


Оффлайн joni

  • **
  • Сообщений: 58
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-28
  • Сайт: 
  • Профессия: Ученик 1С
надо на каждую форму встать, нажать "Изменить" и уже на "форме формы" будет кнопка с дискетой "Сохранить".
в результате получите epf-файл.

После "изменить" открывается форма элемента справочника "Дополнительные внешние печатные формы". Кнопка "Сохранить" позволяет извлечь зашифрованную обработку из элемента и сохранить ее на диск в произвольный каталог.

Не вижу кнопки сохранить.



Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Можете помочь написать обработку которая сможет делать реализацию списывая поступления из другой базы или ссылаясь на них? просто одна компания покупает другая продает этот товар и чтобы вторая компания не смогла продать больше чем есть у первой? 1с 8.2 2

Автор Юлия АндреевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 749
Последний ответ 13 Ноя 2016, 19:25
от BuhRust
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9216
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5165
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7450
Последний ответ 06 Дек 2014, 17:40
от дфтын
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3664
Последний ответ 17 Сен 2014, 13:39
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal