Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 10:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Фильтр документов при обмене  (Прочитано 3042 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день ALL!
УТ 11.1.10 БП 3.0 ,обмениваются штатно,обычными правилами.
Возникла необходимость не передавать из УТ в БП ПКО и РКО которые не пробиты на ККМ,которые пробиты надо передавать.Причем в УТ они должны быть проведены все.
Надо что то типа
Если ПриходныйКассовыйОрдер.НомерЧекаККМ > 0 Тогда
Продолжить
Иначе
Возврат
КонецЕсли;

Поделитесь практическим опытом или идеями как это реализовать?!
Есть мысли дописать в КД стандартные правила,но опять же не сильно углублен в КД,ткните пальцем где там добавить условие.
Заранее благодарен!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. в ПВД ПКО
2. в ПКО ПКО (получился каламбур но сокращения действительно совпадают :D )

Если Объект.НомерЧекаККМ = 0 Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В перед выгрузкой объекта В ПКО
Если Источник.НомерЧекаККМ >0 Тогда
...

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Простите за назойливость,где мне это вносить? в КД редактировать правила обмена?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Да.
ПКО - правило конвертации объекта
ПВД - правило выгрузки данных
ПКС - правило конвертации свойств.

При установке конфигурации КД прицепом устанавливается небольшой учебник в ворде. В самой КД очень хорошая справка.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
При много благодарен!
Добавлено: 25 Сен 2015, 15:19

Подскажите туда ли я залез?
Выделенный текст,туда прописывать ?
Добавлено: 25 Сен 2015, 15:55

Вот я по инструкции выше добавил,правильно ли?
Мне нужна операция в ПКО именно Поступление средств от клиента.

Последний раз редактировалось: SkyNetYar; 25 Сен 2015, 15:55. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
1. Из ПВД добавленный код убрать.
2. В форме настройки ПКО есть большая кнопка "Информация по обработчикам". Нужно читать!
3.
Если Источник.НомерЧекаККМ >0 Тогда


Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Сделал только в ПКО
Если Источник.НомерЧекаККМ = 0 Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Все работает,при много благодарен!
А еще маленький нюанс,те что уже перенесены были документы с чеком =0 ,их их можно убрать?
Я так подозреваю что это можно сделать в "После загрузки" ?
Если Источник.НомерЧекаККМ = 0 Тогда
Источник.Документ.Удалить()
КонецЕсли;
С Источник.Документ.Удалить() не уверен ..
Добавлено: 28 Сен 2015, 10:41

Вернее в "После выгрузки" Источник.ПометаУдаления(Истина) может так?
Добавлено: 28 Сен 2015, 10:46

Или даже Приемник.ПометкаУдаления(ИСТИНА)

Последний раз редактировалось: SkyNetYar; 28 Сен 2015, 10:46. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Ничего непонятно по поводу "удалить"

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Ну те документы которые уже были перенесены из УТ в БП до того как мы их больше не передаем условием
Если Источник.НомерЧекаККМ = 0 Тогда
    Отказ = ИСТИНА;
КонецЕсли;

А как пометить на удаление уже переданные документы в БП с НомерЧекаККМ = 0 ?
Я в БП если честно не нашел где хранятся номера чеков ККМ,почему то не удалось их вывести..,но можно же их обработать еще до выгрузки на стороне УТ? и не удовлетворяющие требованию пометить на удаление?

Да,я проверил в БП у всех переданных ПКО НомерЧекаККМ = 0 ,тоесть НомерЧекаККМ не переносится..из УТ в БП,и на стороне БП их никак не обработать...

Последний раз редактировалось: SkyNetYar; 28 Сен 2015, 11:13


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3307
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4148
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 241
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3136
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1829
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
105 Сообщений
alex0402
28 Сообщений
kiksi
17 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
BuhRust
13 Сообщений
pavl_vs
13 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 942
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal