Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 02:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сделать текущую колонку активной?  (Прочитано 1372 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Стажер 1С

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Посмотрите пожалуйста мой программный код и скажите почему он не работает. Когда я сдвигаю например колонку "к1" направо в табличном поле, активным должен становится текущая колонка ("к1"), но почему то активным становится колонка "к2".

Процедура КоманднаяПанель1СдвинутьКолонкуВПраво(Кнопка)

ТекКолонка = ЭлементыФормы.ТабПоле1.ТекущаяКолонка;
Индекс = ЭлементыФормы.ТабПоле1.Колонки.Индекс(ТекКолонка);
ТабПоле1.Колонки.Сдвинуть(Индекс, 1);
ЭлементыФормы.ТабПоле1.СоздатьКолонки();
ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ТекКолонка;

КонецПроцедуры


Оффлайн Natain14

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 

ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ТекКолонка;

КонецПроцедуры

Если я правильно поняла, то проблема в этой строке. Вы устанавливаете текущей первую колонку. Может пойдет что-то подобное (1- это количество шагов сдвига). Только тогда если колонка станет последней то будет выходить ошибка, так что лучше строку вставить в Попытку например

Попытка
ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ЭлементыФормы.ТабПоле1.Колонки[индекс+1];
исключение
ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ТекКолонка;
конецпопытки

Оффлайн Стажер 1С

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-09-22
  • Сайт: 
  • Профессия: Ученик 1С

ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ТекКолонка;

КонецПроцедуры

Если я правильно поняла, то проблема в этой строке. Вы устанавливаете текущей первую колонку. Может пойдет что-то подобное (1- это количество шагов сдвига). Только тогда если колонка станет последней то будет выходить ошибка, так что лучше строку вставить в Попытку например

Попытка
ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ЭлементыФормы.ТабПоле1.Колонки[индекс+1];
исключение
ЭлементыФормы.ТабПоле1.ТекущаяКолонка = ТекКолонка;
конецпопытки

Спасибо большое, все работает!


Теги:
 

Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2159
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 280
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как "Наименование" сделать числом

Автор zedikusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1817
Последний ответ 24 Авг 2015, 06:26
от cska-fanat-kz
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2053
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1 страница - портрет, 2 страница - ландшафт Подскажите как сделать?

Автор YaposhaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4674
Последний ответ 05 Апр 2012, 11:37
от Yaposha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 203
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal