Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вставка картинки в реквизит табличной части справочника с типом хранилище значения  (Прочитано 1713 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, коллеги
Есть табличная часть справочника ПрикрепленныеФайлы
Вот код вставки картинки с файла в ХранилищеЗначений табличной части с помощью команды ВыбратьФайлКартинки :

&НаКлиенте
Процедура ВыбратьФайлКартинки(Команда)
//Создаем оповещение,   именно  процедура  "ОбработатьВыборФайла"  будет вызвана при закрытии окна выбора файла
Оповещение  =  Новый ОписаниеОповещения("ОбработатьВыборФайла",   ЭтаФорма);
//Открываем интерактивно  окно для выбора файла
НачатьПомещениеФайла(Оповещение,   ,   ,   Истина,   УникальныйИдентификатор);
КонецПроцедуры

 &НаКлиенте
Процедура ОбработатьВыборФайла(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
Если Не Результат Тогда
 Возврат;
КонецЕсли;
СсылкаНаКартинку = Адрес;

         //запись в табличную часть
        //ИмяФайла = ВыбранноеИмяФайла.ПолучитьОбъект();
        //Элементы.ПрикрепленныеФайлы.ДобавитьСтроку();
      Строка=Элементы.ПрикрепленныеФайлы.ТекущиеДанные;
      
                ДобавитьФайлТЧ(ВыбранноеИмяФайла);
       Элементы.ПрикрепленныеФайлы.ЗакончитьРедактированиеСтроки(Ложь);

КонецПроцедуры 

//запись картинки в ХЗ


&НаСервере
Процедура ДобавитьФайлТЧ(ИмяФайла)
   
       Строка=Объект.ПрикрепленныеФайлы.Добавить();
      Строка.НаименованиеФайла=ИмяФайла;
      Строка.РасширениеФайла=Прав(ИмяФайла,4);
      ХЗ = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));
                Строка.СодержимоеФайла = ХЗ;

КонецПроцедуры

Только не работает,  выдает "Поле объекта  (СодержимоеФайла) не обнаружено", хотя в табличной части есть такой реквизит!!
Помогите пожалуйста, заранее большое спасибо!


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Какой тип значения у реквизита: Строка.СодержимоеФайла?
Сейчас вы в него пишете хранилищезначения.
Вы не можете помещать на ФОРМЫ реквизит с типом хранилище значения.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Какой тип значения у реквизита: Строка.СодержимоеФайла?
Сейчас вы в него пишете хранилищезначения.
Вы не можете помещать на ФОРМЫ реквизит с типом хранилище значения.
Тип реквизита СодержимоеФайла - ХранилищеЗначений
Я хочу в него сохранить картинку. Пожалуйста подскажите. Спасибо


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6501
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2041
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 271
Последний ответ 12 Окт 2017, 14:02
от wise
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3896
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 403
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 243
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal