Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться  (Прочитано 1693 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн студент18

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-18
  • Сайт: 
  • Профессия: Ученик 1С
    Добрый день. Начал изучать 1С программирование. и столкнулся с такой задачей.
    На форме есть Реквизит Дата и Текстовое поле.
    Если дата пустая то в  текстовом поле никакого значения нет. Дату поставили появилось значение 1. Если еще раз дату поменять то в поле появится 2 и т.д. т.е     вести сколько раз изменялась дата на форме.
Помогите разобраться. Программирую в обычном приложении.




Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С

ДатаПриИзминении()
Текстовое поле = Текстовое поле+1 (или реквизит Текстового поля если таковой имеется)(реквизит лучше сделать и задать ему тип число)

p.s. это сугубо мое мнение и я могу ошибаться !

Оффлайн студент18

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-18
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ДатаПриИзменении(Элемент)
ЭлементыФормы.Реквизит1.Значение = 1;

КонецПроцедуры


Реквизит1 Тип Число.


так то реквизиту присваивается 1. а  что б при следующем изменении даты было значение 2.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Процедура ДатаПриИзменении(Элемент)
    ЭлементыФормы.Реквизит1.Значение = ЭлементыФормы.Реквизит1.Значение+1;
   
КонецПроцедуры

Оффлайн студент18

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-18
  • Сайт: 
  • Профессия: Ученик 1С
vitasw благодарю!!!

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
кстать еще... вам же надо что бы именно при изменении даты ? Тогда
Перем ДатаДоИзменения;

ПриОткрытии()
ДатаДоИзменения = Дата;

Процедура ДатаПриИзменении(Элемент)
Если НЕ Дата = ДатаДоИзменения тогда
    ЭлементыФормы.Реквизит1.Значение = ЭлементыФормы.Реквизит1.Значение+1;
КонецЕсли   
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
P.S. Так
ЭлементыФормы.Реквизит1.Значение
к реквизитам не принято обращаться (не суть важно это реквизит формы или реквизит объекта).
Для выполнения операций над реквизитам достаточно писать 
Реквизит1=...;
В свою очередь для управления, например видимостью/доступностью нужно пиасть:
ЭлементыФормы.Реквизит1.Видимость=Истина;
ЭлементыФормы.Реквизит1.Доступность=Истина;
и.д.
Т.е. операции над значениями реквизитов = обращение просто по имени реквизита.
Для упралвением отображениеями и размерами ревизитов на форме используется "ЭлементыФормы.<ИмяРеквизита>.<НеобходимоеСвойство>"=...;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а если ему надо проверить что дата именно поменялась?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
EritikWoW, +100500!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
студент тогда будет думать над условием...:D


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5544
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4356
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1974
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 850
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal