Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с вставкой открытой картинки в реквизит формы типа ХранилищеДанных  (Прочитано 919 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, коллеги.
Подскажите пожалуйста.
У меня есть справочник Номенклатура, управляемая форма - форма элемента.
Задача в чем - нужно открыть файл картинки с изображением товара и вставить в табличную часть справочника, в поле СодержимоеФайла, имеющее тип "ХранилищеЗначений".
Этот тип не отображается на форме. В конструкторе формы выдает "Недоступен в данной форме"

Я создал команду на форме, а те в табличной части и написал код:

&НаКлиенте
Процедура ОткрытьФайл(Команда)
   
   // открываем файл картинки для каждой строки
   Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
   Текст = "ru = ""Фото товара""";
    Фильтр = НСтр(Текст)+"(*.jpg)|*.jpg*";

   
   
   ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.Заголовок = "Выберите файл шаблона";
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        Файл = Новый Файл(ДиалогОткрытияФайла.ПолноеИмяФайла);
      //добавление строки в табличную часть документа
      Элементы.ПрикрепленныеФайлы.ДобавитьСтроку();
      Строка=Элементы.ПрикрепленныеФайлы.ТекущиеДанные;
      Строка.НаименованиеФайла=Файл.ИмяБезРасширения;
      Строка.РасширениеФайла=Файл.Расширение;
      Объект.Картинка = Файл.Имя;
      ОткрытыйФайл = Новый ДвоичныеДанные(ДиалогОткрытияФайла.ПолноеИмяФайла);
      ДобавьКартинку(ОткрытыйФайл);
   КонецЕсли;   

КонецПроцедуры


&НаСервере
Процедура ДобавьКартинку(ОткрытыйФайл)
    Картинка = РеквизитФормыВЗначение("СодержимоеФайла");
    Объект.Картинка =  Новый ХранилищеЗначения(ОткрытыйФайл);
    ЗначениеВРеквизитФормы(Картинка, "СодержимоеФайла");
КонецПроцедуры

Подскажите, как записать открытую картинку в реквизит табличной части "СодержимоеФайла". Заранее благодарен. Удачи Вам в Вашем деле!


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 300
Последний ответ 21 Сен 2017, 10:33
от Insider
Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1181
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4711
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2439
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4827
Последний ответ 03 Авг 2011, 11:45
от t955938

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal