Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод на печать результат запроса  (Прочитано 3154 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!
Помогите допилить вывод на печать по запросу пожалуйста!

ОбластьСтрокаШирокаяОтчет 			= Макет.ПолучитьОбласть("СтрокаШирокаяДоп");

ЗапросПоДокументам = Новый Запрос;
ЗапросПоДокументам.Текст=

"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| КассовыеДокументы.Документ КАК Документ,
| НАЧАЛОПЕРИОДА(КассовыеДокументы.Документ.Дата, ДЕНЬ) КАК День,
| КассовыеДокументы.Документ.Дата КАК ДатаДок,
| КассовыеДокументы.Документ.Номер КАК НомерДок,
| ПОДСТРОКА(КассовыеДокументы.Документ.Основание, 1, 200) КАК Основание,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.ПриходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.ПринятоОт
| ИНАЧЕ КассовыеДокументы.Документ.Выдать
| КОНЕЦ КАК ТекстДок,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.ПриходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.СуммаДокумента
| ИНАЧЕ 0
| КОНЕЦ КАК Приход,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.РасходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.СуммаДокумента
| ИНАЧЕ 0
| КОНЕЦ КАК Расход
|ИЗ
| (ВЫБРАТЬ
| ПриходныйКассовыйОрдер.Ссылка КАК Документ
| ИЗ
| Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
| ГДЕ
| ПриходныйКассовыйОрдер.Дата МЕЖДУ &НачИтоги И &ДатаКон
| И ПриходныйКассовыйОрдер.Организация = &Организация
| И ПриходныйКассовыйОрдер.Касса = &Касса
| И ПриходныйКассовыйОрдер.Проведен
|
| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ
| РасходныйКассовыйОрдер.Ссылка
| ИЗ
| Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
| ГДЕ
| РасходныйКассовыйОрдер.Дата МЕЖДУ &НачИтоги И &ДатаКон
| И РасходныйКассовыйОрдер.Организация = &Организация
| И РасходныйКассовыйОрдер.Касса = &Касса
| И РасходныйКассовыйОрдер.Проведен) КАК КассовыеДокументы
|
|УПОРЯДОЧИТЬ ПО
| День,
| ДатаДок,
| Документ
|ИТОГИ ПО
| День,
| Документ
|АВТОУПОРЯДОЧИВАНИЕ";

НачИтоги = ДатаДокумента();
ДатаКон = ДатаДокумента();
Организация = БухгалтерскийУчетПереопределяемый.ПолучитьЗначениеПоУмолчанию("ОсновнаяОрганизация");

ЗапросПоДокументам.УстановитьПараметр("НачИтоги",    НачалоДня(НачИтоги));
ЗапросПоДокументам.УстановитьПараметр("ДатаКон",     КонецДня(ДатаКон));
ЗапросПоДокументам.УстановитьПараметр("Организация", Организация);
ЗапросПоДокументам.Текст=СтрЗаменить(ЗапросПоДокументам.Текст,"И РасходныйКассовыйОрдер.Касса = &Касса","");
ЗапросПоДокументам.Текст=СтрЗаменить(ЗапросПоДокументам.Текст,"И ПриходныйКассовыйОрдер.Касса = &Касса","");

РезультатЗапросаПоДокументам = ЗапросПоДокументам.Выполнить();
ТаблицаДокументы = РезультатЗапросаПоДокументам.Выгрузить();
И еще не знаю как в запросе установить значение даты текущего документа
Дорабатываю КМ-6 УТ 11.1


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вы работает в типовой конфигурации, в модуле менеджера практически любого документа есть процедуры формирования табличных документов на печать. Хочу посоветовать разобрать код печати, который уже есть.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Вы работает в типовой конфигурации, в модуле менеджера практически любого документа есть процедуры формирования табличных документов на печать. Хочу посоветовать разобрать код печати, который уже есть.
Да я как раз этим занимаюсь сейчас,но как указать в запросе или установить значение даты текущего документа,в запросе МЕЖДУ а как за дату текущего документа?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
<КакоетоПолеВЗапросеТипаДата> =&ПараметрДата

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Простите не понял как сделать..

Запрос выше,после запроса
ЗапросПоДокументам.УстановитьПараметр("НачИтоги",    '20150910');
ЗапросПоДокументам.УстановитьПараметр("ДатаКон",     '20150914');

Как мне привязать дату документа по которому я формирую печатную форму,и выбрать результат и вывести именно только по этой дате ?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В процедуре, где присутствует запрос должна быть ссылка на интересующий вас документ.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Простите недопетриваю что то ,вот вся функция печати КМ-6 с моими дописками начинает с //МОЕ///,и у меня почему то все ПКО и РКО выводит по 2 раза :mellow:

Функция СформироватьПечатнуюФормуКМ6(МассивОбъектов, ОбъектыПечати)

Перем ДатаЛиста;
УстановитьПривилегированныйРежим(Истина);

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_КМ6";

Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.ОтчетОРозничныхПродажах.ПФ_MXL_КМ6");

ТекстЗапроса =
"ВЫБРАТЬ
| ЕСТЬNULL(СУММА(ТЧТовары.Сумма), 0) КАК СуммаПродаж,
| ЕСТЬNULL(СУММА(ТЧТовары.СуммаНДС), 0) КАК СуммаПродажНДС,
| 0 КАК СуммаПродажОтчет,
| 0 КАК СуммаПродажОтчетНДС,
| 0 КАК СуммаВозвратов,
| 0 КАК СуммаВозвратовНДС,
| 0 КАК СуммаПродажПодарочныхСертификатов,
| 0 КАК СуммаВозвратовПодарочныхСертификатов,
| ОтчетОРозничныхПродажах.Ссылка КАК Ссылка
|ПОМЕСТИТЬ ПродажиИВозвраты
|ИЗ
| Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЧекККМ.Товары КАК ТЧТовары
| ПО (ТЧТовары.Ссылка.КассоваяСмена = ОтчетОРозничныхПродажах.КассоваяСмена)
| И (ТЧТовары.Ссылка.Проведен)
| И (ТЧТовары.Ссылка.Статус = ЗНАЧЕНИЕ(Перечисление.СтатусыЧековККМ.Пробит))
|ГДЕ
| ОтчетОРозничныхПродажах.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ОтчетОРозничныхПродажах.Ссылка
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| 0,
| 0,
| ЕСТЬNULL(СУММА(ТЧТоварыОтчет.Сумма), 0),
| ЕСТЬNULL(СУММА(ТЧТоварыОтчет.СуммаНДС), 0),
| 0,
| 0,
| 0,
| 0,
| ОтчетОРозничныхПродажах.Ссылка
|ИЗ
| Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ОтчетОРозничныхПродажах.Товары КАК ТЧТоварыОтчет
| ПО (ТЧТоварыОтчет.Ссылка = ОтчетОРозничныхПродажах.Ссылка)
|ГДЕ
| ОтчетОРозничныхПродажах.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ОтчетОРозничныхПродажах.Ссылка
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| 0,
| 0,
| 0,
| 0,
| ЕСТЬNULL(СУММА(ТЧТовары.Сумма), 0),
| ЕСТЬNULL(СУММА(ТЧТовары.СуммаНДС), 0),
| 0,
| 0,
| ОтчетОРозничныхПродажах.Ссылка
|ИЗ
| Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЧекККМВозврат.Товары КАК ТЧТовары
| ПО (ТЧТовары.Ссылка.КассоваяСмена = ОтчетОРозничныхПродажах.КассоваяСмена)
| И (ТЧТовары.Ссылка.Проведен)
| И (ТЧТовары.Ссылка.НомерЧекаККМ > 0)
|ГДЕ
| ОтчетОРозничныхПродажах.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ОтчетОРозничныхПродажах.Ссылка
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| 0,
| 0,
| 0,
| 0,
| 0,
| 0,
| ЕСТЬNULL(СУММА(ТЧПодарочныеСертификаты.Сумма), 0),
| 0,
| ОтчетОРозничныхПродажах.Ссылка
|ИЗ
| Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияПодарочныхСертификатов.ПодарочныеСертификаты КАК ТЧПодарочныеСертификаты
| ПО (ТЧПодарочныеСертификаты.Ссылка.КассоваяСмена = ОтчетОРозничныхПродажах.КассоваяСмена)
| И (ТЧПодарочныеСертификаты.Ссылка.Проведен)
| И (ТЧПодарочныеСертификаты.Ссылка.НомерЧекаККМ > 0)
|ГДЕ
| ОтчетОРозничныхПродажах.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ОтчетОРозничныхПродажах.Ссылка
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| 0,
| 0,
| 0,
| 0,
| 0,
| 0,
| 0,
| ЕСТЬNULL(СУММА(ТЧПодарочныеСертификаты.Сумма), 0),
| ОтчетОРозничныхПродажах.Ссылка
|ИЗ
| Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВозвратПодарочныхСертификатов.ПодарочныеСертификаты КАК ТЧПодарочныеСертификаты
| ПО (ТЧПодарочныеСертификаты.Ссылка.КассоваяСмена = ОтчетОРозничныхПродажах.КассоваяСмена)
| И (ТЧПодарочныеСертификаты.Ссылка.Проведен)
| И (ТЧПодарочныеСертификаты.Ссылка.НомерЧекаККМ > 0)
|ГДЕ
| ОтчетОРозничныхПродажах.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ОтчетОРозничныхПродажах.Ссылка
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ПродажиИВозвраты.Ссылка КАК Ссылка,
| СУММА(ПродажиИВозвраты.СуммаПродаж) КАК СуммаПродаж,
| СУММА(ПродажиИВозвраты.СуммаПродажНДС) КАК СуммаПродажНДС,
| СУММА(ПродажиИВозвраты.СуммаПродажОтчет) КАК СуммаПродажОтчет,
| СУММА(ПродажиИВозвраты.СуммаПродажОтчетНДС) КАК СуммаПродажОтчетНДС,
| СУММА(ПродажиИВозвраты.СуммаВозвратов) КАК СуммаВозвратов,
| СУММА(ПродажиИВозвраты.СуммаВозвратовНДС) КАК СуммаВозвратовНДС,
| СУММА(ПродажиИВозвраты.СуммаПродажПодарочныхСертификатов) КАК СуммаПродажПодарочныхСертификатов,
| СУММА(ПродажиИВозвраты.СуммаВозвратовПодарочныхСертификатов) КАК СуммаВозвратовПодарочныхСертификатов
|ПОМЕСТИТЬ ПродажиВозвратыСгруппировано
|ИЗ
| ПродажиИВозвраты КАК ПродажиИВозвраты
|
|СГРУППИРОВАТЬ ПО
| ПродажиИВозвраты.Ссылка
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ПродажиВозвратыСгруппировано.Ссылка КАК Ссылка,
| ПродажиВозвратыСгруппировано.Ссылка.Дата КАК ДатаДокумента,
| ПродажиВозвратыСгруппировано.Ссылка.ЦенаВключаетНДС КАК ЦенаВключаетНДС,
| ПродажиВозвратыСгруппировано.Ссылка.Номер КАК НомерДокумента,
| ПродажиВозвратыСгруппировано.Ссылка.Валюта КАК Валюта,
| ПродажиВозвратыСгруппировано.Ссылка.КассаККМ КАК КассаККМ,
| ПродажиВозвратыСгруппировано.Ссылка.КассаККМ.ТипКассы КАК ТипКассы,
| ПродажиВозвратыСгруппировано.Ссылка.КассаККМ.Представление КАК ККМПредставление,
| ПродажиВозвратыСгруппировано.Ссылка.КассаККМ.СерийныйНомер КАК СерийныйНомер,
| ПродажиВозвратыСгруппировано.Ссылка.КассаККМ.РегистрационныйНомер КАК РегистрационныйНомер,
| ПродажиВозвратыСгруппировано.Ссылка.Организация КАК Организация,
| ТаблицаОтветственныеЛица.РуководительНаименование КАК Руководитель,
| ТаблицаОтветственныеЛица.РуководительДолжность КАК ДолжностьРуководителя,
| ТаблицаОтветственныеЛица.ГлавныйБухгалтерНаименование КАК ГлавныйБухгалтер,
| ПродажиВозвратыСгруппировано.Ссылка.Организация.Префикс КАК Префикс,
| ПродажиВозвратыСгруппировано.Ссылка.Ответственный.ФизическоеЛицо КАК Ответственный,
| ПродажиВозвратыСгруппировано.Ссылка.КассоваяСмена КАК КассоваяСмена,
| ПродажиВозвратыСгруппировано.Ссылка.КассоваяСмена.НачалоКассовойСмены КАК НачалоСмены,
| ПродажиВозвратыСгруппировано.Ссылка.КассоваяСмена.ОкончаниеКассовойСмены КАК ОкончаниеСмены,
| ПродажиВозвратыСгруппировано.СуммаПродаж КАК СуммаПродаж,
| ПродажиВозвратыСгруппировано.СуммаПродажНДС КАК СуммаПродажНДС,
| ПродажиВозвратыСгруппировано.СуммаПродажОтчет КАК СуммаПродажОтчет,
| ПродажиВозвратыСгруппировано.СуммаПродажОтчетНДС КАК СуммаПродажОтчетНДС,
| ПродажиВозвратыСгруппировано.СуммаВозвратов КАК СуммаВозвратов,
| ПродажиВозвратыСгруппировано.СуммаВозвратовНДС КАК СуммаВозвратовНДС,
| ПродажиВозвратыСгруппировано.СуммаПродажПодарочныхСертификатов КАК СуммаПродажПодарочныхСертификатов,
| ПродажиВозвратыСгруппировано.СуммаВозвратовПодарочныхСертификатов КАК СуммаВозвратовПодарочныхСертификатов
|ИЗ
| ПродажиВозвратыСгруппировано КАК ПродажиВозвратыСгруппировано
| ЛЕВОЕ СОЕДИНЕНИЕ ТаблицаОтветственныеЛица КАК ТаблицаОтветственныеЛица
| ПО ПродажиВозвратыСгруппировано.Ссылка = ТаблицаОтветственныеЛица.Ссылка
|
|УПОРЯДОЧИТЬ ПО
| Ссылка";

МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
ОтветственныеЛицаСервер.СформироватьВременнуюТаблицуОтветственныхЛицДокументов(МассивОбъектов, МенеджерВременныхТаблиц);

Запрос = Новый Запрос;
Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
Запрос.Текст = ТекстЗапроса;
Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

ПервыйДокумент = Истина;

Пока Выборка.Следующий() Цикл

Если Не ПервыйДокумент Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ПервыйДокумент = Ложь;
НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;

СведенияОПокупателе = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(Выборка.Организация, Выборка.ДатаДокумента);
ОтветственныйПредставление = ФизическиеЛицаУТ.ФамилияИнициалыФизЛица(Выборка.Ответственный);

ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.Заполнить(Выборка);
ОбластьМакета.Параметры.ОрганизацияПредставление = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование,ИНН,ЮридическийАдрес,Телефоны, КодПоОКПО");
ОбластьМакета.Параметры.ДатаДокумента            = Выборка.ДатаДокумента;
ОбластьМакета.Параметры.ОрганизацияПоОКПО        = СведенияОПокупателе.КодПоОКПО;
ОбластьМакета.Параметры.ОрганизацияИНН           = СведенияОПокупателе.ИНН;
ОбластьМакета.Параметры.СерийныйНомер            = Выборка.СерийныйНомер;
ОбластьМакета.Параметры.РегистрационныйНомер     = Выборка.РегистрационныйНомер;
ОбластьМакета.Параметры.ККМПредставление         = Выборка.ККМПредставление;
ОбластьМакета.Параметры.ПрограммаУчета           = "1С:Предприятие 8";
ОбластьМакета.Параметры.НомерДокумента           = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Строка(Выборка.НомерДокумента), Ложь, Истина);
ОбластьМакета.Параметры.Ответственный            = ОтветственныйПредставление;

ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабДокумент, Макет, ОбластьМакета, Выборка.Ссылка);
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Строка");

Если Выборка.ТипКассы = Перечисления.ТипыКассККМ.ФискальныйРегистратор И ЗначениеЗаполнено(Выборка.КассоваяСмена) Тогда
СуммаПродаж  = Выборка.СуммаПродаж + ?(НЕ Выборка.ЦенаВключаетНДС, Выборка.СуммаПродажНДС, 0);
СуммаВозврат = Выборка.СуммаВозвратов + ?(НЕ Выборка.ЦенаВключаетНДС, Выборка.СуммаВозвратовНДС, 0);
Иначе
Сумма = Выборка.СуммаПродажОтчет + ?(НЕ Выборка.ЦенаВключаетНДС, Выборка.СуммаПродажОтчетНДС, 0);
Если Сумма >= 0 Тогда
СуммаПродаж  = Сумма;
СуммаВозврат = 0;
Иначе
СуммаПродаж  = 0;
СуммаВозврат = -Сумма;
КонецЕсли;
КонецЕсли;

ОбластьМакета.Параметры.Итого        = СуммаПродаж;
ОбластьМакета.Параметры.ИтогоВозврат = СуммаВозврат;
ОбластьМакета.Параметры.НомерСекции  = 1; // Продажи
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета.Параметры.Итого        = Выборка.СуммаПродажПодарочныхСертификатов;
ОбластьМакета.Параметры.ИтогоВозврат = Выборка.СуммаВозвратовПодарочныхСертификатов;
ОбластьМакета.Параметры.НомерСекции  = 2; // Авансы
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Итог");

ОбластьМакета.Параметры.Итого        = СуммаПродаж + Выборка.СуммаПродажПодарочныхСертификатов;
ОбластьМакета.Параметры.ИтогоВозврат = СуммаВозврат + Выборка.СуммаВозвратовПодарочныхСертификатов;

Если ЗначениеЗаполнено(СуммаПродаж) Тогда
ОбластьМакета.Параметры.СуммаВыручкиПрописью = РаботаСКурсамиВалют.СформироватьСуммуПрописью(
  СуммаПродаж
- СуммаВозврат
+ Выборка.СуммаПродажПодарочныхСертификатов
- Выборка.СуммаВозвратовПодарочныхСертификатов, Выборка.Валюта);
КонецЕсли;

ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Оборот");
ОбластьМакета.Параметры.ФИОРуководителя       = Выборка.Руководитель;
ОбластьМакета.Параметры.Ответственный         = ОтветственныйПредставление;
ОбластьМакета.Параметры.ФИОКассираОрганизации = Выборка.ГлавныйБухгалтер;
ТабДокумент.Вывести(ОбластьМакета);

УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, ОбъектыПечати, Выборка.Ссылка);

    КонецЦикла;

   

////////////////////////////////////МОЕ//////////////////////////////////////////////////////////////////////////////////
   ЗапросПоДокументам = Новый Запрос;
ЗапросПоДокументам.Текст=

"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| КассовыеДокументы.Документ КАК Документ,
| НАЧАЛОПЕРИОДА(КассовыеДокументы.Документ.Дата, ДЕНЬ) КАК День,
| КассовыеДокументы.Документ.Дата КАК ДатаДок,
| КассовыеДокументы.Документ.Номер КАК НомерДок,
| ПОДСТРОКА(КассовыеДокументы.Документ.Основание, 1, 200) КАК Основание,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.ПриходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.ПринятоОт
| ИНАЧЕ КассовыеДокументы.Документ.Выдать
| КОНЕЦ КАК ТекстДок,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.ПриходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.СуммаДокумента
| ИНАЧЕ 0
| КОНЕЦ КАК Приход,
| ВЫБОР
| КОГДА КассовыеДокументы.Документ ССЫЛКА Документ.РасходныйКассовыйОрдер
| ТОГДА КассовыеДокументы.Документ.СуммаДокумента
| ИНАЧЕ 0
| КОНЕЦ КАК Расход
|ИЗ
| (ВЫБРАТЬ
| ПриходныйКассовыйОрдер.Ссылка КАК Документ
| ИЗ
| Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
| ГДЕ
| ПриходныйКассовыйОрдер.Дата МЕЖДУ &НачИтоги И &ДатаКон
| И ПриходныйКассовыйОрдер.Проведен
|
| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ
| РасходныйКассовыйОрдер.Ссылка
| ИЗ
| Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
| ГДЕ
| РасходныйКассовыйОрдер.Дата МЕЖДУ &НачИтоги И &ДатаКон
| И РасходныйКассовыйОрдер.Проведен) КАК КассовыеДокументы
|
|УПОРЯДОЧИТЬ ПО
| День,
| ДатаДок,
| Документ
|ИТОГИ ПО
| День,
| Документ
|АВТОУПОРЯДОЧИВАНИЕ";

ЗапросПоДокументам.УстановитьПараметр("НачИтоги",    '20150910');
ЗапросПоДокументам.УстановитьПараметр("ДатаКон",     '20150914');
РезультатЗапросаПоДокументам = ЗапросПоДокументам.Выполнить();

ДеталиШапка = Макет.ПолучитьОбласть("ДеталиШапка");
ТабДокумент.Вывести(ДеталиШапка);
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ВыборкаДетальныеЗаписи = РезультатЗапросаПоДокументам.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ОбластьДетальныхЗаписей.Параметры.ДокументОс = СокрЛП(ВыборкаДетальныеЗаписи.Документ) + "  Документ основание:  " + СокрЛП(ВыборкаДетальныеЗаписи.Основание);
ТабДокумент.Вывести(ОбластьДетальныхЗаписей);
КонецЦикла;

 

Возврат ТабДокумент
/////////////////////////////////////////////////////////////////////////////////////////////////////////
КонецФункции

Оффлайн Kironten

  • *****
  • Сообщений: 902
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Как минимум потому, что у Вас в запросе:
ОБЪЕДИНИТЬ ВСЕ
Эта конструкция не группирует повторяющиеся строки

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Как минимум потому, что у Вас в запросе:
ОБЪЕДИНИТЬ ВСЕ
Эта конструкция не группирует повторяющиеся строки
А как надо подскажите?!

Оффлайн Kironten

  • *****
  • Сообщений: 902
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Ищите, где задваиваются данные по порядку. Сначала вложенный запрос. Потом ваш общий.
Можете еще и скрин задвоившихся рко и пко скинуть. Если задваиваются во вложенном, то попробуйте ВЫБРАТЬ РАЗЛИЧНЫЕ.
В общем ваших данных базы никто не видит, можно только догадываться о причинах.


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12228
Последний ответ 14 Июн 2012, 17:44
от Alex1111
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3759
Последний ответ 29 Июн 2012, 18:37
от LexaK
Печать справки "Б"

Автор wvlasРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2256
Последний ответ 27 Апр 2016, 18:01
от wvlas
Как "поймать" нажатие на кнопку "Печать" в открываемом макете(табличный документ)?

Автор taramz5Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1170
Последний ответ 14 Фев 2017, 14:27
от ilyay
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 206
Последний ответ 07 Окт 2017, 19:03
от Norfolk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 175
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal