Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Оформление Списка  (Прочитано 1503 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sportik142

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Александр
  • Регистрация: 2015-08-10
  • Сайт: 
  • Профессия: Программист 1С
Как при выводе списка, выделять строки цветом с определенным параметром??


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Например в обработчике табличного поля ПриПолученииДанных.
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Для каждого Оформление из ОформленияСтрок Цикл
        Если КакоеТоУсловие Тогда 
            Оформление.ЦветФона = WebЦвета.Желтый;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Оффлайн sportik142

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Александр
  • Регистрация: 2015-08-10
  • Сайт: 
  • Профессия: Программист 1С
Есть вот такой код программы, где тут указать оформление?

 Процедура СписокСегодняСБВыбор(Элемент, ВыбраннаяСтрока, ОформлениеСтроки, Колонка, СтандартнаяОбработка)
//   Договор = Справочники.Договоры.НайтиПоКоду(ВыбраннаяСтрока.Договор);
//   Договор.ПолучитьФорму().ОткрытьМодально();
Если СтрДлина(ВыбраннаяСтрока.Договор) = 10 Тогда
       Документ = Справочники.Договоры.НайтиПоКоду(ВыбраннаяСтрока.Договор);
      Документ.ПолучитьФорму().Открыть();
   ИначеЕсли СтрДлина(ВыбраннаяСтрока.Договор) = 12 Тогда
      Документ = Справочники.ДопСогл.НайтиПоКоду(ВыбраннаяСтрока.Договор);
      Документ.ПолучитьФорму().Открыть();
   ИначеЕсли СтрДлина(ВыбраннаяСтрока.Договор) = 11 Тогда
      Документ = Справочники.Расписки.НайтиПоКоду(ВыбраннаяСтрока.Договор);
                  Документ.ПолучитьФорму().Открыть();
            
         КонецЕсли;
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Почему событие Выбор используется? Вы же написали
Как при выводе списка, выделять строки цветом с определенным параметром??

Оффлайн sportik142

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Александр
  • Регистрация: 2015-08-10
  • Сайт: 
  • Профессия: Программист 1С
Не могу найти процедуру выгрузке. В программе есть вкладка, при ее открытии,выбирается период и кнопка сформировать. И формируется список.

Вот код с кнопки
Процедура ОбновитьДолжников()
   Если не ЗначениеЗаполнено(ЭлементыФормы.ПолеВвода1.Значение) и ЭлементыФормы.ФлажокТолькоРасписки.Значение = истина тогда
   Должники = Новый Запрос;
   Должники.Текст = "ВЫБРАТЬ
                    |   Расписки.Заемщик,
                    |   Расписки.Код,
                    |   Расписки.СуммаКПогашению,
                    |   Расписки.ДатаПогашения,
                    |   Расписки.Заемщик.МобильныйТелефон,
                    |   Расписки.Подразделение,
                    |   Расписки.Представление,
                    |   Расписки.ТекКомиссияН,
                    |   Расписки.ТекОсновнаяСумма,
                    |   Расписки.ТекКомиссияС,
                    |   Расписки.ТекНеустойка
                    |ИЗ
                    |   Справочник.Расписки КАК Расписки
                    |ГДЕ
                    |   Расписки.ДатаПогашения >= &ДатаПогашения1
                    |   И Расписки.ДатаПогашения <= &ДатаПогашения2
                    |   И Расписки.ТекОсновнаяСумма > &Тек
                    |   И Расписки.ПометкаУдаления = ЛОЖЬ";
    Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ЭлементыФормы.ДатаС.Значение));
   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ЭлементыФормы.ДатаПО.Значение));
   Должники.УстановитьПараметр("Тек", 0);
   ЭлементыФормы.СписокСегодняСБ.Значение = Должники.Выполнить().Выгрузить();
      
      КонецЕсли;
   Если ЗначениеЗаполнено(ЭлементыФормы.ПолеВвода1.Значение) и ЭлементыФормы.ФлажокТолькоРасписки.Значение = истина тогда
   Должники = Новый Запрос;
   Должники.Текст = "ВЫБРАТЬ
                    |   Расписки.Заемщик,
                    |   Расписки.Код,
                    |   Расписки.СуммаКПогашению,
                    |   Расписки.ДатаПогашения,
                    |   Расписки.Заемщик.МобильныйТелефон,
                    |   Расписки.Подразделение,
                    |   Расписки.Представление,
                    |   Расписки.ТекКомиссияН,
                    |   Расписки.ТекОсновнаяСумма,
                    |   Расписки.ТекКомиссияС,
                    |   Расписки.ТекНеустойка
                    |ИЗ
                    |   Справочник.Расписки КАК Расписки
                    |ГДЕ
                    |   Расписки.ДатаПогашения >= &ДатаПогашения1
                    |   И Расписки.ДатаПогашения <= &ДатаПогашения2
                    |   И Расписки.ТекОсновнаяСумма > &Тек
                    |   И Расписки.Подразделение = &Подразделение
                    |   И Расписки.ПометкаУдаления = ЛОЖЬ";
    Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ЭлементыФормы.ДатаС.Значение));
   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ЭлементыФормы.ДатаПО.Значение));
   Должники.УстановитьПараметр("Тек", 0);
   Должники.УстановитьПараметр("Подразделение", ЭлементыФормы.ПолеВвода1.Значение);
   ЭлементыФормы.СписокСегодняСБ.Значение = Должники.Выполнить().Выгрузить();
КонецЕсли;
   
Если не ЗначениеЗаполнено(ЭлементыФормы.ПолеВвода1.Значение) и ЭлементыФормы.ФлажокТолькоРасписки.Значение = ложь тогда   
   Должники = Новый Запрос;
   Должники.Текст = "ВЫБРАТЬ
                    |   Договоры.Заемщик КАК Заемщик,
                    |   Договоры.Код КАК Договор,
                    |   Договоры.СуммаКПогашению КАК Сумма,
                    |   Договоры.ДатаПогашения КАК ДатаВозврата,
                    |   Договоры.Заемщик.МобильныйТелефон КАК Телефон,
                    |   Договоры.Подразделение КАК Подразделение,
                    |   Договоры.Представление,
                    |   Договоры.ТекКомиссияН,
                    |   Договоры.ТекОсновнаяСумма,
                    |   Договоры.ТекКомиссияС,
                    |   Договоры.ТекНеустойка КАК ТекНеустойка
                    |ИЗ
                    |   Справочник.Договоры КАК Договоры
                    |ГДЕ
                    |   Договоры.ДатаПогашения >= &ДатаПогашения1
                    |   И Договоры.ПогашенаОсновнаяЗадолженность = &ПогашенаОсновнаяЗадолженность
                    |   И Договоры.ЗаймВыдан = &ЗаймВыдан
                    |   И Договоры.ДатаПогашения <= &ДатаПогашения2
                    |   И Договоры.ПометкаУдаления = ЛОЖЬ
                    |
                    |ОБЪЕДИНИТЬ ВСЕ
                    |
                    |ВЫБРАТЬ
                    |   ДопСогл.Заемщик,
                    |   ДопСогл.Код,
                    |   ДопСогл.СуммаКПогашению,
                    |   ДопСогл.ДатаПогашения,
                    |   ДопСогл.Заемщик.МобильныйТелефон,
                    |   ДопСогл.Подразделение,
                    |   ДопСогл.Представление,
                    |   ДопСогл.ТекКомиссияН,
                    |   ДопСогл.ТекОсновнаяСумма,
                    |   ДопСогл.ТекКомиссияС,
                    |   ДопСогл.ТекНеустойка
                    |ИЗ
                    |   Справочник.ДопСогл КАК ДопСогл
                    |ГДЕ
                    |   ДопСогл.ДатаПогашения >= &ДатаПогашения1
                    |   И ДопСогл.ТекОсновнаяСумма > &Тек
                    |   И ДопСогл.ДатаПогашения <= &ДатаПогашения2
                    |   И ДопСогл.ПометкаУдаления = ЛОЖЬ
                    |
                    |ОБЪЕДИНИТЬ ВСЕ
                    |
                    |ВЫБРАТЬ
                    |   Расписки.Заемщик,
                    |   Расписки.Код,
                    |   Расписки.СуммаКПогашению,
                    |   Расписки.ДатаПогашения,
                    |   Расписки.Заемщик.МобильныйТелефон,
                    |   Расписки.Подразделение,
                    |   Расписки.Представление,
                    |   Расписки.ТекКомиссияН,
                    |   Расписки.ТекОсновнаяСумма,
                    |   Расписки.ТекКомиссияС,
                    |   Расписки.ТекНеустойка
                    |ИЗ
                    |   Справочник.Расписки КАК Расписки
                    |ГДЕ
                    |   Расписки.ДатаПогашения >= &ДатаПогашения1
                    |   И Расписки.ДатаПогашения <= &ДатаПогашения2
                    |   И Расписки.ТекОсновнаяСумма > &Тек
                    |   И Расписки.ПометкаУдаления = ЛОЖЬ
                    |
                    |УПОРЯДОЧИТЬ ПО
                    |   ДатаВозврата";
//   Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ТекущаяДата()));
//   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ТекущаяДата()));
    Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ЭлементыФормы.ДатаС.Значение));
   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ЭлементыФормы.ДатаПО.Значение));
    Должники.УстановитьПараметр("ЗаймВыдан", Истина);
//   Должники.УстановитьПараметр("ПогашенаКомиссия", Ложь);
   Должники.УстановитьПараметр("ПогашенаОсновнаяЗадолженность", Ложь);
   Должники.УстановитьПараметр("Тек", 0);
   ЭлементыФормы.СписокСегодняСБ.Значение = Должники.Выполнить().Выгрузить();
КонецЕсли;
Если ЗначениеЗаполнено(ЭлементыФормы.ПолеВвода1.Значение) и ЭлементыФормы.ФлажокТолькоРасписки.Значение = ложь тогда
   Должники = Новый Запрос;
   Должники.Текст = "ВЫБРАТЬ
                    |   Договоры.Заемщик КАК Заемщик,
                    |   Договоры.Код КАК Договор,
                    |   Договоры.СуммаКПогашению КАК Сумма,
                    |   Договоры.ДатаПогашения КАК ДатаВозврата,
                    |   Договоры.Заемщик.МобильныйТелефон КАК Телефон,
                    |   Договоры.Подразделение КАК Подразделение,
                    |   Договоры.Представление,
                    |   Договоры.ТекКомиссияН,
                    |   Договоры.ТекОсновнаяСумма,
                    |   Договоры.ТекКомиссияС,
                    |   Договоры.ТекНеустойка КАК ТекНеустойка
                       |ИЗ
                    |   Справочник.Договоры КАК Договоры
                    |ГДЕ
                    |   Договоры.ДатаПогашения >= &ДатаПогашения1
                    |   И Договоры.ПогашенаОсновнаяЗадолженность = &ПогашенаОсновнаяЗадолженность
                    |   И Договоры.ЗаймВыдан = &ЗаймВыдан
                    |   И Договоры.ДатаПогашения <= &ДатаПогашения2
                    |   И Договоры.Подразделение = &Подразделение
                    |   И Договоры.ПометкаУдаления = ЛОЖЬ
                    |
                    |ОБЪЕДИНИТЬ ВСЕ
                    |
                    |ВЫБРАТЬ
                    |   ДопСогл.Заемщик,
                    |   ДопСогл.Код,
                    |   ДопСогл.СуммаКПогашению,
                    |   ДопСогл.ДатаПогашения,
                    |   ДопСогл.Заемщик.МобильныйТелефон,
                    |   ДопСогл.Подразделение,
                    |   ДопСогл.Представление,
                    |   ДопСогл.ТекКомиссияН,
                    |   ДопСогл.ТекОсновнаяСумма,
                    |   ДопСогл.ТекКомиссияС,
                    |   ДопСогл.ТекНеустойка
                    |ИЗ
                    |   Справочник.ДопСогл КАК ДопСогл
                    |ГДЕ
                    |   ДопСогл.ДатаПогашения >= &ДатаПогашения1
                    |   И ДопСогл.ТекОсновнаяСумма > &Тек
                    |   И ДопСогл.ДатаПогашения <= &ДатаПогашения2
                    |   И ДопСогл.Подразделение = &Подразделение
                    |   И ДопСогл.ПометкаУдаления = ЛОЖЬ
                    |
                    |ОБЪЕДИНИТЬ ВСЕ
                    |
                    |ВЫБРАТЬ
                    |   Расписки.Заемщик,
                    |   Расписки.Код,
                    |   Расписки.СуммаКПогашению,
                    |   Расписки.ДатаПогашения,
                    |   Расписки.Заемщик.МобильныйТелефон,
                    |   Расписки.Подразделение,
                    |   Расписки.Представление,
                    |   Расписки.ТекКомиссияН,
                    |   Расписки.ТекОсновнаяСумма,
                    |   Расписки.ТекКомиссияС,
                    |   Расписки.ТекНеустойка
                    |ИЗ
                    |   Справочник.Расписки КАК Расписки
                    |ГДЕ
                    |   Расписки.ДатаПогашения >= &ДатаПогашения1
                    |   И Расписки.ТекОсновнаяСумма > &Тек
                    |   И Расписки.ДатаПогашения <= &ДатаПогашения2
                    |   И Расписки.Подразделение = &Подразделение
                    |   И Расписки.ПометкаУдаления = ЛОЖЬ
                    |
                    |УПОРЯДОЧИТЬ ПО
                    |   ДатаВозврата";
//   Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ТекущаяДата()));
//   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ТекущаяДата()));
   Должники.УстановитьПараметр("ДатаПогашения1", НачалоДня(ЭлементыФормы.ДатаС.Значение));
   Должники.УстановитьПараметр("ДатаПогашения2", КонецДня(ЭлементыФормы.ДатаПО.Значение));
   Должники.УстановитьПараметр("ЗаймВыдан", Истина);
//   Должники.УстановитьПараметр("ПогашенаКомиссия", Ложь);
   Должники.УстановитьПараметр("ПогашенаОсновнаяЗадолженность", Ложь);
   Должники.УстановитьПараметр("Тек", 0);
   Должники.УстановитьПараметр("Подразделение", ЭлементыФормы.ПолеВвода1.Значение);
   ЭлементыФормы.СписокСегодняСБ.Значение = Должники.Выполнить().Выгрузить();
КонецЕсли;
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
СписокСегодняСБ это что за элемент формы?

Оффлайн sportik142

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Александр
  • Регистрация: 2015-08-10
  • Сайт: 
  • Профессия: Программист 1С
ИМя таблицы

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
В общем, я так думаю это табличное поле, смотрите событие ПриПолученииДанных как я описал выше.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Есть вот такой код программы, где тут указать оформление?

 Процедура СписокСегодняСБВыбор(Элемент, ВыбраннаяСтрока, ОформлениеСтроки, Колонка, СтандартнаяОбработка)
//   Договор = Справочники.Договоры.НайтиПоКоду(ВыбраннаяСтрока.Договор);
//   Договор.ПолучитьФорму().ОткрытьМодально();
Если СтрДлина(ВыбраннаяСтрока.Договор) = 10 Тогда
       Документ = Справочники.Договоры.НайтиПоКоду(ВыбраннаяСтрока.Договор);
      Документ.ПолучитьФорму().Открыть();
   ИначеЕсли СтрДлина(ВыбраннаяСтрока.Договор) = 12 Тогда
      Документ = Справочники.ДопСогл.НайтиПоКоду(ВыбраннаяСтрока.Договор);
      Документ.ПолучитьФорму().Открыть();
   ИначеЕсли СтрДлина(ВыбраннаяСтрока.Договор) = 11 Тогда
      Документ = Справочники.Расписки.НайтиПоКоду(ВыбраннаяСтрока.Договор);
                  Документ.ПолучитьФорму().Открыть();
            
         КонецЕсли;
КонецПроцедуры


у вас открываются формы трех разных справочников.
соответственно во все 3 надо добавить обработку события ПриПолученииДанных
по идее по какому то признаку, который как раз можно "прислать снаружи"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 272
Последний ответ 12 Окт 2017, 14:02
от wise
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1685
Последний ответ 21 Сен 2016, 08:16
от GadLex
Изменение вида "выпадающего списка"

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1224
Последний ответ 20 Май 2016, 13:26
от LexaK
Отключение кнопки "Отключить отбор" на панели формы списка документа

Автор AlterMannРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 10355
Последний ответ 13 Мар 2013, 09:41
от AlterMann
Где найти вкладку "Параметры", в конструкторе запроса при создании динамического списка?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 813
Последний ответ 09 Мар 2017, 14:48
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 138
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal