Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как обратиться к одному из реквизитов табличной части??  (Прочитано 1776 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mila1231

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Есть документ, в нём есть табличная часть, как обратиться к одному из реквизитов табличной части??
.....
вот запрос
Запрос.Текст = "ВЫБРАТЬ

                  |   Приемка_СИ.Номер,
                  |   Приемка_СИ.Приборы.(
                  |      Заводской_Номер,
                  |   )
                  |ИЗ
                  |   Документ.Приемка_СИ КАК Приемка_СИ";   
ВыборкаДанные = Запрос.Выполнить().Выбрать();
   
не могу понять, как обратиться к Заводской_номер...
т.е по сути должно быть что то под вид этого...

ОбластьДанные.Параметры.ЗавНомер_акт=ВыборкаДанный.Приборы.Заводской_Номер;
но по всей видимости я ошибаюсь, как правильно??
         
               


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
ОбластьДанные.Параметры.ЗавНомер_акт=ВыборкаДанный.Приборы.Заводской_Номер;
1. В запросе выбрать ссылку на документ
2. Прописать так:
ОбластьДанные.Параметры.ЗавНомер_акт=ВыборкаДанный.Ссылка.Приборы[0].Заводской_Номер;
т.е. берём 1-ую строку ТЧ.
3. Или делаем обход в цикле:
Для каждого СтрокаТЧ ИЗ ВыборкаДанный.Ссылка.Приборы Цикл
    ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
КонецЦикла
4. Или в запросе обратиться сразу к ТЧ Приборы и в качестве параметра указать ссылку на документ.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн mila1231

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо добавила в запрос строку

|    Приемка_СИ.ССылка,

дальше стало работать)), но не совсем так как надо...
как я поняла если мы делаем обход

Для каждого СтрокаТЧ ИЗ ВыборкаДанные.Ссылка.Приборы Цикл
        ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
КонецЦикла;

то, должны выбираться все данные, заполненные в табличном поле, т.е я имею в виду, если заполнена не одна строка, а например две, т.е два заводских номера или я не права?
Задача в том, чтоб вывести эти данные в отчёт, соответственно я делаю так:

Пока ВыборкаДанные.следующий() Цикл
      
   ОбластьШапка.Параметры.номер_акт = "№"+ номер+" "+ "от" + " " +Формат(Дата,"ДФ=""дд.ММ.гггг""");

     Для каждого СтрокаТЧ ИЗ ВыборкаДанные.Ссылка.Приборы Цикл
        ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
    КонецЦикла
      
КонецЦикла;
     
может подскажите, где ошибка??


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Использование Для каждого - обход всех строк ТЧ, сколько их бы там не было.
Для каждого СтрокаТЧ ИЗ ВыборкаДанные.Ссылка.Приборы Цикл
        ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
    ТабличныйДокумент.Вывести(ОбластьДанные);
КонецЦикла

А что конкретно нужно?
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн mila1231

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Нужно вывести данные табличной части документа в отчёт. В табличном документе может быть несколько строк (например пускай будет больше одной, т.е две)
соответственно мне эти две строки и нужно вывести в отчёт. Сама процедура счас выглядит так.


ТабДок   = новый ТабличныйДокумент;
   табДок.Очистить();


   
   Запрос = Новый запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   Приемка_СИ.Контрагент.Полное_наименование,
                  |   Приемка_СИ.Контрагент.ИНН,
                  |   Приемка_СИ.Дата,
                  |   Приемка_СИ.Номер,
               |    Приемка_СИ.ССылка,

                  |   Приемка_СИ.Приборы.(
                  |      Заводской_Номер,
                  |      Тип_СИ.Наименование,
                  |      Марка.Наименование,
                  |      ДУ.Наименование,
                  |      Год_выпуска,
                  |      Паспорт,
                  |      Предыдущее_свидетельство
                  |   )
                  |ИЗ
                  |   Документ.Приемка_СИ КАК Приемка_СИ";               
               
               
               
   ВыборкаДанные = Запрос.Выполнить().Выбрать();
   
    // получаем макет
   Макет = ПолучитьМакет ("Макет_акт");

   ОбластьШапка = макет.ПолучитьОбласть("Шапка");
   
   ОбластьЗаголовок = макет.ПолучитьОбласть("Заголовок");
   
   ОбластьДанные  = Макет.получитьОбласть ("Данные");
   
   ОбластьПодвал  = Макет.получитьОбласть ("Подвал");
   
   Пока ВыборкаДанные.следующий() Цикл
      
   ОбластьШапка.Параметры.номер_акт = "№"+ номер+" "+ "от" + " " +Формат(Дата,"ДФ=""дд.ММ.гггг""");

    Для каждого СтрокаТЧ ИЗ ВыборкаДанные.Ссылка.Приборы Цикл
        ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
    КонецЦикла;
      
КонецЦикла;
     


 //ТабДок.вывести(ОбластьДанные);
    ТабДок.вывести(ОбластьШапка );
    ТабДок.вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьДанные);

    ТабДок.Вывести(ОбластьПодвал);

    ТабДок.показать();

и в результате выводится последняя строка табличного документа.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для каждого СтрокаТЧ ИЗ ВыборкаДанные.Ссылка.Приборы Цикл
        ОбластьДанные.Параметры.ЗавНомер_акт = СтрокаТЧ.Заводской_Номер;
    ТабличныйДокумент.Вывести(ОбластьДанные);
КонецЦикла
Читать умеем или не по глазам?
Нужно добавить строку:
ТабДок.Вывести(ОбластьДанные);
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн mila1231

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
ещё раз спасибо, оно было, но не там, где надо, поэтому и не работало.


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1935
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3049
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3085
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 665
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 244
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 249
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal