Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Строки НДФЛ в ЗП 1С 8.2 СХ ИнАгро  (Прочитано 747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Ребят помогите плз решить проблему.... Расчет сделал не могу со строками разобраться.. нужно удалить(заменить)(если удалить тогда вставить новые, если заменить тогда добавить недостающие) строки в табличной части документа Начисление ЗП... сопсно вся суть в том что я делаю расчет по этой табличной части.. и когда расчет уже сделан ее либо удалить либо заменить нужно !

Функция РасчетНДФЛ()

ТабНДФЛ = НДФЛПроводки.Выгрузить();
ТабНач = НачисленияПроводки.Выгрузить();
ТабВзнос = ВзносыПроводки.Выгрузить();
ТабОтрВБУ = ОтражениеВРеглУчете.Выгрузить();
ТабНДФЛИсправленная = НДФЛПроводки.Выгрузить();

СуммаНДФЛ = 0;
СуммаНДФЛ661 = 0;
СуммаНДФЛ663 = 0;
СуммаВС661 = 0;
СуммаВС663 = 0;
СуммаВзн661     = 0;
СуммаВзн663     = 0;

СумБоль = 0;
СумНДФЛ = 0;
СумВС = 0;
СуммВзн661 = 0;
СуммВзн663 = 0;
СуммНач = 0;

    ////////////////////////Сотрудник//////////////////////////////
Для Каждого Строка из ТабНДФЛ Цикл
Отбор = Новый Структура();
Отбор.Вставить("Сотрудник", Строка.Сотрудник);
Отбор.Вставить("СчетКт", ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка);

    Строки = ТабНач.НайтиСтроки(Отбор);

Если Строки.Количество() > 1 Тогда
Работник = Строка.Сотрудник;
КонецЕсли;
КонецЦикла;
////////////////////////Сотрудник//////////////////////////////

////////////////////////Взносы/////////////////////////////////
Для Каждого Строк Из ТабВзнос цикл
Если Строк.Сотрудник = Работник И НЕ Строк.Результат = 0 и
Строк.СтатьяНалоговойДекларации.Ссылка = Справочники.СтатьиНалоговыхДеклараций.ЕСВ_Больничные.Ссылка Тогда
СумВзн663 = Строк.Результат;                                                                                                                 
СуммВзн663 = СуммВзн663 + СумВзн663;                                                                                                             
СуммаВзн663 = СуммВзн663                                                                                                        
ИначеЕсли Строк.Сотрудник = Работник И НЕ Строк.Результат = 0 и
Строк.СтатьяНалоговойДекларации.Ссылка = Справочники.СтатьиНалоговыхДеклараций.ЕСВ_Работники.Ссылка Тогда
СумВзн661 = Строк.Результат;                                                                                                                 
СуммВзн661 = СуммВзн661 + СумВзн661;                                                                                                             
СуммаВзн661 = СуммВзн661;                                                                                                                           
КонецЕсли;                                                                                                                                 
КонецЦикла;
////////////////////////Взносы/////////////////////////////////

////////////////////////Начисления Общие///////////////////////
Для Каждого Стро из ТабОтрВБУ Цикл
Если Стро.СубконтоКт1 = Работник Тогда                                                                                                 
СумНач = Стро.Сумма;                                                                                                               
СуммНач = СуммНач + СумНач;                                                                                                             
СуммаНач = СуммНач                                                                                                                     
КонецЕсли;
КонецЦикла;
////////////////////////Начисления Общие///////////////////////

////////////////////////Начисления Больничные//////////////////
Для каждого Стр из ТабНач Цикл
Если Стр.СчетКт.Ссылка =  ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка и Стр.Сотрудник = Работник Тогда
СуммБоль = Стр.Результат;
СумБоль = СумБоль + СуммБоль;
СуммаБоль = СумБоль;
КонецЕсли;
КонецЦикла;
////////////////////////Начисления Больничные//////////////////

////////////////////////НДФЛ и Военный Сбор////////////////////
Для Каждого Ст из ТабНДФЛ Цикл
Если Ст.Сотрудник = Работник Тогда
Если  НЕ Ст.ДоходНДФЛ.Ссылка = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка Тогда
СуммНДФЛ = Строка.Результат;
СумНДФЛ = СумНДФЛ + СуммНДФЛ;
СуммаНДФЛ = СумНДФЛ;
КонецЕсли;

Если  Ст.ДоходНДФЛ.Ссылка = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка Тогда
СуммВС = Строка.Результат;
СумВС = СумВС + СуммВС;
СуммаВС = СумВС;
КонецЕсли;
КонецЕсли;
КонецЦикла;
////////////////////////НДФЛ и Военный Сбор////////////////////

////////////////////////Расчет кофицента///////////////////////
Если НЕ СуммаБоль = 0 И НЕ СуммаНДФЛ = 0 И НЕ СуммаВС = 0 И
НЕ СуммаБоль = Неопределено и НЕ СуммаНДФЛ = Неопределено И НЕ СуммаВС = Неопределено Тогда

СуммаНач663    = СуммаБоль;                   //Начисления на 663 Счет
СуммаНач661    = СуммаНач - СуммаБоль;                    //Начисления на 661 Счет
СуммаНачБезВзн = СуммаНач - (СуммаВзн661 + СуммаВзн663); //Сумма начеслений без ЕСВ общая
СуммаНачБезВзн663 = СуммаНач663 - СуммаВзн663;              //Начисления на 663 Счет без ЕСВ
СуммаНачБезВзн661 = СуммаНач661 - СуммаВзн661;              //Начисления на 661 Счет без ЕСВ
ДоляБольничных = СуммаНачБезВзн663 / СуммаНачБезВзн;      //Доля больничных в полном доходе
СуммаНДФЛ661 = СуммаНДФЛ * ДоляБольничных;                       //Доля НДФЛ из общего НДФЛ на 661 Счет
СуммаНДФЛ663 = СуммаНДФЛ - СуммаНДФЛ661;                         //Доля НДФЛ из общего НДФЛ на 663 Счет
СуммаВС661 = СуммаВС * ДоляБольничных;                      //Доля ВС из общего ВС на 661 Счет
СуммаВС663 = СуммаВС - СуммаВС661;                             //Доля ВС из общего ВС на 663 Счет

КонецЕсли;
////////////////////////Расчет кофицента///////////////////////

////////////////////////Строки НДФЛ////////////////////////////
Для Каждого Строч Из ТабНДФЛИсправленная Цикл
Если Строч.Сотрудник = Работник Тогда
Отбор = Новый Структура();
Отбор.Вставить("Сотрудник", Работник);
    СтрокиНДФЛ = ТабНДФЛИсправленная.НайтиСтроки(Отбор);

Если СтрокиНДФЛ.Количество() > 0 Тогда
Индекс = ТабНДФЛИсправленная.Индекс(Строч);
ТабНДФЛИсправленная.Удалить(Индекс);
КонецЕсли;
КонецЕсли;
КонецЦикла;

Для Каждого Строч Из ТабНДФЛ Цикл
Если Строч.Сотрудник = Работник Тогда
Если СуммаНДФЛ663 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строка.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строка.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строка.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.Код01.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строка.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки          = Строка.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строка.ОбъектСтроительства;
НовСтрока.Результат              = СуммаНДФЛ663;
НовСтрока.РезультатТочный = Строка.РезультатТочный;
НовСтрока.Сотрудник            = Работник;
НовСтрока.СтатьяЗатрат = Строка.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строка.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строка.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строка.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строка.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строка.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка;
НовСтрока.СчетКт             = Строка.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строка.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строка.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаВС663 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строка.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строка.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строка.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строка.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строка.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строка.ОбъектСтроительства;
НовСтрока.Результат              = СуммаВС663;
НовСтрока.РезультатТочный = Строка.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строка.СтатьяЗатрат;
НовСтрока.СубконтоДт1            = Работник;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строка.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строка.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строка.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строка.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строка.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка;
НовСтрока.СчетКт             = Строка.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строка.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строка.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаНДФЛ661 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строка.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строка.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строка.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.Код01.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строка.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строка.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строка.ОбъектСтроительства;
НовСтрока.Результат              = СуммаНДФЛ661;
НовСтрока.РезультатТочный = Строка.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строка.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строка.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строка.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строка.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строка.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строка.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоЗаработнойПлате.Ссылка;
НовСтрока.СчетКт             = Строка.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строка.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строка.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаВС661 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строка.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строка.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строка.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строка.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строка.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строка.ОбъектСтроительства;;
НовСтрока.Результат              = СуммаВС661;
НовСтрока.РезультатТочный = Строка.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строка.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строка.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строка.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строка.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строка.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строка.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоЗаработнойПлате.Ссылка;
НовСтрока.СчетКт             = Строка.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строка.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строка.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;
КонецЕсли;
КонецЦикла;

НДФЛПроводки.Очистить();
НДФЛПроводки.Загрузить(ТабНДФЛИсправленная);

КонецФункции


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Ну так вы очищаете(удаляете), а потом загружаете.
чего не так?
или вам нужен выбор добавить или удалить?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Ну так вы очищаете(удаляете), а потом загружаете.
чего не так?
или вам нужен выбор добавить или удалить?
В частности при этом коде вообще не чего не происходит со строками кроме расчета !
Мне нужно сделать так что бы рассчитанные строки попали в таблицу НДФЛпроводки в Документе "Начисление ЗП", а старые были удалены.
Или в старых строка изменить данные на новые + добавить не достающие строки с новыми данными...

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
А. ясно
и, что, и ошибку никакую не выдает?
Добавлено: 17 Сен 2015, 02:52

Цитировать
В частности при этом коде вообще не чего не происходит со строками кроме расчета !

т.е. чтото все таки происходит?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Ну ошибки там быть на тек момент не может быть т.к. я работаю с 2мя таблицами 1 ТабНДФЛ 2 ТабНДФЛИсправленная 1ая для расчета 2ая для исправления ! обе выгрузка из НДФЛПроводки

Вот я и хочу удалить\исправить из\в ТабНДФЛИсправленная строки и загрузить из нее данные обратно в НДФЛПроводки
Добавлено: 17 Сен 2015, 02:56

На данный момент идет расчет коэффициента больничных из дохода
НДФЛна663
НДФЛна661
ВСна663
ВСна661
На основе коэффициента больничных из дохода
Добавлено: 17 Сен 2015, 02:58

То есть теперь осталось подставить данные из этих переменных в нужные строки и отобразить(выгрузить) в документ(е)


Мммм..... надо еще в цикл все это зогнать для расчета бо я что то не подумал что расчет на тек момент будет только для одного работника !=\

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
НДФЛПроводки.Очистить();
НДФЛПроводки.Загрузить(ТабНДФЛИсправленная);

Изучайте кто это. если это ссылка на ваш документобъект, то должно сработать.
только маленький нюанс. Структура в конфигураторе, и то, что отображается на форме обычно разные вещи. очень может быть, что вы забыли заполнить какойто реквизит табличной части, на основании которого, при открытии формы, ваши строки не подтягиваются.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Вот так строки дублируются.... =(
Для каждого Строч из ТабНач Цикл 
Если Строч.СчетКТ = ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка Тогда
    ////////////////////////Сотрудник//////////////////////////////
//Для Каждого Строка из ТабНДФЛ Цикл
//Отбор = Новый Структура();
//Отбор.Вставить("Сотрудник", Строка.Сотрудник);
//Отбор.Вставить("СчетКт", ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка);

    //Строки = ТабНач.НайтиСтроки(Отбор);

//Если Строки.Количество() > 1 Тогда
Работник = Строч.Сотрудник;
//КонецЕсли;
//КонецЦикла;
////////////////////////Сотрудник//////////////////////////////

////////////////////////Взносы/////////////////////////////////
Для Каждого Строк Из ТабВзнос цикл
Если Строк.Сотрудник = Работник И НЕ Строк.Результат = 0 и
Строк.СтатьяНалоговойДекларации.Ссылка = Справочники.СтатьиНалоговыхДеклараций.ЕСВ_Больничные.Ссылка Тогда
СумВзн663 = Строк.Результат;                                                                                                                 
СуммВзн663 = СуммВзн663 + СумВзн663;                                                                                                             
СуммаВзн663 = СуммВзн663                                                                                                        
ИначеЕсли Строк.Сотрудник = Работник И НЕ Строк.Результат = 0 и
Строк.СтатьяНалоговойДекларации.Ссылка = Справочники.СтатьиНалоговыхДеклараций.ЕСВ_Работники.Ссылка Тогда
СумВзн661 = Строк.Результат;                                                                                                                 
СуммВзн661 = СуммВзн661 + СумВзн661;                                                                                                             
СуммаВзн661 = СуммВзн661;                                                                                                                           
КонецЕсли;                                                                                                                                 
КонецЦикла;
////////////////////////Взносы/////////////////////////////////

////////////////////////Начисления Общие///////////////////////
Для Каждого Стро из ТабОтрВБУ Цикл
Если Стро.СубконтоКт1 = Работник Тогда                                                                                                 
СумНач = Стро.Сумма;                                                                                                               
СуммНач = СуммНач + СумНач;                                                                                                             
СуммаНач = СуммНач                                                                                                                     
КонецЕсли;
КонецЦикла;
////////////////////////Начисления Общие///////////////////////

////////////////////////Начисления Больничные//////////////////
Для каждого Стр из ТабНач Цикл
Если Стр.СчетКт.Ссылка =  ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка и Стр.Сотрудник = Работник Тогда
СуммБоль = Стр.Результат;
СумБоль = СумБоль + СуммБоль;
СуммаБоль = СумБоль;
КонецЕсли;
КонецЦикла;
////////////////////////Начисления Больничные//////////////////

////////////////////////НДФЛ и Военный Сбор////////////////////
Для Каждого Ст из ТабНДФЛ Цикл
Если Ст.Сотрудник = Работник Тогда
Если  НЕ Ст.ДоходНДФЛ.Ссылка = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка Тогда
СуммНДФЛ = Ст.Результат;
СумНДФЛ = СумНДФЛ + СуммНДФЛ;
СуммаНДФЛ = СумНДФЛ;
КонецЕсли;

Если  Ст.ДоходНДФЛ.Ссылка = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка Тогда
СуммВС = Ст.Результат;
СумВС = СумВС + СуммВС;
СуммаВС = СумВС;
КонецЕсли;
КонецЕсли;
КонецЦикла;
////////////////////////НДФЛ и Военный Сбор////////////////////

////////////////////////Расчет кофицента///////////////////////
Если НЕ СуммаБоль = 0 И НЕ СуммаНДФЛ = 0 И НЕ СуммаВС = 0 И
НЕ СуммаБоль = Неопределено и НЕ СуммаНДФЛ = Неопределено И НЕ СуммаВС = Неопределено Тогда

СуммаНач663    = СуммаБоль;                   //Начисления на 663 Счет
СуммаНач661    = СуммаНач - СуммаБоль;                    //Начисления на 661 Счет
СуммаНачБезВзн = СуммаНач - (СуммаВзн661 + СуммаВзн663); //Сумма начеслений без ЕСВ общая
СуммаНачБезВзн663 = СуммаНач663 - СуммаВзн663;              //Начисления на 663 Счет без ЕСВ
СуммаНачБезВзн661 = СуммаНач661 - СуммаВзн661;              //Начисления на 661 Счет без ЕСВ
ДоляБольничных = СуммаНачБезВзн663 / СуммаНачБезВзн;      //Доля больничных в полном доходе
СуммаНДФЛ661 = СуммаНДФЛ * ДоляБольничных;                       //Доля НДФЛ из общего НДФЛ на 661 Счет
СуммаНДФЛ663 = СуммаНДФЛ - СуммаНДФЛ661;                         //Доля НДФЛ из общего НДФЛ на 663 Счет
СуммаВС661 = СуммаВС * ДоляБольничных;                      //Доля ВС из общего ВС на 661 Счет
СуммаВС663 = СуммаВС - СуммаВС661;                             //Доля ВС из общего ВС на 663 Счет

КонецЕсли;
////////////////////////Расчет кофицента///////////////////////

////////////////////////Строки НДФЛ////////////////////////////
Для Каждого Строч Из ТабНДФЛИсправленная Цикл
Если Строч.Сотрудник = Работник Тогда
Отбор = Новый Структура();
Отбор.Вставить("Сотрудник", Работник);
    СтрокиНДФЛ = ТабНДФЛИсправленная.НайтиСтроки(Отбор);

Если СтрокиНДФЛ.Количество() > 0 Тогда
Индекс = ТабНДФЛИсправленная.Индекс(Строч);
ТабНДФЛИсправленная.Удалить(Индекс);
КонецЕсли;
КонецЕсли;
КонецЦикла;

Для Каждого Строч Из ТабНДФЛ Цикл
Если Строч.Сотрудник = Работник Тогда
Если СуммаНДФЛ663 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строч.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строч.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строч.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.Код01.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строч.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки          = Строч.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строч.ОбъектСтроительства;
НовСтрока.Результат              = СуммаНДФЛ663;
НовСтрока.РезультатТочный = Строч.РезультатТочный;
НовСтрока.Сотрудник            = Работник;
НовСтрока.СтатьяЗатрат = Строч.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строч.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строч.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строч.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строч.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строч.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка;
НовСтрока.СчетКт             = Строч.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строч.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строч.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаВС663 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строч.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строч.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строч.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строч.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строч.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строч.ОбъектСтроительства;
НовСтрока.Результат              = СуммаВС663;
НовСтрока.РезультатТочный = Строч.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строч.СтатьяЗатрат;
НовСтрока.СубконтоДт1            = Работник;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строч.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строч.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строч.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строч.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строч.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоДругимВыплатам.Ссылка;
НовСтрока.СчетКт             = Строч.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строч.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строч.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаНДФЛ661 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строч.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строч.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строч.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.Код01.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строч.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строч.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строч.ОбъектСтроительства;
НовСтрока.Результат              = СуммаНДФЛ661;
НовСтрока.РезультатТочный = Строч.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строч.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строч.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строч.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строч.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строч.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строч.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоЗаработнойПлате.Ссылка;
НовСтрока.СчетКт             = Строч.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строч.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строч.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;

Если СуммаВС661 > 0 Тогда
НовСтрока = ТабНДФЛИсправленная.Добавить();
НовСтрока.БазаВзноса            = Строч.БазаВзноса;
НовСтрока.БазовыйПериодНачало = Строч.БазовыйПериодНачало;
НовСтрока.ВидРасчетаБазы        = Строч.ВидРасчетаБазы;
НовСтрока.ДоходНДФЛ              = Справочники.ВидыДоходовНДФЛ.ВоенныйСбор.Ссылка;
НовСтрока.НоменклатурнаяГруппа = Строч.НоменклатурнаяГруппа;
НовСтрока.НомерСтроки            = Строч.НомерСтроки;
НовСтрока.ОбъектСтроительства = Строч.ОбъектСтроительства;;
НовСтрока.Результат              = СуммаВС661;
НовСтрока.РезультатТочный = Строч.РезультатТочный;
НовСтрока.Сотрудник              = Работник;
НовСтрока.СтатьяЗатрат = Строч.СтатьяЗатрат;
НовСтрока.СубконтоДт1          = Работник;
НовСтрока.СубконтоДт2            = Строч.СубконтоДт2;
НовСтрока.СубконтоДт3            = Строч.СубконтоДт3;
НовСтрока.СубконтоКт1            = Строч.СубконтоКт1;
НовСтрока.СубконтоКт2            = Строч.СубконтоКт2;
НовСтрока.СубконтоКт3            = Строч.СубконтоКт3;
НовСтрока.СчетДт                = ПланыСчетов.Хозрасчетный.РасчетыПоЗаработнойПлате.Ссылка;
НовСтрока.СчетКт             = Строч.СчетКт;
НовСтрока.УдалитьВидВзаиморасчетов = Строч.УдалитьВидВзаиморасчетов;
НовСтрока.УдалитьНалоговоеНазначениеДоходовИЗатрат = Строч.УдалитьНалоговоеНазначениеДоходовИЗатрат;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
Добавлено: 18 Сен 2015, 20:00

Всем спс... решил свою проблему кардинально поменяв систему расчета =)

Последний раз редактировалось: EritikWoW; 18 Сен 2015, 20:00. Причина: Объединение сообщений


Теги:
 

В декабре 2015 весь НДФЛ отсторнировался за весь 2015 год по всем сотрудникам.

Автор Светлана СкворцоваРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1964
Последний ответ 19 Апр 2016, 14:33
от Светлана Скворцова
Не подтягивается Ставка налогообложения "Основная" в табличной части расчета НДФЛ в документе Начисление зарплаты работникам организаций

Автор bombatРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2975
Последний ответ 11 Июн 2014, 07:05
от Alex56
Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2065
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
"Дистанционный" работник и уплата НДФЛ

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 2625
Последний ответ 20 Сен 2015, 20:56
от topics
Перерасчет НДФЛ в документе "начисление з.п"

Автор lonselotРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1498
Последний ответ 22 Авг 2016, 16:14
от lonselot

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal