Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 16:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вгрузить данные в Анализ данных  (Прочитано 9127 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн utkin295

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-03
  • Сайт: 
  • Профессия: Программист 1С
Есть такой вопрос. Имеется учебная задача - получить список документов в виде какой-либо таблицы, например, дата, номер.
Я сделал так:
1. Создал обработку
2. На форме обработки кинул реквизит - Динамический список.
3. Для Динамического списка (назовем его Реквизит1)сделал произвольный запрос, откуда из нужных мне документов я выбираю Номер (документа) и Дату. Все чудесно работает и при открытии формы обработки эти данные появляются.
4. Создал кнопку Анализ
5. Прицепил на нее команду Анализ.
6. Для команды повесил процедуру Анализ
7. Пытаюсь теперь в созданный (Новый АнализДанных) АнализДанных прикрепить свой источник данных - ТабличнуюЧасть (визуальное отображение Реквизит1). И тут получаю беду - Несоответствие типов. Я понимаю, что ему надо что-то вроде ТаблицыЗначений.
В связи с этим возникает вопрос - Как преобразовать таблицу так, чтобы АнализДанных съел его? Либо как пересоздать ТаблицуЗначений и вгружать туда данные при открытии формы? Проблема в первом случае - я не умею преобразовывать один объект в другой. Проблема во втором случае - я не могу вгрузить результат запроса в ТаблицуЗначений. Потому как наКлиенте нельзя, а наСервере тупо игнорит.

ЗЫ. 1с 8.2


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте "ТабличнаяЧасть.Выгрузить()".
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн utkin295

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-03
  • Сайт: 
  • Профессия: Программист 1С
Пишет - "Не определен тип данных"

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
А тип анализа вы определили?
Добавлено: 16 Сен 2015, 15:07

Например
Анализ = Новый АнализДанных;
Анализ.ТипАнализа = Тип("АнализДанныхОбщаяСтатистика");
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн utkin295

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-03
  • Сайт: 
  • Профессия: Программист 1С
Да там все также. Потом:
МойАнализДанных.ИсточникДанных  = ЭтаФорма.ТабличнаяЧасть1;
Ну и в разных вариациях :D Проблема в том что если к примеру я нашел, что нужно ИсточникуДанных, то есть типы в СинтаксисПомощнике есть, то что такое ТабличнаяЧасть я оперативно отследить не могу и молчу уже о всем том, что он своими методами выгружает.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
приведи код.
По идее эта строчка должна выглядеть так МойАнализДанных.ИсточникДанных  = ЭтаФорма.ТабличнаяЧасть1.Выгрузить();
Добавлено: 16 Сен 2015, 16:22

и какой тип анализа используешь
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн utkin295

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-03
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Анализ(Команда)                                                 

МойАнализДанных = Новый АнализДанных;
МойАнализДанных.ТипАнализа=Тип ("АнализДанныхОбщаяСтатистика");
//МойАнализДанных.ИсточникДанных = ЭлементыФормы.ТабличноеПоле1.Значение;
//МойАнализДанных.ИсточникДанных = ЭтаФорма.Элементы.ТабличнаяЧасть1.ПодчиненныеЭлементы.Дата;
МойАнализДанных.ИсточникДанных = ЭтаФорма.ТабличнаяЧасть1.Выгрузить();
РезультатАнализаДанных = МойАнализДанных.Выполнить();
Построитель = Новый ПостроительОтчетаАнализаДанных();
Построитель.Макет = Неопределено;
Построитель.ТипАнализа = Тип ("АнализДанныхОбщаяСтатистика");
ТабДок = Новый ТабличныйДокумент;
Построитель.Вывести(РезультатАнализаДанных, ТабДок);
ТабДок.Показать();

КонецПроцедуры
Как-то так.
Результат:
Цитировать
{Обработка.АнализДанных.Форма.Форма.Форма(4,26)}: Тип не определен (АнализДанных)
   МойАнализДанных = Новый <<?>>АнализДанных;
{Обработка.АнализДанных.Форма.Форма.Форма(10,22)}: Тип не определен (ПостроительОтчетаАнализаДанных)
   Построитель = Новый <<?>>ПостроительОтчетаАнализаДанных();

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Анализ(Команда)                                                       
   
    ПолучитьТабДок().Показать();

КонецПроцедуры

&НаСервере
Функция ПолучитьТабДок()

    МойАнализДанных = Новый АнализДанных;
    МойАнализДанных.ТипАнализа=Тип ("АнализДанныхОбщаяСтатистика");
    ДанныеОбъект = РеквизитФормыВЗначение("Объект");
    МойАнализДанных.ИсточникДанных = ДанныеОбъект.ТабличнаяЧасть1.Выгрузить();
    РезультатАнализаДанных = МойАнализДанных.Выполнить();
    Построитель = Новый ПостроительОтчетаАнализаДанных();
    Построитель.Макет = Неопределено;
    Построитель.ТипАнализа = Тип ("АнализДанныхОбщаяСтатистика");
    ТабДок = Новый ТабличныйДокумент;
    Построитель.Вывести(РезультатАнализаДанных, ТабДок);
    Возврат ТабДок;   

КонецФункции
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн utkin295

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-03
  • Сайт: 
  • Профессия: Программист 1С
Взлетело! Но это не решение, а готовый ответ. Объясните мне пожалста почему надо именно так? Очень нада самому разобраться. Препод сам на замене и ему пофиг, а мне хочется понять за что я убил полдня.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Объект анализ данных работает только на сервере, читайте внимательно справку, там написано где работает тот или иной объект.
Добавлено: 16 Сен 2015, 18:33

А где счас учат 1С если не секрет?
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7432
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3881
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2112
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7322
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Как перенести конфу базы данных на новую конфу?

Автор dim3740Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 11247
Последний ответ 23 Авг 2010, 15:41
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 850
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal