Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма ПКО\РКО  (Прочитано 1150 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!
УТ 11.1.10
Пытаюсь сделать внешнюю печатную форму к документу "Отчет о розничных продажах"
Хочу выводить все ПКО и РКО за день в ТД
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
     Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПФ_MXL_ЛистКассовойКниги") Тогда
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,
                     "ПФ_MXL_ЛистКассовойКниги", "ПФ_MXL_ЛистКассовойКниги",
                     СформироватьПечатнуюФорму("Бланк лист кассовой книги", МассивОбъектов, ОбъектыПечати));
     КонецЕсли;
КонецПроцедуры

Функция СформироватьПечатнуюФорму(Тип, МассивОбъектов, ОбъектыПечати)

УстановитьПривилегированныйРежим(Истина);
ТабДок = Новый ТабличныйДокумент;
Ссылка = Документы.ЛистКассовойКниги;

Макет = ПолучитьМакет("ПФ_MXL_ЛистКассовойКниги");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЛистКассовойКниги.КоличествоДокументовНаЛисте,
| ЛистКассовойКниги.СуммаВыдачи,
| ЛистКассовойКниги.СуммаПоступления,
| ЛистКассовойКниги.КассовыеОрдера.(
| НомерСтроки,
| Документ,
| Приход,
| Расход
| )
|ИЗ
| Документ.ЛистКассовойКниги КАК ЛистКассовойКниги
|ГДЕ
| ЛистКассовойКниги.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьКассовыеОрдераШапка = Макет.ПолучитьОбласть("КассовыеОрдераШапка");
ОбластьКассовыеОрдера = Макет.ПолучитьОбласть("КассовыеОрдера");
Подвал = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

ТабДок.Вывести(ОбластьКассовыеОрдераШапка);
ВыборкаКассовыеОрдера = Выборка.КассовыеОрдера.Выбрать();
Пока ВыборкаКассовыеОрдера.Следующий() Цикл
ОбластьКассовыеОрдера.Параметры.Заполнить(ВыборкаКассовыеОрдера);
ТабДок.Вывести(ОбластьКассовыеОрдера, ВыборкаКассовыеОрдера.Уровень());
КонецЦикла;

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;

КонецФункции
Выдает ошибку
{ВнешняяОбработка.ВнешняяПечатнаяКМ6.МодульОбъекта(72)}: Ошибка при вызове метода контекста (Выполнить)
Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(14, 30)}: Неверные параметры
ЛистКассовойКниги.Ссылка В (<<?>>&Ссылка)

И вообще может я не оттуда делаю запрос?
Подскажите пожалуйста как правильно сделать.


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ошибка тут
Ссылка = Документы.ЛистКассовойКниги;
Ссылка - это указатель на конкретный документ.
Документы.ЛистКассовойКниги - это менеджер документа


Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Может тогда так сделать?
|ГДЕ
| ДокументКассоваяКнига.Ссылка В(&МассивДокументов)
| И ДокументКассоваяКнига.Проведен
|
|УПОРЯДОЧИТЬ ПО
| Дата,
| Ссылка";

Запрос.УстановитьПараметр("МассивДокументов", МассивОбъектов);

Ммм.Так тоже не работает,что то запутался совсем =\

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Наверное так

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(237)}: В обработчике печати не был сформирован табличный документ для: ПФ_MXL_ЛистКассовойКниги
ВызватьИсключение(ТекстСообщенияОбОшибке);

// Проверим, все ли макеты были сформированы.
Для Каждого Стр Из КоллекцияПечатныхФорм Цикл
Если Стр.ТабличныйДокумент = Неопределено Тогда
ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
Стр.ИмяМакета);
ВызватьИсключение(ТекстСообщенияОбОшибке);
КонецЕсли;

Стр.ТабличныйДокумент.КоличествоЭкземпляров = Стр.Экземпляров;
КонецЦикла;


Теги:
 

Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4664
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 346
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4364
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6388
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Шаблон или Форма для заполнения "заказа покупателя"

Автор SandrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6597
Последний ответ 02 Сен 2013, 14:22
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 276
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal