Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Передать параметр на &Сервер  (Прочитано 1544 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Добрый день всем! Пишу запрос в управляемых формах УТ 11 8,3 и не могу никак передать параметр Запрос.УстановитьПараметр("Номенклатура",Номенклатура) в запрос. Подскажите пожалуйста как это сделать?
&НаКлиенте
Процедура ПолучитьПоследнююЦенуПродажиТовара(Элемент)
ЦенаРезультат = 0;
ПолучитьПоследнююЦенуПродажиТовараСервер(ЦенаРезультат);
КонецПроцедуры

&НаСервере
Функция ПолучитьПоследнююЦенуПродажиТовараСервер(Номенклатура) Экспорт

ЦенаРезультат = 0;
ТекстЗапроса =
"ВЫБРАТЬ ПЕРВЫЕ 1
|    РеализацияТоваровУслуг.Ссылка.Дата КАК Дата,
|    МАКСИМУМ(РеализацияТоваровУслуг.Цена) КАК Цена
|ИЗ
|    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
|ГДЕ
|    РеализацияТоваровУслуг.Номенклатура = &Номенклатура
|    И РеализацияТоваровУслуг.Ссылка.Проведен
|
|СГРУППИРОВАТЬ ПО
|    РеализацияТоваровУслуг.Ссылка.Дата
|
|УПОРЯДОЧИТЬ ПО
|    Дата УБЫВ";

Запрос = Новый Запрос;
Запрос.Текст = ТекстЗапроса;
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ЦенаРезультат = Выборка.Цена;
КонецЦикла;

Возврат ЦенаРезультат;

КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Номенклатура - это что?

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Номенклатура это СправочникСсылка.Номенклатура при выборе в документе поступление товаров и услуг

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура);

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ПолучитьПоследнююЦенуПродажиТовара(Элемент)
    ЦенаРезультат = ПолучитьПоследнююЦенуПродажиТовараСервер(Объект.Номенклатура);
КонецПроцедуры

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура);
Все равно ничего не выводится, такое ощущение что все таки не передается в запрос номенклатура

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Зачем вам ощущения, у вас есть отладчик.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура); Здесь данные есть, а в самом запросе Запрос.УстановитьПараметр("Номенклатура",Номенклатура); пусто.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте так:
Функция ПолучитьПоследнююЦенуПродажиТовараСервер(ПараметрНоменклатура) Экспорт
....
Запрос.УстановитьПараметр("Номенклатура",ПараметрНоменклатура);

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7


Теги:
 

ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6116
Последний ответ 06 Июн 2012, 09:15
от lindelu
Регламентные задания "Недопустимое значение параметра (параметр номер "1")

Автор pyvfРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 17257
Последний ответ 27 Фев 2013, 11:57
от reshkra
Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 970
Последний ответ 01 Мар 2016, 14:33
от sveta C
Адресный классификатор в 1С Сервер: Расчет квартплаты. Базовая версия

Автор СовёнокРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1936
Последний ответ 09 Сен 2011, 14:19
от Совёнок
Как отправить из файловой базы на sql/pgsql сервер некоторые данные

Автор cartorysРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 819
Последний ответ 06 Дек 2016, 13:23
от Oldman06

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
55 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal