Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 19:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Передать параметр на &Сервер  (Прочитано 1902 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Добрый день всем! Пишу запрос в управляемых формах УТ 11 8,3 и не могу никак передать параметр Запрос.УстановитьПараметр("Номенклатура",Номенклатура) в запрос. Подскажите пожалуйста как это сделать?
&НаКлиенте
Процедура ПолучитьПоследнююЦенуПродажиТовара(Элемент)
ЦенаРезультат = 0;
ПолучитьПоследнююЦенуПродажиТовараСервер(ЦенаРезультат);
КонецПроцедуры

&НаСервере
Функция ПолучитьПоследнююЦенуПродажиТовараСервер(Номенклатура) Экспорт

ЦенаРезультат = 0;
ТекстЗапроса =
"ВЫБРАТЬ ПЕРВЫЕ 1
|    РеализацияТоваровУслуг.Ссылка.Дата КАК Дата,
|    МАКСИМУМ(РеализацияТоваровУслуг.Цена) КАК Цена
|ИЗ
|    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
|ГДЕ
|    РеализацияТоваровУслуг.Номенклатура = &Номенклатура
|    И РеализацияТоваровУслуг.Ссылка.Проведен
|
|СГРУППИРОВАТЬ ПО
|    РеализацияТоваровУслуг.Ссылка.Дата
|
|УПОРЯДОЧИТЬ ПО
|    Дата УБЫВ";

Запрос = Новый Запрос;
Запрос.Текст = ТекстЗапроса;
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ЦенаРезультат = Выборка.Цена;
КонецЦикла;

Возврат ЦенаРезультат;

КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Номенклатура - это что?

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Номенклатура это СправочникСсылка.Номенклатура при выборе в документе поступление товаров и услуг

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура);

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ПолучитьПоследнююЦенуПродажиТовара(Элемент)
    ЦенаРезультат = ПолучитьПоследнююЦенуПродажиТовараСервер(Объект.Номенклатура);
КонецПроцедуры

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура);
Все равно ничего не выводится, такое ощущение что все таки не передается в запрос номенклатура

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Зачем вам ощущения, у вас есть отладчик.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
ПолучитьПоследнююЦенуПродажиТовараСервер(Элементы.Товары.ТекущиеДанные.Номенклатура); Здесь данные есть, а в самом запросе Запрос.УстановитьПараметр("Номенклатура",Номенклатура); пусто.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте так:
Функция ПолучитьПоследнююЦенуПродажиТовараСервер(ПараметрНоменклатура) Экспорт
....
Запрос.УстановитьПараметр("Номенклатура",ПараметрНоменклатура);

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7


Теги:
 

1с 8.2 Тонкий клиент. Клиент-сервер. Как убрать лишнее?

Автор ROG DominatorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 313
Последний ответ 20 Фев 2018, 13:02
от ROG Dominator
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6801
Последний ответ 06 Июн 2012, 09:15
от lindelu
Регламентные задания "Недопустимое значение параметра (параметр номер "1")

Автор pyvfРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 18606
Последний ответ 27 Фев 2013, 11:57
от reshkra
Обмен данными между мобильным приложением и основным через прокси сервер

Автор Евгений НеханьРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 628
Последний ответ 23 Янв 2018, 13:01
от Евгений Нехань
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 154
Последний ответ 10 Апр 2018, 14:00
от Св Ч

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений

* Кто онлайн

  • Точка Гостей: 328
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal