Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 15:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: РКО печать чека  (Прочитано 2269 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! УТ 11.1.10.167
Столкнулся с интересной ситуацией в УТ 11.1 в РКО есть
&НаСервере
Процедура УстановитьДоступностьПечатиЧека()

НапечататьЧекДоступность = Ложь;

Кнопка = Элементы.Найти("НапечататьЧек");
Если Кнопка <> Неопределено Тогда
Если Объект.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ВозвратОплатыКлиенту Тогда
НапечататьЧекДоступность = Истина;
КонецЕсли;
Кнопка.Доступность = НапечататьЧекДоступность;
КонецЕсли;

КонецПроцедуры

Получается что я не могу напечатать чек на ККМ если только я не делаю возврат оплаты клиенту,но,что если мне надо сделать скажем прочую выдачу или оплату поставщику,почему я не могу это провести по кассе и выдать деньги из кассы ?
Приходится писать РКО на бумажках и делать выемки...


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: РКО печать чека
« Ответ #1: 10 Сен 2015, 11:31 »
Это розничная торговля. Из кассы ККМ вы не можете выдать деньги не пойми куда. Из ККМ отправляете в основную кассу, и только из основной кассы выдаете куда угодно.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: РКО печать чека
« Ответ #2: 10 Сен 2015, 13:24 »
Со 2-й части можно пожалуйста подробней?
Каким документом отправлять?
Почему тогда вообще эта кнопка видима если применяется только для возврата в розницу ?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: РКО печать чека
« Ответ #3: 10 Сен 2015, 13:46 »
Чек - это подтверждение факта оплаты или возврата в розничной торговле. Чек, грубо говоря, предназначен для печати на фискальном регистраторе, что в свою очередь определяет размер налогообложения. Касса ККМ предназначена только для операции продажи/возврата в розничной торговле. Тем не мение, возможны ситуации, когда происходит возврат оплаты покупателю, без возврата товара (порченный товар).
Никакие другие операции кроме не фиксируются ФР.
Хотите выдать деньги - оформляйте обычный РКО и печатайте его. По-другому = никак.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: РКО печать чека
« Ответ #4: 10 Сен 2015, 14:56 »
Ну вообще логично конечно,получается мне надо делать РКО что бы отразить в 1С скажем выплату поставщику или еще что-то, и делать из РМК "Выемка" если мне надо из кассы выплатить деньги ,так я понимаю?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: РКО печать чека
« Ответ #5: 10 Сен 2015, 15:50 »
делать из РМК "Выемка"
Это так называемая "инкасация". Передача денег из кассы ККМ в обычную кассу. А из обычной кассы посредством РКО можете выполнить любую операцию выдачи денег, хоть оплату поставщику, хоть прочее списание.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: РКО печать чека
« Ответ #6: 10 Сен 2015, 16:41 »
Все ясно,благодарю за разжеванные ответы, вроде бы докупался до сути.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal