Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 17:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: метод записать  (Прочитано 433 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн joystas

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-13
  • Сайт: 
  • Профессия: Программист 1С
добрый день! при переходе с 8,2 на 8,3 перестал работать отчет. Выдает ошибку :{Форма.Форма.Форма(340)}: Ошибка при вызове метода контекста (Записать)
   ДвиженияУпр2.Записать();
по причине:
Запись не верна! Поле "Количество" должно быть пустым! (Регистр бухгалтерии: Управленческий 2; Номер строки: 1)

вот текст:Процедура ВыполнитьФормированиеПлан()
       //Состояние("Выборка данных (план)...");
   Запр = Новый Запрос;
   Запр.Текст =
   "ВЫБРАТЬ
   |   осиПЭОПриказ1.Наименование КАК НоменклатураПЭО,
   |   осиПЭОПриказ1.Количество * осиПЭОПриказ1.Цена * 1000 КАК Сумма,
   |   осиПЭОПриказ1.Подразделение КАК ПодразделениеПЭО,
   |   ВЫБОР
   |      КОГДА осиПЭОПриказ1.Пассив = &Строительство
   |         ТОГДА &Счет106
   |      КОГДА осиПЭОПриказ1.Пассив = &Приобретение
   |         ТОГДА &Счет107
   |      КОГДА осиПЭОПриказ1.Пассив = &ИнвестПроекты
   |         ТОГДА &Счет108
   |   КОНЕЦ КАК СчетПЭО,
   |   ВЫБОР
   |      КОГДА осиПЭОПриказ1.Пассив = &Строительство
   |         ТОГДА NULL
   |      ИНАЧЕ осиПЭОПриказ1.Количество
   |   КОНЕЦ КАК Количество
   |ИЗ
   |   РегистрСведений.осиПЭОПриказ1 КАК осиПЭОПриказ1
   |ГДЕ
   |   осиПЭОПриказ1.Период МЕЖДУ &НачДата И &КонДата
   |   И (осиПЭОПриказ1.Пассив = &Приобретение
   |         ИЛИ осиПЭОПриказ1.Пассив = &Строительство ИЛИ осиПЭОПриказ1.Пассив = &ИнвестПроекты)
   |   И осиПЭОПриказ1.Приоритет = 0";
   Запр.УстановитьПараметр("НачДата", НачалоМесяца(Объект.ЗаПериод));
   Запр.УстановитьПараметр("КонДата", КонецМесяца(Объект.ЗаПериод));
   Запр.УстановитьПараметр("Приобретение", ПолучитьЭлементСправочникаПоРеквизиту("осиПЭОПассив", "Наименование", "_Приобретение оборудования"));
   Запр.УстановитьПараметр("Строительство", ПолучитьЭлементСправочникаПоРеквизиту("осиПЭОПассив", "Наименование", "Капитальное строительство"));
   Запр.УстановитьПараметр("ИнвестПроекты", ПолучитьЭлементСправочникаПоРеквизиту("осиПЭОПассив", "Наименование", "_Инвестиционные проекты"));
   Запр.УстановитьПараметр("Счет106", ПолучитьЭлемент("ПланСчетов", "Инт_Управленческий2", "Код", "106"));
   Запр.УстановитьПараметр("Счет107", ПолучитьЭлемент("ПланСчетов", "Инт_Управленческий2", "Код", "107"));
   Запр.УстановитьПараметр("Счет108", ПолучитьЭлемент("ПланСчетов", "Инт_Управленческий2", "Код", "108"));
   
   ТЗ=Запр.Выполнить().Выгрузить();

   Выборка = Запр.Выполнить().Выбрать();
   
   
   //Состояние("Формирование проводок (план)...");
   Сценарий = ПолучитьЭлемент("Справочник", "Инт_Сценарии", "Наименование", "План");
   
   ЦФО = ПолучитьЭлемент("Справочник", "Инт_ЦФО", "Наименование", "ЦЗ ""Оренбургские минералы""");
   ВидСубконтоНоменклатураПЭО = ПолучитьЭлемент("ПланВидовХарактеристик", "ИНТ_Аналитика", "Код", "00000000042");//Номенклатура ПЭО
   ВидСубконтоПодразделенияПЭО = ПолучитьЭлемент("ПланВидовХарактеристик", "ИНТ_Аналитика", "Код", "00000000053");//Подразделения ПЭО
   
   Счет00 = ПолучитьЭлемент("ПланСчетов", "Инт_Управленческий2", "Код", "0");
   
   Проформа = ПолучитьПроформу(Сценарий).ПолучитьОбъект();
   ДвиженияУпр2 = Проформа.Движения.Инт_Управленческий2;
    ДвиженияУпр2.Очистить();
   
   Пока Выборка.Следующий() Цикл
      Проводка = ДвиженияУпр2.Добавить();
      Проводка.Период = КонецМесяца(Объект.ЗаПериод);
      Проводка.Содержание = "авт.загр.";
      Проводка.СчетДт = Выборка.СчетПЭО;
      Проводка.СчетКт = Счет00;
      Проводка.Сценарий = Сценарий;
      Проводка.Сумма = Выборка.Сумма;
      Проводка.ЦФОДт = ЦФО;
      Если Выборка.Количество<> 0  Тогда
         Проводка.КоличествоДт = Выборка.Количество;
      КонецЕсли;
            
      Проводка.Субконто1Дт= Выборка.НоменклатураПЭО;
      Проводка.Субконто2Дт = Выборка.ПодразделениеПЭО;                
   КонецЦикла;
   
   ДвиженияУпр2.Записать();
         //Состояние();
   
КонецПроцедуры


начал писать меньше месяца назад, помогите чем можете


Теги:
 

Удаление помеченных объектов ("Не удалось записать "Контактная информация"")

Автор SnakeyРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 6956
Последний ответ 08 Янв 2015, 09:15
от Sanario
Кнопка "Записать"

Автор ВоительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 9160
Последний ответ 18 Ноя 2011, 17:00
от sergejK74
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 281
Последний ответ 21 Сен 2017, 10:33
от Insider
Метод "ВыбратьЭлемент"

Автор GunnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1750
Последний ответ 24 Ноя 2015, 11:29
от Kironten
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3425
Последний ответ 06 Окт 2014, 15:23
от jenya1111

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 655
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal