Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 02:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: контроль глубины кредита  (Прочитано 851 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlaMaRit

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-05
  • Сайт: 
  • Профессия: Программист 7.7
//*******************************************
Процедура Сформировать()
   Спр=СоздатьОбъект("СправочникСонтрагенты");
   Дог=СоздатьОбъект ("СправочникДоговоры");
   Спр.ВыбратьЭлементы();
   Пока Спр=("ПолучитьЭлемент")
    Цикл Дог.ИспользоватьВладельца(Спр.ТекущийЭлемент);
   Дог.ВыбратьЭлементы();
   Пока Дог.ПолучитьЭлемент(1)
   Дог.ГлубинаКредита=14;
   Дог.Записать()
   КонецЦикла      

КонецПроцедуры

 вот такая процедура, сохраняю, открываю и мне выдаёт такую ошибку:
<<?>>Дог.ГлубинаКредита=14;
{C:\USERS\ADMIN\DESKTOP\123.ERT(10)}: Выражение должно иметь логический тип

что должно стоять вместо знака вопроса?, где я допустил ошибку?, прошу показать наглядно знающих


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Что за бред написан? Вы понимаете, что Вы пишите вообще?
Спр=СоздатьОбъект("СправочникСонтрагенты");
Дог=СоздатьОбъект ("СправочникДоговоры");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
   Дог.ИспользоватьВладельца(Спр.ТекущийЭлемент());
   Дог.ВыбратьЭлементы();
   Пока Дог.ПолучитьЭлемент() = 1 Цикл
      Дог.ГлубинаКредита=14;
      Дог.Записать() ;
   КонецЦикла;
КонецЦикла

Оффлайн AlaMaRit

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-05
  • Сайт: 
  • Профессия: Программист 7.7
тема закрыта, всем спасибо


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
Orion
12 Сообщений

* Кто онлайн

  • Точка Гостей: 201
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal